summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-11-03 01:20:20 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-11-03 01:20:20 +0000
commit6807735391f03f2de6db8a8b759c3c1f87f9bc37 (patch)
tree3e05d79af16fafe830df3ce8331aeedfb422ba17 /sci-misc
parentversion bump (diff)
downloadgentoo-2-6807735391f03f2de6db8a8b759c3c1f87f9bc37.tar.gz
gentoo-2-6807735391f03f2de6db8a8b759c3c1f87f9bc37.tar.bz2
gentoo-2-6807735391f03f2de6db8a8b759c3c1f87f9bc37.zip
Removed append-ldflags -lstdc++, bug #226919. Fixed -fPIC issue, bug #240366.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/tinysvm/ChangeLog11
-rw-r--r--sci-misc/tinysvm/files/tinysvm-0.09-r2-pm.patch16
-rw-r--r--sci-misc/tinysvm/tinysvm-0.09-r2.ebuild80
3 files changed, 105 insertions, 2 deletions
diff --git a/sci-misc/tinysvm/ChangeLog b/sci-misc/tinysvm/ChangeLog
index 6564ba8d5625..5042a17cd44b 100644
--- a/sci-misc/tinysvm/ChangeLog
+++ b/sci-misc/tinysvm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-misc/tinysvm
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/tinysvm/ChangeLog,v 1.5 2007/12/25 17:14:41 phreak Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/tinysvm/ChangeLog,v 1.6 2008/11/03 01:20:20 matsuu Exp $
+
+*tinysvm-0.09-r2 (03 Nov 2008)
+
+ 03 Nov 2008; MATSUU Takuto <matsuu@gentoo.org>
+ +files/tinysvm-0.09-r2-pm.patch, +tinysvm-0.09-r2.ebuild:
+ Removed append-ldflags -lstdc++, bug #226919. Fixed -fPIC issue, bug
+ #240366.
25 Dec 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing usata from metadata.xml as per #22931.
diff --git a/sci-misc/tinysvm/files/tinysvm-0.09-r2-pm.patch b/sci-misc/tinysvm/files/tinysvm-0.09-r2-pm.patch
new file mode 100644
index 000000000000..105f4efe3747
--- /dev/null
+++ b/sci-misc/tinysvm/files/tinysvm-0.09-r2-pm.patch
@@ -0,0 +1,16 @@
+diff -Naur TinySVM-0.09.orig/perl/Makefile.PL.in TinySVM-0.09/perl/Makefile.PL.in
+--- TinySVM-0.09.orig/perl/Makefile.PL.in 2001-08-29 23:56:31.000000000 +0900
++++ TinySVM-0.09/perl/Makefile.PL.in 2008-11-03 09:47:48.000000000 +0900
+@@ -3,8 +3,9 @@
+ # the contents of the Makefile that is written.
+ WriteMakefile(
+ 'CC' => '@CXX@',
++ 'LD' => '@CXX@',
+ 'NAME' => 'TinySVM',
+- 'INC' => '-I@prefix@/include',
+- 'LIBS' => '-L@prefix@/lib -ltinysvm',
+- 'OBJECT' => 'TinySVM_wrap.o'
++ 'INC' => '-I../src -I@includedir@',
++ 'LIBS' => '-L../src/.libs -L@libdir@ -ltinysvm',
++ 'OBJECT' => 'TinySVM_wrap.o'
+ );
diff --git a/sci-misc/tinysvm/tinysvm-0.09-r2.ebuild b/sci-misc/tinysvm/tinysvm-0.09-r2.ebuild
new file mode 100644
index 000000000000..13c0274346bf
--- /dev/null
+++ b/sci-misc/tinysvm/tinysvm-0.09-r2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/tinysvm/tinysvm-0.09-r2.ebuild,v 1.1 2008/11/03 01:20:20 matsuu Exp $
+
+inherit eutils perl-module toolchain-funcs
+
+MY_P="TinySVM-${PV}"
+DESCRIPTION="TinySVM is an implementation of Support Vector Machines (SVMs) for
+pattern recognition."
+HOMEPAGE="http://chasen.org/~taku/software/TinySVM/"
+SRC_URI="http://chasen.org/~taku/software/TinySVM/src/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+#IUSE="java perl python ruby"
+IUSE="perl"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PF}-pm.patch"
+ ln -s . src/TinySVM
+}
+
+src_compile() {
+ tc-export CC CXX
+
+ econf || die
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" || die
+ if use perl ; then
+ (
+ cd perl
+ perl-module_src_compile || die "compile failed in perl"
+ )
+ fi
+ ## currently it fails to compile under python-2.4
+ #if use python ; then
+ # (
+ # cd python
+ # emake -f Makefile.pre.in boot || die "compile failed in python"
+ # emake || die
+ # )
+ #fi
+ ## currently it fails to compile under gcc-3.4
+ #if use ruby ; then
+ # (
+ # cd ruby
+ # ruby extconf.rb || die
+ # emake || die
+ # )
+ #fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS README THANKS
+
+ if use perl ; then
+ (
+ cd perl
+ perl-module_src_install || die "install failed in perl"
+ )
+ fi
+ #if use python ; then
+ # (
+ # cd python
+ # emake DESTDIR="${D}" install || die "install failed in python"
+ # )
+ #fi
+ #if use ruby ; then
+ # (
+ # cd ruby
+ # emake DESTDIR="${D}" install || die "install failed in ruby"
+ # )
+ #fi
+}