summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-10-27 12:06:52 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-10-27 12:06:52 +0000
commit48738fdcb4292e1d1b53e3373e80716e86283a13 (patch)
treedd319f4a3f294a582d1f26e6cd2151fc3cab6d6b /sci-misc
parentAdd kid3-1.1. Now it supports kde4 if installed. (diff)
downloadgentoo-2-48738fdcb4292e1d1b53e3373e80716e86283a13.tar.gz
gentoo-2-48738fdcb4292e1d1b53e3373e80716e86283a13.tar.bz2
gentoo-2-48738fdcb4292e1d1b53e3373e80716e86283a13.zip
Switch to EAPI=2 with use dependencies
(Portage version: 2.2_rc11/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/gato/ChangeLog7
-rw-r--r--sci-misc/gato/files/gato-0.99-python.patch22
-rw-r--r--sci-misc/gato/files/gato-python2.4-gentoo.patch180
-rw-r--r--sci-misc/gato/gato-0.99.ebuild59
-rw-r--r--sci-misc/gato/gato-0.99c.ebuild13
5 files changed, 10 insertions, 271 deletions
diff --git a/sci-misc/gato/ChangeLog b/sci-misc/gato/ChangeLog
index 722ce21d2ac2..9a473ccccf90 100644
--- a/sci-misc/gato/ChangeLog
+++ b/sci-misc/gato/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-misc/gato
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/gato/ChangeLog,v 1.10 2008/01/29 15:08:52 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/gato/ChangeLog,v 1.11 2008/10/27 12:06:52 bicatali Exp $
+
+ 27 Oct 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ -files/gato-0.99-python.patch, -files/gato-python2.4-gentoo.patch,
+ -gato-0.99.ebuild, gato-0.99c.ebuild:
+ Switch to EAPI=2 with use dependencies
29 Jan 2008; Sébastien Fabbro <bicatali@gentoo.org> gato-0.99c.ebuild:
Oops: fixed python dir
diff --git a/sci-misc/gato/files/gato-0.99-python.patch b/sci-misc/gato/files/gato-0.99-python.patch
deleted file mode 100644
index db78336edbab..000000000000
--- a/sci-misc/gato/files/gato-0.99-python.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -Naur Gato/DataStructures.py Gato-patched/DataStructures.py
---- Gato/DataStructures.py 2006-09-05 07:13:38.000000000 -0500
-+++ Gato-patched/DataStructures.py 2007-08-23 18:54:01.000000000 -0500
-@@ -37,8 +37,8 @@
- ################################################################################
-
-
--from GatoGlobals import *
- from __future__ import generators #Needed for PQImplementation
-+from GatoGlobals import *
-
-
- ################################################################################
-diff -Naur Gato/Gato.py Gato-patched/Gato.py
---- Gato/Gato.py 2006-09-05 07:13:38.000000000 -0500
-+++ Gato-patched/Gato.py 2007-08-23 18:49:04.000000000 -0500
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python2.3
-+#!/usr/bin/env python
- ################################################################################
- #
- # This file is part of Gato (Graph Animation Toolbox)
diff --git a/sci-misc/gato/files/gato-python2.4-gentoo.patch b/sci-misc/gato/files/gato-python2.4-gentoo.patch
deleted file mode 100644
index 744b3d661a96..000000000000
--- a/sci-misc/gato/files/gato-python2.4-gentoo.patch
+++ /dev/null
@@ -1,180 +0,0 @@
-diff -Naur Gato/Embedder.py Gato-patched/Embedder.py
---- Gato/Embedder.py 2005-05-28 10:36:48.000000000 +0000
-+++ Gato-patched/Embedder.py 2005-12-04 20:24:05.000000000 +0000
-@@ -59,14 +59,14 @@
- theGraphEditor.G.yCoord[v], 1)
-
- #----------------------------------------------------------------------
--import whrandom
-+import random
-
- def RandomCoords(G):
- G.xCoord={}
- G.yCoord={}
- for v in G.vertices:
-- G.xCoord[v]=whrandom.randint(10,990)
-- G.yCoord[v]=whrandom.randint(10,990)
-+ G.xCoord[v]=random.randint(10,990)
-+ G.yCoord[v]=random.randint(10,990)
- return 1
-
- class RandomEmbedder(Embedder):
-@@ -454,7 +454,7 @@
- for d in list.values():
- Coord2=500-(len(d)-1)*yDist/2
- for v in d:
-- G.xCoord[v]=Coord1+whrandom.randint(-20,20)
-+ G.xCoord[v]=Coord1+random.randint(-20,20)
- G.yCoord[v]=Coord2
- Coord2=Coord2+yDist
- Coord1=Coord1-xDist
-diff -Naur Gato/Gato.py Gato-patched/Gato.py
---- Gato/Gato.py 2005-05-28 10:36:48.000000000 +0000
-+++ Gato-patched/Gato.py 2005-12-04 20:24:05.000000000 +0000
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python2.3
-+#!/usr/bin/env python2.4
- ################################################################################
- #
- # This file is part of Gato (Graph Animation Toolbox)
-@@ -40,7 +40,7 @@
- import traceback
- import os
- import bdb
--import whrandom
-+import random
- import re
- import string
- import StringIO
-@@ -1588,7 +1588,7 @@
-
- if v == None:
- if default == None:
-- v = whrandom.choice(self.graph.vertices)
-+ v = random.choice(self.graph.vertices)
- else:
- v = default
- if visual is not None:
-@@ -1613,7 +1613,7 @@
-
- if e == None:
- if default == None:
-- e = whrandom.choice(self.graph.Edges())
-+ e = random.choice(self.graph.Edges())
- else:
- e = default
-
-diff -Naur Gato/GatoFile.py Gato-patched/GatoFile.py
---- Gato/GatoFile.py 2005-05-28 10:36:48.000000000 +0000
-+++ Gato-patched/GatoFile.py 2005-12-04 20:24:05.000000000 +0000
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python2.3
-+#!/usr/bin/env python2.4
- ################################################################################
- #
- # This file is part of Gato (Graph Animation Toolbox)
-diff -Naur Gato/GraphCreator.py Gato-patched/GraphCreator.py
---- Gato/GraphCreator.py 2005-05-28 10:36:48.000000000 +0000
-+++ Gato-patched/GraphCreator.py 2005-12-04 20:24:05.000000000 +0000
-@@ -36,7 +36,7 @@
-
- from Graph import *
- from Embedder import *
--import whrandom
-+import random
-
- class Creator:
- """ This class provides an abstract Creator as
-@@ -202,7 +202,7 @@
-
- m=2
- while index < n:
-- e=Edges[whrandom.randint(0,m-1)]
-+ e=Edges[random.randint(0,m-1)]
- v=G.vertices[index]
- index=index+1
-
-@@ -297,7 +297,7 @@
- Edges=CompleteEdges(G,n,direction)
-
- for i in range(0,m):
-- pos=whrandom.randint(0,len(Edges)-1)
-+ pos=random.randint(0,len(Edges)-1)
- G.AddEdge(Edges[pos][0],Edges[pos][1])
- del Edges[pos]
-
-@@ -386,7 +386,7 @@
- Edges=MaximalPlanarEdges(G,n,direction)
-
- for i in range(0,m):
-- pos=whrandom.randint(0,len(Edges)-1)
-+ pos=random.randint(0,len(Edges)-1)
- G.AddEdge(Edges[pos][0],Edges[pos][1])
- del Edges[pos]
-
-@@ -578,7 +578,7 @@
- if direction==0:
- G.AddEdge(v,new_v)
- else:
-- if whrandom.randint(0,1):
-+ if random.randint(0,1):
- G.AddEdge(v,new_v)
- else:
- G.AddEdge(new_v,v)
-@@ -640,9 +640,9 @@
- float((float(degree)**(height-h)-1)/
- (degree-1))))
- max_nodes=min(n-G.Order()-height+h+1,len(nodes[h])*degree)
-- nodes_nr=whrandom.randint(min_nodes,max_nodes)
-+ nodes_nr=random.randint(min_nodes,max_nodes)
- for i in range(0,nodes_nr):
-- pos=whrandom.randint(0,len(nodes[h])-1)
-+ pos=random.randint(0,len(nodes[h])-1)
- v=nodes[h][pos]
- children_nr[v]=children_nr[v]+1
- if children_nr[v]==degree:
-@@ -652,7 +652,7 @@
- if direction==0:
- G.AddEdge(v,new_v)
- else:
-- if whrandom.randint(0,1):
-+ if random.randint(0,1):
- G.AddEdge(v,new_v)
- else:
- G.AddEdge(new_v,v)
-diff -Naur Gato/Gred.py Gato-patched/Gred.py
---- Gato/Gred.py 2005-05-28 10:36:48.000000000 +0000
-+++ Gato-patched/Gred.py 2005-12-04 20:24:05.000000000 +0000
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python2.3
-+#!/usr/bin/env python2.4
- ################################################################################
- #
- # This file is part of Gato (Graph Animation Toolbox)
-@@ -50,7 +50,7 @@
- from tkFileDialog import askopenfilename, asksaveasfilename
- from tkMessageBox import askokcancel
- import tkSimpleDialog
--import whrandom
-+import random
- import string
- import sys
- import os
-@@ -768,7 +768,7 @@
- for e in self.G.Edges():
- for i in xrange(count):
- if d.result[i][0] == 1:
-- val = whrandom.uniform(d.result[i][1],d.result[i][2])
-+ val = random.uniform(d.result[i][1],d.result[i][2])
- if self.G.edgeWeights[i].QInteger():
- self.G.edgeWeights[i][e] = round(int(val))
- else:
-diff -Naur Gato/TextTreeWidget.py Gato-patched/TextTreeWidget.py
---- Gato/TextTreeWidget.py 2005-05-28 10:36:48.000000000 +0000
-+++ Gato-patched/TextTreeWidget.py 2005-12-04 20:24:05.000000000 +0000
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python2.3
-+#!/usr/bin/env python2.4
- ################################################################################
- #
- # This file is part of Gato (Graph Animation Toolbox)
diff --git a/sci-misc/gato/gato-0.99.ebuild b/sci-misc/gato/gato-0.99.ebuild
deleted file mode 100644
index a17651782aa8..000000000000
--- a/sci-misc/gato/gato-0.99.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/gato/gato-0.99.ebuild,v 1.2 2008/01/29 13:34:40 markusle Exp $
-
-inherit eutils
-
-MY_P="Gato"
-MY_PV="0.99"
-
-DESCRIPTION="Graph Animation Toolbox"
-LICENSE="LGPL-2"
-HOMEPAGE="http://gato.sourceforge.net/"
-SRC_URI="http://gato.sourceforge.net/Download/${MY_P}-${MY_PV}.tar.gz
- doc? ( http://gato.sourceforge.net/Download/${MY_P}-Doc-${MY_PV}.tar.gz )"
-
-SLOT="0"
-KEYWORDS="~x86 ~ppc"
-IUSE="doc"
-
-DEPEND=""
-RDEPEND="dev-lang/python
- dev-lang/tk"
-
-S="${WORKDIR}"/Gato
-GATO_DOC="${WORKDIR}"/Doc
-
-src_unpack() {
- unpack ${A}
-
- # convert to python2.4
- epatch "${FILESDIR}"/${P}-python.patch
-
- cd "${S}"
- # change TKinter call to avoid crashing of X
- sed -e "s:self.overrideredirect(1):self.overrideredirect(0):" \
- -i GatoDialogs.py || die "failed to patch GatoDialogs.py"
-}
-
-src_install() {
-
- # install python code
- insinto /usr/lib/${PN}
- doins *.py || die "Failed to install python files"
- fperms 755 /usr/lib/${PN}/Gato.py /usr/lib/${PN}/Gred.py
-
- # create symlinks
- dodir /usr/bin
- dosym /usr/lib/${PN}/Gato.py /usr/bin/gato
- dosym /usr/lib/${PN}/Gred.py /usr/bin/gred
-
- # install data files
- insinto /usr/share/${PN}
- doins BFS.* DFS.* sample.cat || die "failed to data files"
-
- # install docs
- if use doc; then
- dohtml -r ${GATO_DOC}/*
- fi
-}
diff --git a/sci-misc/gato/gato-0.99c.ebuild b/sci-misc/gato/gato-0.99c.ebuild
index 72d52f535414..3797259fb9b9 100644
--- a/sci-misc/gato/gato-0.99c.ebuild
+++ b/sci-misc/gato/gato-0.99c.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/gato/gato-0.99c.ebuild,v 1.3 2008/01/29 15:08:52 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/gato/gato-0.99c.ebuild,v 1.4 2008/10/27 12:06:52 bicatali Exp $
+EAPI=2
inherit python eutils multilib
MY_PN="Gato"
@@ -16,19 +17,13 @@ SRC_URI="http://gato.sourceforge.net/Download/${MY_PN}-${MY_PV}.tar.gz
SLOT="0"
KEYWORDS="~x86 ~ppc ~amd64"
IUSE="doc"
+DEPEND="dev-lang/python[tk]"
S="${WORKDIR}"/${MY_PN}
-pkg_setup() {
- python_tkinter_exists
-}
-
-src_unpack() {
- unpack ${A}
-
+src_prepare() {
# convert to python >=2.4
epatch "${FILESDIR}"/${P}-python.patch
-
# change TKinter call to avoid crashing of X
sed -i \
-e 's:self.overrideredirect(1):self.overrideredirect(0):' \