summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-12-12 18:30:02 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-12-12 18:30:02 +0000
commit28038abd6691833b1729fa88c3d4817bafd456bc (patch)
tree59cd86c0fd84973dcc0bfa324489cf98a73d501c /sci-misc/ncview
parentVersion bump (diff)
downloadgentoo-2-28038abd6691833b1729fa88c3d4817bafd456bc.tar.gz
gentoo-2-28038abd6691833b1729fa88c3d4817bafd456bc.tar.bz2
gentoo-2-28038abd6691833b1729fa88c3d4817bafd456bc.zip
Version bump
(Portage version: 2.2_rc58/cvs/Linux x86_64)
Diffstat (limited to 'sci-misc/ncview')
-rw-r--r--sci-misc/ncview/ChangeLog9
-rw-r--r--sci-misc/ncview/ncview-1.93g.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/sci-misc/ncview/ChangeLog b/sci-misc/ncview/ChangeLog
index 917f4e06299b..52304ceaa846 100644
--- a/sci-misc/ncview/ChangeLog
+++ b/sci-misc/ncview/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-misc/ncview
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/ncview/ChangeLog,v 1.14 2008/08/06 18:29:54 ulm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/ncview/ChangeLog,v 1.15 2009/12/12 18:30:02 bicatali Exp $
+
+*ncview-1.93g (12 Dec 2009)
+
+ 12 Dec 2009; Sébastien Fabbro <bicatali@gentoo.org> +ncview-1.93g.ebuild:
+ Version bump
06 Aug 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/sci-misc/ncview/ncview-1.93g.ebuild b/sci-misc/ncview/ncview-1.93g.ebuild
new file mode 100644
index 000000000000..b1541883b928
--- /dev/null
+++ b/sci-misc/ncview/ncview-1.93g.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/ncview/ncview-1.93g.ebuild,v 1.1 2009/12/12 18:30:02 bicatali Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="X-based viewer for netCDF files"
+SRC_URI="ftp://cirrus.ucsd.edu/pub/ncview/${P}.tar.gz"
+HOMEPAGE="http://meteora.ucsd.edu/~pierce/ncview_home_page.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="udunits"
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+DEPEND="sci-libs/netcdf
+ media-libs/netpbm
+ x11-libs/libXaw
+ udunits? ( sci-libs/udunits )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # force netpbm (could be a use flag, but worth it?)
+ econf \
+ --x-libraries=/usr/$(get_libdir) \
+ --x-include=/usr/include \
+ --with-libppm \
+ $(use_with udunits)
+}
+
+src_install() {
+ local appdef=/usr/share/X11/app-defaults
+ dodir ${appdef}
+ dodir /usr/share/${PN}
+ # fix when root installs it.
+ sed -i \
+ -e "s:/usr/lib/X11/app-defaults:${D}${appdef}:g" \
+ install-appdef || die "sed failed"
+ emake \
+ DESTDIR="${D}" \
+ BINDIR="${D}/usr/bin" \
+ MANDIR="${D}/usr/share/man/man1" \
+ NCVIEW_LIB_DIR="${D}/usr/share/${PN}" \
+ XAPPLRESDIR="${D}/usr/share/X11/app-defaults" \
+ install || die "emake install failed"
+ insinto /usr/share/${PN}
+ doins *.ncmap nc_overlay* || die "doins failed"
+ dodoc README README_WISH_LIST RELEASE_NOTES || die
+}