summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-02-25 06:15:12 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-02-25 06:15:12 +0000
commit34a14a241f9cad0097bb951eed03c0a33a06e480 (patch)
tree4fd67be8f970e6b6523cbe5ec9c534e980d231ae /sci-misc/brlcad
parentVersion bump, bug #306609, thank Justin Lecher for report. (diff)
downloadgentoo-2-34a14a241f9cad0097bb951eed03c0a33a06e480.tar.gz
gentoo-2-34a14a241f9cad0097bb951eed03c0a33a06e480.tar.bz2
gentoo-2-34a14a241f9cad0097bb951eed03c0a33a06e480.zip
Version bump and moved to the main tree
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'sci-misc/brlcad')
-rw-r--r--sci-misc/brlcad/ChangeLog40
-rw-r--r--sci-misc/brlcad/brlcad-7.16.6.ebuild88
-rw-r--r--sci-misc/brlcad/files/brlcad-7.16.6-as-needed.patch25
-rw-r--r--sci-misc/brlcad/files/brlcad-7.16.6-stl-headers.patch10
-rw-r--r--sci-misc/brlcad/metadata.xml22
5 files changed, 185 insertions, 0 deletions
diff --git a/sci-misc/brlcad/ChangeLog b/sci-misc/brlcad/ChangeLog
new file mode 100644
index 000000000000..096cb39a2264
--- /dev/null
+++ b/sci-misc/brlcad/ChangeLog
@@ -0,0 +1,40 @@
+# ChangeLog for sci-misc/brlcad
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/brlcad/ChangeLog,v 1.1 2010/02/25 06:15:11 bicatali Exp $
+
+*brlcad-7.16.6 (25 Feb 2010)
+
+ 25 Feb 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ +brlcad-7.16.6.ebuild, +files/brlcad-7.16.6-as-needed.patch,
+ +files/brlcad-7.16.6-stl-headers.patch, +metadata.xml:
+ Version bump and moved to the main tree
+
+ 04 Feb 2010; Sébastien Fabbro <bicatali@gentoo.org> brlcad-7.16.4.ebuild:
+ Changed man directory to avoid conflicts
+
+*brlcad-7.16.4 (02 Feb 2010)
+
+ 02 Feb 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ -brlcad-7.10.4.ebuild, +brlcad-7.16.4.ebuild,
+ +files/brlcad-7.16.4-as-needed.patch,
+ -files/brlcad-tcltk-man_install.patch:
+ Version bump. Rewrote from scratch
+
+ 24 Aug 2008; Tim Cera <timcera@earthlink.net> brlcad-7.10.4.ebuild:
+ * The BDL (BSD Documentation License) was for content on their wiki. Removed
+ from software licenses. * Changed the copyright year to 2008.
+
+ 19 Dec 2007; Sébastien Fabbro <bicatali@gentoo.org>
+ -files/brlcad-7.6.6-gentoo.diff, +files/brlcad-tcltk-man_install.patch,
+ -files/tcl.m4, -brlcad-7.6.6.ebuild, +brlcad-7.10.4.ebuild:
+ Version bump
+
+ 26 January 2006; Lucas Chiesa <lucas.chiesa@gmail.com> brlcad-7.6.6.ebuild:
+ Added brlcad-7.6.6-gentoo.diff which replaces the entire test for
+ tcl/tk/itcl/iwidgets in configure.ac. It needs some more work.
+
+*brlcad-7.6.6 (19 January 2006)
+
+ 19 January 2006; Marcus D. Hanwell <cryos@gentoo.org>
+ +brlcad-7.6.6.ebuild:
+ Initial import into the science overlay, bug 77197.
diff --git a/sci-misc/brlcad/brlcad-7.16.6.ebuild b/sci-misc/brlcad/brlcad-7.16.6.ebuild
new file mode 100644
index 000000000000..6c0aa13da315
--- /dev/null
+++ b/sci-misc/brlcad/brlcad-7.16.6.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/brlcad/brlcad-7.16.6.ebuild,v 1.1 2010/02/25 06:15:11 bicatali Exp $
+
+EAPI=2
+inherit eutils java-pkg-opt-2
+
+DESCRIPTION="Constructive solid geometry modeling system"
+HOMEPAGE="http://brlcad.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc examples java opengl smp X"
+
+RDEPEND="media-libs/libpng
+ sys-libs/zlib
+ >=sci-libs/tnt-3
+ sci-libs/jama
+ dev-tcltk/itcl
+ dev-tcltk/itk
+ dev-tcltk/iwidgets
+ dev-tcltk/tkimg
+ sys-libs/libtermcap-compat
+ media-libs/urt
+ java? ( >=virtual/jre-1.5 )
+ X? ( x11-libs/libXt x11-libs/libXi )"
+
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ java? ( >=virtual/jdk-1.5 )
+ doc? ( dev-libs/libxslt )"
+
+BRLCAD_DIR="/usr/${PN}"
+
+src_prepare() {
+ #patch a simple Makefile.in since the Makefile.am would need
+ #a full and slow autoreconf of many directories
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ epatch "${FILESDIR}"/${P}-stl-headers.patch
+}
+
+src_configure() {
+ local myitcl="/usr/$(get_libdir)/itcl3.4"
+ local myitk="/usr/$(get_libdir)/itk3.4"
+ econf \
+ --prefix="${BRLCAD_DIR}" \
+ --datadir="/usr/share/${PN}" \
+ --mandir="${BRLCAR_DIR}/man" \
+ --disable-almost-everything \
+ --disable-regex-build \
+ --disable-png-build \
+ --disable-zlib-build \
+ --disable-urt-build \
+ --disable-tcl-build \
+ --disable-tk-build \
+ --disable-itcl-build \
+ --disable-tkimg-build \
+ --disable-jove-build \
+ --disable-tnt-install \
+ --disable-iwidgets-install \
+ --enable-opennurbs-build \
+ --with-ldflags="-L${myitcl} -L${myitk}" \
+ $(use_enable debug) \
+ $(use_enable debug optimization) \
+ $(use_enable debug runtime-debug) \
+ $(use_enable debug strict-build) \
+ $(use_enable debug verbose) \
+ $(use_enable debug warnings) \
+ $(use_enable debug progress) \
+ $(use_enable doc documentation) \
+ $(use_enable examples models-install) \
+ $(use_enable smp parallel) \
+ $(use_with java jdk $(java-config -O)) \
+ $(use_with opengl ogl) \
+ $(use_with X x) \
+ $(use_with X x11) \
+ LD_LIBRARY_PATH="${myitcl}:${myitk}:${LD_LIBRARY_PATH}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ echo "PATH=${BRLCAD_DIR}/bin" > 99brlcad
+ echo "MANPATH=${BRLCAD_DIR}/man" >> 99brlcad
+ doenvd 99brlcad || die
+}
diff --git a/sci-misc/brlcad/files/brlcad-7.16.6-as-needed.patch b/sci-misc/brlcad/files/brlcad-7.16.6-as-needed.patch
new file mode 100644
index 000000000000..ae83acddd43b
--- /dev/null
+++ b/sci-misc/brlcad/files/brlcad-7.16.6-as-needed.patch
@@ -0,0 +1,25 @@
+--- src/conv/step/Makefile.in.orig 2010-02-02 19:37:34.000000000 +0000
++++ src/conv/step/Makefile.in 2010-02-02 19:38:15.000000000 +0000
+@@ -894,6 +894,11 @@
+ VolumeSiUnit.h \
+ VolumeUnit.h
+
++libstep2g_nil_la_LIBADD = \
++ ${BU} \
++ ${WDB} \
++ ${RT} \
++ ${STEP_LIBS}
+
+ # FIXME: these declarations are required for proper distchecking if
+ # the files do not exist before configure is run.
+@@ -903,10 +908,6 @@
+
+ step_g_SOURCES =
+ step_g_LDADD = \
+- ${BU} \
+- ${WDB} \
+- ${RT} \
+- ${STEP_LIBS} \
+ libstep2g_nil.la
+
+
diff --git a/sci-misc/brlcad/files/brlcad-7.16.6-stl-headers.patch b/sci-misc/brlcad/files/brlcad-7.16.6-stl-headers.patch
new file mode 100644
index 000000000000..5f45c78b3fe2
--- /dev/null
+++ b/sci-misc/brlcad/files/brlcad-7.16.6-stl-headers.patch
@@ -0,0 +1,10 @@
+--- src/other/openNURBS/opennurbs_system.h.orig 2010-02-25 06:10:58.000000000 +0000
++++ src/other/openNURBS/opennurbs_system.h 2010-02-25 06:12:17.000000000 +0000
+@@ -244,6 +244,7 @@
+ #define ON_CPLUSPLUS
+ #endif
+
++#include <cstddef>
+ #include <new> // for declaration of placement versions of new used in onClassArray<>.
+
+ #endif
diff --git a/sci-misc/brlcad/metadata.xml b/sci-misc/brlcad/metadata.xml
new file mode 100644
index 000000000000..ce48108a6e6c
--- /dev/null
+++ b/sci-misc/brlcad/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+BRL-CAD is a Combinatorial/Constructive Solid Geometry (CSG)
+solid modeling system that includes an interactive geometry editor,
+ray-tracing support for rendering and geometric analysis,
+network-distributed framebuffer support, image and signal-processing
+tools, and an embedded scripting language.
+
+The package is a collection of over 400 tools and utilities. Included
+is support for various geometric data format conversions, image and
+signal processing capabilities, ray-tracing based lighting models,
+network distributed ray-tracing, parallel ray-tracing, animation
+capabilities, data compression, image handling, and interactive 3-D
+geometric editing, and also an implementation of Weiler's n-Manifold
+Geometry (NMG) data structures for surface-based solid models and
+photon mapping.
+</longdescription>
+</pkgmetadata>
+