summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Jackson <tsunam@gentoo.org>2007-03-27 05:29:11 +0000
committerJoshua Jackson <tsunam@gentoo.org>2007-03-27 05:29:11 +0000
commit9d03a990eaadaf5e95c5d0b7bf2e8a7b8a07f746 (patch)
treef32bd54c09351c50d2d16d31f0572a451b7e68c4 /sci-misc/boinc
parentupdating message for boinc's masking to replace the not working with all proj... (diff)
downloadgentoo-2-9d03a990eaadaf5e95c5d0b7bf2e8a7b8a07f746.tar.gz
gentoo-2-9d03a990eaadaf5e95c5d0b7bf2e8a7b8a07f746.tar.bz2
gentoo-2-9d03a990eaadaf5e95c5d0b7bf2e8a7b8a07f746.zip
adding the new version with blessings from cryos
(Portage version: 2.1.2.2)
Diffstat (limited to 'sci-misc/boinc')
-rw-r--r--sci-misc/boinc/ChangeLog8
-rw-r--r--sci-misc/boinc/boinc-5.8.15.ebuild104
-rw-r--r--sci-misc/boinc/files/digest-boinc-5.8.153
3 files changed, 114 insertions, 1 deletions
diff --git a/sci-misc/boinc/ChangeLog b/sci-misc/boinc/ChangeLog
index c0fa0df7dcde..272ef95c3a05 100644
--- a/sci-misc/boinc/ChangeLog
+++ b/sci-misc/boinc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-misc/boinc
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.30 2007/03/13 00:34:19 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.31 2007/03/27 05:29:11 tsunam Exp $
+
+*boinc-5.8.15 (27 Mar 2007)
+
+ 27 Mar 2007; Joshua Jackson <tsunam@gentoo.org> +boinc-5.8.15.ebuild:
+ Adding the new considered stable version to the tree, with help from users
+ in bug #166920
13 Mar 2007; Danny van Dyk <kugelfang@gentoo.org>
boinc-4.72.20050813-r3.ebuild, boinc-5.2.14.ebuild, boinc-5.4.11.ebuild,
diff --git a/sci-misc/boinc/boinc-5.8.15.ebuild b/sci-misc/boinc/boinc-5.8.15.ebuild
new file mode 100644
index 000000000000..55a0ca5e112b
--- /dev/null
+++ b/sci-misc/boinc/boinc-5.8.15.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.8.15.ebuild,v 1.1 2007/03/27 05:29:11 tsunam Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
+HOMEPAGE="http://boinc.ssl.berkeley.edu/"
+SRC_URI="mirror://gentoo//${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="server X unicode"
+
+RDEPEND="sys-libs/zlib
+ >=net-misc/curl-7.15.5
+ >=dev-libs/openssl-0.9.7
+ X? ( >=x11-libs/wxGTK-2.6.2 )
+ server? ( net-www/apache
+ >=virtual/mysql-4.0
+ virtual/php
+ >=dev-lang/python-2.2.3
+ >=dev-python/mysql-python-0.9.2 )"
+DEPEND=">=sys-devel/gcc-3.0.4
+ >=sys-devel/autoconf-2.58
+ >=sys-devel/automake-1.8
+ >=dev-util/pkgconfig-0.15
+ >=sys-devel/m4-1.4
+ X? ( || ( ( x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-proto/xproto )
+ virtual/x11 )
+ virtual/glut
+ virtual/glu
+ media-libs/jpeg )
+ server? ( virtual/imap-c-client )
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ append-flags -O3 -funroll-loops -fforce-addr -ffast-math
+ # Just run the necessary tools directly
+ #einfo "Running necessary autotools..."
+ #aclocal -I m4 || die "aclocal failed."
+ #autoheader || die "autoheader failed."
+ #automake || die "automake failed."
+ #autoconf || die "autoconf failed."
+ econf \
+ --enable-client \
+ --disable-static-client \
+ --with-ssl \
+ --with-wx-config=$(type -P wx-config-2.6) \
+ $(use_enable unicode) \
+ $(use_enable server) \
+ $(use_with X x) || die "econf failed"
+ # Make it link to the compiled libs, not the installed ones
+ sed -e "s|LDFLAGS = |LDFLAGS = -L../lib |g" -i */Makefile || \
+ die "sed failed"
+ # Force -j1 - bug 136374.
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ mkdir ${D}/var ${D}/var/lib ${D}/var/lib/boinc/
+ cp ${S}/ca-bundle.crt ${D}/var/lib/boinc
+ chown boinc:boinc ${D}/var/lib/boinc
+ newinitd ${FILESDIR}/boinc.init boinc
+ newconfd ${FILESDIR}/boinc.conf boinc
+
+ make_desktop_entry boinc_gui BOINC boinc Science /var/lib/boinc
+}
+
+pkg_preinst() {
+ enewgroup boinc
+ enewuser boinc -1 -1 /var/lib/boinc boinc
+}
+
+pkg_postinst() {
+ echo
+ einfo "You need to attach to a project to do anything useful with boinc."
+ einfo "You can do this by running /etc/init.d/boinc attach"
+ einfo "BOINC The howto for configuration is located at:"
+ einfo "http://boinc.berkeley.edu/anonymous_platform.php"
+ if use server;then
+ echo
+ einfo "You have chosen to enable server mode. this ebuild has installed"
+ einfo "the necessary packages to be a server. You will need to have a"
+ einfo "project. Contact BOINC directly for further information."
+ fi
+ echo
+ # Add warning about the new password for the client, bug 121896.
+ einfo "If you need to use the graphical client the password is in "
+ einfo "/var/lib/boinc/gui_rpc_auth.cfg which is randomly generated "
+ einfo "by BOINC upon successfully running the gui for the first time."
+ einfo "You can change this to something more memorable."
+ echo
+}
diff --git a/sci-misc/boinc/files/digest-boinc-5.8.15 b/sci-misc/boinc/files/digest-boinc-5.8.15
new file mode 100644
index 000000000000..0397fcb9db7d
--- /dev/null
+++ b/sci-misc/boinc/files/digest-boinc-5.8.15
@@ -0,0 +1,3 @@
+MD5 c6192ddfcec84852e57f387db954d088 boinc-5.8.15.tar.bz2 3544744
+RMD160 cdeb0a544be911db3f1d505f6cd9eb7c8a4971cb boinc-5.8.15.tar.bz2 3544744
+SHA256 0e428af6a76dd41786f15c9de0a31a403613b2e366c0f5b950e2be266f82b902 boinc-5.8.15.tar.bz2 3544744