summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2013-05-14 07:21:21 +0000
committerThomas Kahle <tomka@gentoo.org>2013-05-14 07:21:21 +0000
commitdd8ad39c20ae1a67eb05f55e7633943a9bd75418 (patch)
treeff45f4b2fd161fd2c1494230ea70fe84d1c6fbdd /sci-mathematics
parentFix systemd unit due to removed tmpfiles (bug #469784). Remove left-overs fro... (diff)
downloadgentoo-2-dd8ad39c20ae1a67eb05f55e7633943a9bd75418.tar.gz
gentoo-2-dd8ad39c20ae1a67eb05f55e7633943a9bd75418.tar.bz2
gentoo-2-dd8ad39c20ae1a67eb05f55e7633943a9bd75418.zip
bump to 2.10
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0x89DEB219565C32BC!)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/normaliz/ChangeLog10
-rw-r--r--sci-mathematics/normaliz/files/normaliz-2.10-respect-flags.patch27
-rw-r--r--sci-mathematics/normaliz/normaliz-2.10.ebuild57
3 files changed, 92 insertions, 2 deletions
diff --git a/sci-mathematics/normaliz/ChangeLog b/sci-mathematics/normaliz/ChangeLog
index d1e7ed5322d4..97d1dec1b297 100644
--- a/sci-mathematics/normaliz/ChangeLog
+++ b/sci-mathematics/normaliz/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/normaliz
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/normaliz/ChangeLog,v 1.9 2012/11/12 03:15:19 tomka Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/normaliz/ChangeLog,v 1.10 2013/05/14 07:21:21 tomka Exp $
+
+*normaliz-2.10 (14 May 2013)
+
+ 14 May 2013; Thomas Kahle <tomka@gentoo.org>
+ +files/normaliz-2.10-respect-flags.patch, +normaliz-2.10.ebuild:
+ bump to 2.10
*normaliz-2.8 (12 Nov 2012)
diff --git a/sci-mathematics/normaliz/files/normaliz-2.10-respect-flags.patch b/sci-mathematics/normaliz/files/normaliz-2.10-respect-flags.patch
new file mode 100644
index 000000000000..3486fe4435c4
--- /dev/null
+++ b/sci-mathematics/normaliz/files/normaliz-2.10-respect-flags.patch
@@ -0,0 +1,27 @@
+diff -U 3 -dHrN Normaliz2.10.org/source/Makefile Normaliz2.10/source/Makefile
+--- Normaliz2.10.org/source/Makefile 2013-05-14 09:13:29.148646896 +0200
++++ Normaliz2.10/source/Makefile 2013-05-14 09:17:55.002658867 +0200
+@@ -17,7 +17,7 @@
+ @$(MAKE) normaliz
+
+ normaliz: $(SOURCES) $(HEADERS) libnormaliz/libnormaliz.a
+- $(CXX) $(CXXFLAGS) $(NORMFLAGS) Normaliz.cpp libnormaliz/libnormaliz.a $(GMPFLAGS) -o normaliz
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) $(NORMFLAGS) Normaliz.cpp libnormaliz/libnormaliz.a $(GMPFLAGS) -o normaliz
+
+ normaliz1: $(SOURCES) $(HEADERS) $(LIBHEADERS) $(LIBSOURCES)
+ $(CXX) $(CXXFLAGS) $(NORMFLAGS) Normaliz-impl.cpp $(GMPFLAGS) -o normaliz1
+diff -U 3 -dHrN Normaliz2.10.org/source/Makefile.configuration Normaliz2.10/source/Makefile.configuration
+--- Normaliz2.10.org/source/Makefile.configuration 2013-05-14 09:13:29.149646895 +0200
++++ Normaliz2.10/source/Makefile.configuration 2013-05-14 09:13:44.469637334 +0200
+@@ -1,11 +1,9 @@
+ ##
+ ## Makefile configuration for normaliz
+ ##
+-CXX = g++
+ #CXX = linux32 g++ -m32 -march=i686 #compile it for linux32
+ CXXFLAGS += -std=c++0x
+ CXXFLAGS += -Wall -pedantic
+-CXXFLAGS += -O3 -funroll-loops
+ #CXXFLAGS += -I /usr/local/boost_1_45_0
+ #CXXFLAGS += -g ## debugging
+ #CXXFLAGS += -pg ## profiling
diff --git a/sci-mathematics/normaliz/normaliz-2.10.ebuild b/sci-mathematics/normaliz/normaliz-2.10.ebuild
new file mode 100644
index 000000000000..b24a415addfa
--- /dev/null
+++ b/sci-mathematics/normaliz/normaliz-2.10.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/normaliz/normaliz-2.10.ebuild,v 1.1 2013/05/14 07:21:21 tomka Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+MYP="Normaliz${PV}"
+
+DESCRIPTION="Tool for computations in affine monoids and more"
+HOMEPAGE="http://www.mathematik.uni-osnabrueck.de/normaliz/"
+SRC_URI="http://www.mathematik.uni-osnabrueck.de/${PN}/${MYP}/${MYP}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="extras openmp"
+
+RDEPEND="dev-libs/gmp[cxx]"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-libs/boost"
+# Only a boost header is needed -> not RDEPEND
+
+S=${WORKDIR}/${MYP}
+
+src_prepare () {
+ epatch "${FILESDIR}/${P}-respect-flags.patch"
+
+ if use openmp && tc-has-openmp; then
+ export OPENMP=yes
+ else
+ export OPENMP=no
+ fi
+}
+
+src_compile(){
+ emake CXX="$(tc-getCXX)" OPENMP="${OPENMP}" -C source
+}
+
+src_install() {
+ dobin source/normaliz
+ dodoc doc/"${MYP}Documentation.pdf"
+ dodoc doc/"NmzIntegrate1.1Documentation.pdf"
+ if use extras; then
+ elog "You have selected to install extras which consist of Macaulay2"
+ elog "and Singular packages. These have been installed into "
+ elog "/usr/share/${PN}, and cannot be used without additional setup. Please refer"
+ elog "to the homepages of the respective projects for additional information."
+ elog "Note however, Gentoo's versions of Singular and Macaulay2 bring their own"
+ elog "copies of these interface packages. Usually you don't need normaliz's versions."
+ insinto "/usr/share/${PN}"
+ doins Singular/normaliz.lib
+ doins Macaulay2/Normaliz.m2
+ fi
+}