summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-11-07 23:26:11 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-11-07 23:26:11 +0000
commitbe2aa11f1199aafec25c8268bb10520a1f3ef859 (patch)
tree8d7ddd66bb4ce715c262959ee780f233ee2627a9 /sci-mathematics
parentStable on x86, bug #198314 (diff)
downloadgentoo-2-be2aa11f1199aafec25c8268bb10520a1f3ef859.tar.gz
gentoo-2-be2aa11f1199aafec25c8268bb10520a1f3ef859.tar.bz2
gentoo-2-be2aa11f1199aafec25c8268bb10520a1f3ef859.zip
Version bump, and added longdescription in metadata.xml
(Portage version: 2.1.3.16)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/yacas/ChangeLog8
-rw-r--r--sci-mathematics/yacas/files/digest-yacas-1.2.23
-rw-r--r--sci-mathematics/yacas/metadata.xml8
-rw-r--r--sci-mathematics/yacas/yacas-1.2.2.ebuild42
4 files changed, 60 insertions, 1 deletions
diff --git a/sci-mathematics/yacas/ChangeLog b/sci-mathematics/yacas/ChangeLog
index 69155b720cc6..d8a532cbd591 100644
--- a/sci-mathematics/yacas/ChangeLog
+++ b/sci-mathematics/yacas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/yacas
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/ChangeLog,v 1.17 2007/08/10 18:00:16 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/ChangeLog,v 1.18 2007/11/07 23:26:11 bicatali Exp $
+
+*yacas-1.2.2 (07 Nov 2007)
+
+ 07 Nov 2007; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
+ +yacas-1.2.2.ebuild:
+ Version bump, and added longdescription in metadata.xml
*yacas-1.1.0 (10 Aug 2007)
diff --git a/sci-mathematics/yacas/files/digest-yacas-1.2.2 b/sci-mathematics/yacas/files/digest-yacas-1.2.2
new file mode 100644
index 000000000000..5a95cc893638
--- /dev/null
+++ b/sci-mathematics/yacas/files/digest-yacas-1.2.2
@@ -0,0 +1,3 @@
+MD5 329f149ca3ceb976a7e596b56fc3cba5 yacas-1.2.2.tar.gz 1203303
+RMD160 6c49ca60e4f1f92e7d30e8d91b6126e55d77321b yacas-1.2.2.tar.gz 1203303
+SHA256 e8345de267ed41790128649e3ff5ab7be7d0a2fa6e721b82e0a552c04775aab6 yacas-1.2.2.tar.gz 1203303
diff --git a/sci-mathematics/yacas/metadata.xml b/sci-mathematics/yacas/metadata.xml
index 5a2f1c7b832e..f3aedac45295 100644
--- a/sci-mathematics/yacas/metadata.xml
+++ b/sci-mathematics/yacas/metadata.xml
@@ -2,4 +2,12 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci-mathematics</herd>
+<longdescription lang="en">
+Yacas (Yet Another Computer Algebra System) is a small and highly
+flexible general-purpose computer algebra language. The syntax uses a
+infix-operator grammar parser. The distribution contains a small
+library of mathematical functions, but its real strength is in the
+language in which you can easily write your own symbolic manipulation
+algorithms.
+</longdescription>
</pkgmetadata>
diff --git a/sci-mathematics/yacas/yacas-1.2.2.ebuild b/sci-mathematics/yacas/yacas-1.2.2.ebuild
new file mode 100644
index 000000000000..7d52f1996a0a
--- /dev/null
+++ b/sci-mathematics/yacas/yacas-1.2.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/yacas-1.2.2.ebuild,v 1.1 2007/11/07 23:26:11 bicatali Exp $
+
+DESCRIPTION="Powerful general purpose computer algebra system"
+HOMEPAGE="http://yacas.sourceforge.net/"
+SRC_URI="http://${PN}.sourceforge.net/backups/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="doc java server"
+
+DEPEND="java? ( virtual/jdk )"
+
+src_compile() {
+ econf \
+ $(use_enable doc html-doc) \
+ $(use_enable server) \
+ --with-html-dir="/usr/share/doc/${PF}/html" \
+ || die "econf failed"
+ emake || die "emake failed"
+ if use java; then
+ cd JavaYacas
+ emake -f makefile.yacas || die "emake java interface failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS README TODO || die
+ if use java; then
+ cd JavaYacas
+ insinto /usr/share/${PN}
+ doins yacas.jar hints.txt yacasconsole.html || die "doins java interface failed"
+ echo "#!/bin/sh" > jyacas
+ echo "java -jar /usr/share/${PN}/java.jar" >> jyacas
+ exeinto /usr/bin
+ doexe jyacas
+ fi
+}