summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2011-01-23 22:03:35 +0000
committerThomas Kahle <tomka@gentoo.org>2011-01-23 22:03:35 +0000
commitb103b0386d6f67be429a265228fa02726f24c950 (patch)
tree1c8d62f61f24244f1d6541b46bc5d1599f7a5155 /sci-mathematics
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-b103b0386d6f67be429a265228fa02726f24c950.tar.gz
gentoo-2-b103b0386d6f67be429a265228fa02726f24c950.tar.bz2
gentoo-2-b103b0386d6f67be429a265228fa02726f24c950.zip
bump to 0.5
(Portage version: 2.1.9.35/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/gfan/ChangeLog7
-rw-r--r--sci-mathematics/gfan/gfan-0.5.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/sci-mathematics/gfan/ChangeLog b/sci-mathematics/gfan/ChangeLog
index 450e8c392680..1b181e70aff9 100644
--- a/sci-mathematics/gfan/ChangeLog
+++ b/sci-mathematics/gfan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/gfan
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gfan/ChangeLog,v 1.3 2011/01/02 09:19:26 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gfan/ChangeLog,v 1.4 2011/01/23 22:03:35 tomka Exp $
+
+*gfan-0.5 (23 Jan 2011)
+
+ 23 Jan 2011; Thomas Kahle <tomka@gentoo.org> +gfan-0.5.ebuild:
+ bump to 0.5
02 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> gfan-0.4-r1.ebuild:
x86 stable wrt bug #349167
diff --git a/sci-mathematics/gfan/gfan-0.5.ebuild b/sci-mathematics/gfan/gfan-0.5.ebuild
new file mode 100644
index 000000000000..398fb67dd9c1
--- /dev/null
+++ b/sci-mathematics/gfan/gfan-0.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gfan/gfan-0.5.ebuild,v 1.1 2011/01/23 22:03:35 tomka Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="computes Groebner fans and tropical varities"
+HOMEPAGE="http://www.math.tu-berlin.de/~jensen/software/gfan/gfan.html"
+SRC_URI="http://www.math.tu-berlin.de/~jensen/software/gfan/${PN}${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-libs/gmp[-nocxx]
+ sci-libs/cddlib"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}${PV}/"
+
+src_prepare () {
+ sed -i -e "s/-O2/${CXXFLAGS}/" \
+ -e "/GPROFFLAG =/d" \
+ -e "s/g++/$(tc-getCXX)/" \
+ -e "s/\$(CCLINKER)/& \$(LDFLAGS)/" Makefile || die
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" install || die "emake install failed"
+}