summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2005-09-06 00:12:26 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2005-09-06 00:12:26 +0000
commit79eb05fd3d7445d2fcfaa6b4bd0bd64dcb26e604 (patch)
treeca25d566c6d0d5c27f0fe6c467831098fda610d4 /sci-mathematics
parent(#104660) Get rid of obsolete license. (diff)
downloadgentoo-2-79eb05fd3d7445d2fcfaa6b4bd0bd64dcb26e604.tar.gz
gentoo-2-79eb05fd3d7445d2fcfaa6b4bd0bd64dcb26e604.tar.bz2
gentoo-2-79eb05fd3d7445d2fcfaa6b4bd0bd64dcb26e604.zip
Fixed USE=mpi handling.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/octave/ChangeLog5
-rw-r--r--sci-mathematics/octave/octave-2.1.69.ebuild10
2 files changed, 12 insertions, 3 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index bc3108367b9f..77dd7128ddd6 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-mathematics/octave
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.12 2005/08/21 04:15:27 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.13 2005/09/06 00:12:26 kugelfang Exp $
+
+ 06 Sep 2005; Danny van Dyk <kugelfang@gentoo.org> octave-2.1.69.ebuild:
+ Fixed USE=mpi handling.
*octave-2.1.71 (21 Aug 2005)
diff --git a/sci-mathematics/octave/octave-2.1.69.ebuild b/sci-mathematics/octave/octave-2.1.69.ebuild
index fd7cb6ee7eb1..7b4eff009dbe 100644
--- a/sci-mathematics/octave/octave-2.1.69.ebuild
+++ b/sci-mathematics/octave/octave-2.1.69.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.69.ebuild,v 1.6 2005/08/21 04:15:27 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.69.ebuild,v 1.7 2005/09/06 00:12:26 kugelfang Exp $
inherit flag-o-matic
@@ -24,6 +24,7 @@ DEPEND="virtual/libc
tetex? ( virtual/tetex )
x86? ( ifc? ( dev-lang/ifc ) )
blas? ( virtual/blas )
+ mpi? ( sys-cluster/lam-mpi )
!=app-text/texi2html-1.70"
# NOTE: octave supports blas/lapack from intel but this is not open
@@ -51,9 +52,14 @@ src_compile() {
# Danny van Dyk 2004/08/26
use zlib && LDFLAGS="${LDFLAGS} -lz"
+ if use mpi; then
+ myconf="${myconf} --with-mpi=lammpi++"
+ else
+ myconf="${myconf} --without-mpi"
+ fi
+
econf \
$(use_with hdf5) \
- $(use_with mpi) \
$(use_enable readline) \
${myconf} \
LDFLAGS="${LDFLAGS}" || die "econf failed"