summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2007-12-25 01:46:56 +0000
committerSteve Arnold <nerdboy@gentoo.org>2007-12-25 01:46:56 +0000
commit661b51c3df1a54551380e93c296bc9a9304107ac (patch)
tree71444fd6eda7fe8ebb74620539ad6ebce8ca0bd5 /sci-mathematics
parentwhitespace (diff)
downloadgentoo-2-661b51c3df1a54551380e93c296bc9a9304107ac.tar.gz
gentoo-2-661b51c3df1a54551380e93c296bc9a9304107ac.tar.bz2
gentoo-2-661b51c3df1a54551380e93c296bc9a9304107ac.zip
updated to check for mpich2 cxx interface (which breaks standard headers)
(Portage version: 2.1.4_rc7)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/octave/ChangeLog12
-rw-r--r--sci-mathematics/octave/octave-2.1.73-r1.ebuild29
-rw-r--r--sci-mathematics/octave/octave-2.1.73-r2.ebuild32
-rw-r--r--sci-mathematics/octave/octave-2.1.73.ebuild29
4 files changed, 68 insertions, 34 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index a6184dc3bad5..4c1a17e8c9e5 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sci-mathematics/octave
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.50 2007/12/18 10:29:01 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.51 2007/12/25 01:46:56 nerdboy Exp $
+
+ 25 Dec 2007; Steve Arnold <nerdboy@gentoo.org> octave-2.1.73.ebuild,
+ octave-2.1.73-r1.ebuild, octave-2.1.73-r2.ebuild:
+ Updated to check for mpich2 cxx interface (which breaks standard headers)
+ to address bug #182904). Unfortunately, the mpich2 headers aren't
+ compatible with the standard ones (see bug #202304) so each package is
+ responsible for the workaround and breakage checking; see the above bug
+ for upstream octave response. Although it kicks the build, the best way
+ to handle it for now seems to be getting rid of the offending mpich2 C++
+ libraries and include nastiness.
18 Dec 2007; Markus Dittrich <markusle@gentoo.org>
octave-2.1.73-r2.ebuild:
diff --git a/sci-mathematics/octave/octave-2.1.73-r1.ebuild b/sci-mathematics/octave/octave-2.1.73-r1.ebuild
index 568d09144b25..ed67a7b038b0 100644
--- a/sci-mathematics/octave/octave-2.1.73-r1.ebuild
+++ b/sci-mathematics/octave/octave-2.1.73-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.73-r1.ebuild,v 1.6 2007/11/20 14:46:56 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.73-r1.ebuild,v 1.7 2007/12/25 01:46:56 nerdboy Exp $
inherit flag-o-matic fortran autotools
@@ -58,20 +58,29 @@ src_compile() {
# mpicc/mpic++
# octave links agains -lmpi by default
# mpich needs -lmpich instead
- if use mpi; then
- CC="mpicc" && CXX="mpiCC"
- if has_version 'sys-cluster/mpich'; then
- myconf="${myconf} --with-mpi=mpich"
+ if use mpi ; then
+ if built_with_use sys-cluster/mpich2 cxx ; then
+ elog "mpich2 must be built without C++ support!"
+ die "please rebuild mpich2 with USE=-cxx..."
+ else
+ CC="mpicc"
+ if has_version 'sys-cluster/mpich' ; then
+ CXX="mpiCC"
+ myconf="${myconf} --with-mpi=mpich"
+ elif has_version 'sys-cluster/mpich2' ; then
+ F77="mpif77"
+ myconf="${myconf} --with-mpi=mpich"
else
- myconf="${myconf} --with-mpi=mpi"
+ myconf="${myconf} --with-mpi=mpi"
fi
+ fi
else
- CC="$(tc-getCC)"
- CXX="$(tc-getCXX)"
- myconf="${myconf} --without-mpi"
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ myconf="${myconf} --without-mpi"
fi
- CC="${CC}" CXX="${CXX}" \
+ CC="${CC}" CXX="${CXX}" F77="${F77}" \
econf \
$(use_with hdf5) \
$(use_enable readline) \
diff --git a/sci-mathematics/octave/octave-2.1.73-r2.ebuild b/sci-mathematics/octave/octave-2.1.73-r2.ebuild
index 9ce075319a5a..df4c4d8b7858 100644
--- a/sci-mathematics/octave/octave-2.1.73-r2.ebuild
+++ b/sci-mathematics/octave/octave-2.1.73-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.73-r2.ebuild,v 1.4 2007/12/18 10:29:01 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.73-r2.ebuild,v 1.5 2007/12/25 01:46:56 nerdboy Exp $
inherit flag-o-matic fortran autotools xemacs-elisp-common
@@ -62,23 +62,29 @@ src_compile() {
# mpicc/mpic++
# octave links agains -lmpi by default
# mpich needs -lmpich instead
- if use mpi; then
- CC="mpicc" && CXX="mpiCC"
- if has_version 'sys-cluster/mpich'; then
- myconf="${myconf} --with-mpi=mpich"
+ if use mpi ; then
+ if built_with_use sys-cluster/mpich2 cxx ; then
+ elog "mpich2 must be built without C++ support!"
+ die "please rebuild mpich2 with USE=-cxx..."
+ else
+ CC="mpicc"
+ if has_version 'sys-cluster/mpich' ; then
+ CXX="mpiCC"
+ myconf="${myconf} --with-mpi=mpich"
+ elif has_version 'sys-cluster/mpich2' ; then
+ F77="mpif77"
+ myconf="${myconf} --with-mpi=mpich"
else
- myconf="${myconf} --with-mpi=mpi"
+ myconf="${myconf} --with-mpi=mpi"
fi
+ fi
else
- CC="$(tc-getCC)"
- CXX="$(tc-getCXX)"
- myconf="${myconf} --without-mpi"
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ myconf="${myconf} --without-mpi"
fi
- # force use of external blas and lapack
- myconf="${myconf} --with-blas=blas --with-lapack=lapack"
-
- CC="${CC}" CXX="${CXX}" \
+ CC="${CC}" CXX="${CXX}" F77="${F77}" \
econf \
$(use_with hdf5) \
$(use_enable readline) \
diff --git a/sci-mathematics/octave/octave-2.1.73.ebuild b/sci-mathematics/octave/octave-2.1.73.ebuild
index 247bf1836f8c..cc6465bd9d99 100644
--- a/sci-mathematics/octave/octave-2.1.73.ebuild
+++ b/sci-mathematics/octave/octave-2.1.73.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.73.ebuild,v 1.8 2007/11/20 14:46:56 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.73.ebuild,v 1.9 2007/12/25 01:46:56 nerdboy Exp $
inherit flag-o-matic fortran
@@ -53,20 +53,29 @@ src_compile() {
# mpicc/mpic++
# octave links agains -lmpi by default
# mpich needs -lmpich instead
- if use mpi; then
- CC="mpicc" && CXX="mpiCC"
- if has_version 'sys-cluster/mpich'; then
- myconf="${myconf} --with-mpi=mpich"
+ if use mpi ; then
+ if built_with_use sys-cluster/mpich2 cxx ; then
+ elog "mpich2 must be built without C++ support!"
+ die "please rebuild mpich2 with USE=-cxx..."
+ else
+ CC="mpicc"
+ if has_version 'sys-cluster/mpich' ; then
+ CXX="mpiCC"
+ myconf="${myconf} --with-mpi=mpich"
+ elif has_version 'sys-cluster/mpich2' ; then
+ F77="mpif77"
+ myconf="${myconf} --with-mpi=mpich"
else
- myconf="${myconf} --with-mpi=mpi"
+ myconf="${myconf} --with-mpi=mpi"
fi
+ fi
else
- CC="$(tc-getCC)"
- CXX="$(tc-getCXX)"
- myconf="${myconf} --without-mpi"
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ myconf="${myconf} --without-mpi"
fi
- CC="${CC}" CXX="${CXX}" \
+ CC="${CC}" CXX="${CXX}" F77="${F77}" \
econf \
$(use_with hdf5) \
$(use_enable readline) \