summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-06-20 20:57:18 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-06-20 20:57:18 +0000
commit33d65f31969f6582cd5b45705015262371a7a8e0 (patch)
treec7afd9ddf63dcfe23eadbcca62b8b4d4b2d46515 /sci-mathematics
parentBump per bug #509804. (diff)
downloadgentoo-2-33d65f31969f6582cd5b45705015262371a7a8e0.tar.gz
gentoo-2-33d65f31969f6582cd5b45705015262371a7a8e0.tar.bz2
gentoo-2-33d65f31969f6582cd5b45705015262371a7a8e0.zip
version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/flint/ChangeLog7
-rw-r--r--sci-mathematics/flint/flint-2.4.4.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/sci-mathematics/flint/ChangeLog b/sci-mathematics/flint/ChangeLog
index f9bbbbd89bf4..26d282a38798 100644
--- a/sci-mathematics/flint/ChangeLog
+++ b/sci-mathematics/flint/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/flint
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/flint/ChangeLog,v 1.4 2014/05/18 23:46:28 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/flint/ChangeLog,v 1.5 2014/06/20 20:57:18 hasufell Exp $
+
+*flint-2.4.4 (20 Jun 2014)
+
+ 20 Jun 2014; Julian Ospald <hasufell@gentoo.org> +flint-2.4.4.ebuild:
+ version bump
18 May 2014; Julian Ospald <hasufell@gentoo.org> metadata.xml:
add myself as maintainer
diff --git a/sci-mathematics/flint/flint-2.4.4.ebuild b/sci-mathematics/flint/flint-2.4.4.ebuild
new file mode 100644
index 000000000000..a02be8ffaa0e
--- /dev/null
+++ b/sci-mathematics/flint/flint-2.4.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/flint/flint-2.4.4.ebuild,v 1.1 2014/06/20 20:57:18 hasufell Exp $
+
+EAPI="5"
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Fast Library for Number Theory"
+HOMEPAGE="http://www.flintlib.org/"
+SRC_URI="http://www.flintlib.org/${P}.tar.gz"
+
+RESTRICT="mirror"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gc ntl static-libs test"
+
+RDEPEND="dev-libs/gmp
+ dev-libs/mpfr
+ gc? ( dev-libs/boehm-gc )
+ ntl? ( dev-libs/ntl )"
+DEPEND="${RDEPEND}
+ doc? ( app-text/texlive-core )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.4.3-libdir.patch \
+ "${FILESDIR}"/${PN}-2.4.3-whitespaces.patch \
+ "${FILESDIR}"/${PN}-2.4.3-cflags-ldflags.patch
+}
+
+src_configure() {
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ --with-gmp="${EPREFIX}/usr" \
+ --with-mpfr="${EPREFIX}/usr" \
+ $(usex ntl "--with-ntl=${EPREFIX}/usr" "") \
+ $(use_enable static-libs static) \
+ $(usex gc "--with-gc=${EPREFIX}/usr" "") \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
+ AR=$(tc-getAR) \
+ || die
+}
+
+src_compile() {
+ emake verbose
+
+ if use doc ; then
+ emake -C doc/latex
+ fi
+}
+
+src_test() {
+ emake AT= QUIET_CC= QUIET_CXX= QUIET_AR= check
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="$(get_libdir)" install
+ einstalldocs
+ use doc && dodoc doc/latex/flint-manual.pdf
+}