summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2011-08-27 05:03:22 +0000
committerAndrey Grozin <grozin@gentoo.org>2011-08-27 05:03:22 +0000
commit20e91f07af9d6d65f0079784c8e1c587c7f7fe39 (patch)
tree6118dc9d58f7178e3f49a179d5492fd7ae7444b0 /sci-mathematics
parentFix parallel build #380717 by Cédric Jeanneret, and clean up bind tweaks wit... (diff)
downloadgentoo-2-20e91f07af9d6d65f0079784c8e1c587c7f7fe39.tar.gz
gentoo-2-20e91f07af9d6d65f0079784c8e1c587c7f7fe39.tar.bz2
gentoo-2-20e91f07af9d6d65f0079784c8e1c587c7f7fe39.zip
Fixed LDFLAGS handling in ecl (bug #378195), thanks to jez austin <jezaustin@gmail.com>
(Portage version: 2.2.0_alpha51/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/maxima/ChangeLog7
-rw-r--r--sci-mathematics/maxima/files/maxima-ecl-ldflags.patch27
-rw-r--r--sci-mathematics/maxima/maxima-5.25.0.ebuild5
3 files changed, 37 insertions, 2 deletions
diff --git a/sci-mathematics/maxima/ChangeLog b/sci-mathematics/maxima/ChangeLog
index e4e6ccb35615..8e10eb9c2af7 100644
--- a/sci-mathematics/maxima/ChangeLog
+++ b/sci-mathematics/maxima/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/maxima
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/ChangeLog,v 1.90 2011/08/04 10:33:07 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/ChangeLog,v 1.91 2011/08/27 05:03:22 grozin Exp $
+
+ 27 Aug 2011; Andrey Grozin <grozin@gentoo.org> maxima-5.25.0.ebuild,
+ +files/maxima-ecl-ldflags.patch:
+ Fixed LDFLAGS handling in ecl (bug #378195), thanks to jez austin
+ <jezaustin@gmail.com>
*maxima-5.25.0 (04 Aug 2011)
diff --git a/sci-mathematics/maxima/files/maxima-ecl-ldflags.patch b/sci-mathematics/maxima/files/maxima-ecl-ldflags.patch
new file mode 100644
index 000000000000..e71486fcf736
--- /dev/null
+++ b/sci-mathematics/maxima/files/maxima-ecl-ldflags.patch
@@ -0,0 +1,27 @@
+diff -p -up maxima-5.20.1/src/maxima.system.orig maxima-5.20.1/src/maxima.system
+--- maxima-5.20.1/src/maxima.system.orig 2010-03-04 17:25:38.708483072 -0300
++++ maxima-5.20.1/src/maxima.system 2010-03-04 17:27:27.150481620 -0300
+@@ -44,6 +44,14 @@
+ (c:build-fasl output :lisp-files (list object-output)))))
+
+ #+ecl
++(defun split-ld-flags-for-ecl (string &aux space)
++ (setf string (string-trim '(#\Space) string))
++ (if (setf space (position #\Space string))
++ (cons (subseq string 0 space)
++ (split-ld-flags-for-ecl (subseq string (1+ space))))
++ (cons string nil)))
++
++#+ecl
+ (defun build-maxima-lib ()
+ (labels ((list-all-objects (module)
+ (if (eql (mk::component-type module) :file)
+@@ -66,7 +74,7 @@
+ :ld-flags
+ (let ((x (symbol-value (find-symbol "*AUTOCONF-LD-FLAGS*"
+ (find-package "MAXIMA")))))
+- (if (and x (not (string= x ""))) (list x)))
++ (if (and x (not (string= x ""))) (split-ld-flags-for-ecl x)))
+ :epilogue-code '(progn (require :defsystem)
+ (cl-user::run)))))))
+
diff --git a/sci-mathematics/maxima/maxima-5.25.0.ebuild b/sci-mathematics/maxima/maxima-5.25.0.ebuild
index dfb5818ee647..a5f64db682d0 100644
--- a/sci-mathematics/maxima/maxima-5.25.0.ebuild
+++ b/sci-mathematics/maxima/maxima-5.25.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/maxima-5.25.0.ebuild,v 1.1 2011/08/04 10:33:07 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/maxima-5.25.0.ebuild,v 1.2 2011/08/27 05:03:22 grozin Exp $
EAPI=3
@@ -114,6 +114,9 @@ src_prepare() {
# remove rmaxima if not needed
epatch "${FILESDIR}"/${PN}-rmaxima.patch
+ # fix LDFLAGS handling in ecl (#378195)
+ epatch "${FILESDIR}"/${PN}-ecl-ldflags.patch
+
# bug #343331
rm share/Makefile.in || die
rm src/Makefile.in || die