summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-11-14 04:02:06 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-11-14 04:02:06 +0000
commitda390ece2513acd51dff4b914775971a3689d2c7 (patch)
tree417c45e11f8c1d79a98f057bbf29c0988952b217 /sci-mathematics/yacas
parentVersion bumped. Removed old version. (diff)
downloadgentoo-2-da390ece2513acd51dff4b914775971a3689d2c7.tar.gz
gentoo-2-da390ece2513acd51dff4b914775971a3689d2c7.tar.bz2
gentoo-2-da390ece2513acd51dff4b914775971a3689d2c7.zip
Version bump.
(Portage version: 2.1.2_rc1-r6)
Diffstat (limited to 'sci-mathematics/yacas')
-rw-r--r--sci-mathematics/yacas/ChangeLog7
-rw-r--r--sci-mathematics/yacas/files/digest-yacas-1.0.623
-rw-r--r--sci-mathematics/yacas/yacas-1.0.62.ebuild50
3 files changed, 59 insertions, 1 deletions
diff --git a/sci-mathematics/yacas/ChangeLog b/sci-mathematics/yacas/ChangeLog
index 6d3445b5d9e1..9ca296c3515d 100644
--- a/sci-mathematics/yacas/ChangeLog
+++ b/sci-mathematics/yacas/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/yacas
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/ChangeLog,v 1.11 2006/07/15 22:38:43 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/ChangeLog,v 1.12 2006/11/14 04:02:06 markusle Exp $
+
+*yacas-1.0.62 (14 Nov 2006)
+
+ 14 Nov 2006; Markus Dittrich <markusle@gentoo.org> +yacas-1.0.62.ebuild:
+ Version bump.
15 Jul 2006; Marcus D. Hanwell <cryos@gentoo.org> -files/1.0.57.patch,
-files/opengl-gcc3.4.patch:
diff --git a/sci-mathematics/yacas/files/digest-yacas-1.0.62 b/sci-mathematics/yacas/files/digest-yacas-1.0.62
new file mode 100644
index 000000000000..3165e3fa0316
--- /dev/null
+++ b/sci-mathematics/yacas/files/digest-yacas-1.0.62
@@ -0,0 +1,3 @@
+MD5 31c9b83f21460faca32e1df25ebd1440 yacas-1.0.62.tar.gz 2093683
+RMD160 2354212586334eeb9e6aead3ee341b438bbc4e79 yacas-1.0.62.tar.gz 2093683
+SHA256 17b8fad5e508aefc34495ab61d4b3b350cb378e29ebbde0b7d8cd70d9c840df4 yacas-1.0.62.tar.gz 2093683
diff --git a/sci-mathematics/yacas/yacas-1.0.62.ebuild b/sci-mathematics/yacas/yacas-1.0.62.ebuild
new file mode 100644
index 000000000000..0d0f9e896b38
--- /dev/null
+++ b/sci-mathematics/yacas/yacas-1.0.62.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/yacas-1.0.62.ebuild,v 1.1 2006/11/14 04:02:06 markusle Exp $
+
+inherit eutils flag-o-matic
+
+IUSE="glut"
+
+DESCRIPTION="very powerful general purpose computer algebra system"
+HOMEPAGE="http://yacas.sourceforge.net/"
+SRC_URI="http://${PN}.sourceforge.net/backups/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="virtual/libc
+ >=sys-apps/sed-4
+ dev-lang/perl
+ glut? ( virtual/glut )
+ www-client/lynx"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ if ! use glut; then
+ sed -e 's:opengl::g' -i plugins/Makefile.in || die "sed (opengl) failed"
+ sed -e 's/\(^PLUGINDOCSCHAPTERS.*\)opengl.chapt\(.*\)/\1 \2/' -i \
+ manmake/Makefile.in || die 'sed (manmake) failed'
+ fi
+}
+
+src_compile() {
+ # Filter -Os due to reported issues with it in bug 126779.
+ replace-flags -Os -O2
+ econf --with-numlib=native || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install-strip || die
+
+ dodoc AUTHORS INSTALL NEWS README TODO
+ mv "${D}"/usr/share/${PN}/documentation "${D}"/usr/share/doc/${PF}/html
+ rmdir "${D}"/usr/include/
+ rm "${D}"/usr/share/${PN}/include/win32*
+ sed -e "s|\":FindFile(\"documentation/ref.html\"):\"|localhost/usr/share/doc/${PF}/html/ref.html|" \
+ -e "s|\":FindFile(\"documentation/books.html\"):\"|localhost/usr/share/doc/${PF}/html/books.html|" \
+ -i "${D}"/usr/share/${PN}/yacasinit.ys || die
+}