summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-11-10 23:34:22 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-11-10 23:34:22 +0000
commit5ff053e2adb135fe333b8c56ca25b3f3dba8d4bd (patch)
tree2252e217d0d36b82f157908325d6f2f7b4b4acbe /sci-mathematics/yacas
parentUpdated to new xerces-c interface, along with minor metadata update. (diff)
downloadgentoo-2-5ff053e2adb135fe333b8c56ca25b3f3dba8d4bd.tar.gz
gentoo-2-5ff053e2adb135fe333b8c56ca25b3f3dba8d4bd.tar.bz2
gentoo-2-5ff053e2adb135fe333b8c56ca25b3f3dba8d4bd.zip
Fixed a few java problems, thanks to Serkan, bug #246094
(Portage version: 2.2_rc13/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'sci-mathematics/yacas')
-rw-r--r--sci-mathematics/yacas/ChangeLog7
-rw-r--r--sci-mathematics/yacas/files/yacas-1.2.2-makefixes.patch22
-rw-r--r--sci-mathematics/yacas/yacas-1.0.61.ebuild52
-rw-r--r--sci-mathematics/yacas/yacas-1.2.2.ebuild23
4 files changed, 39 insertions, 65 deletions
diff --git a/sci-mathematics/yacas/ChangeLog b/sci-mathematics/yacas/ChangeLog
index e200074728b7..18020765d642 100644
--- a/sci-mathematics/yacas/ChangeLog
+++ b/sci-mathematics/yacas/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/yacas
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/ChangeLog,v 1.24 2008/11/08 17:20:49 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/ChangeLog,v 1.25 2008/11/10 23:34:22 bicatali Exp $
+
+ 10 Nov 2008; Sébastien Fabbro <bicatalib@gentoo.org>
+ +files/yacas-1.2.2-makefixes.patch, -yacas-1.0.61.ebuild,
+ yacas-1.2.2.ebuild:
+ Fixed a few java problems, thanks to Serkan, bug #246094
08 Nov 2008; Markus Meier <maekke@gentoo.org> yacas-1.2.2.ebuild:
amd64/x86 stable, bug #245708
diff --git a/sci-mathematics/yacas/files/yacas-1.2.2-makefixes.patch b/sci-mathematics/yacas/files/yacas-1.2.2-makefixes.patch
new file mode 100644
index 000000000000..4f4f8acd2125
--- /dev/null
+++ b/sci-mathematics/yacas/files/yacas-1.2.2-makefixes.patch
@@ -0,0 +1,22 @@
+diff -Nur yacas-1.2.2/JavaYacas/makefile.yacas yacas-1.2.2_patched/JavaYacas/makefile.yacas
+--- yacas-1.2.2/JavaYacas/makefile.yacas 2007-09-26 15:08:55.000000000 +0300
++++ yacas-1.2.2_patched/JavaYacas/makefile.yacas 2008-11-10 21:44:41.000000000 +0200
+@@ -1,4 +1,4 @@
+-
++JAVAC?=javac
+ .SUFFIXES: .java .class
+
+ all: net/sf/yacas/CVersion.java yacas.jar hints.txt
+@@ -30,10 +31,10 @@
+ cd ../scripts/ ; jar uvf ../JavaYacas/yacas.jar *
+
+ .java.class:
+- javac $*.java
++ $(JAVAC) $(JAVACFLAGS) $*.java
+
+ net/sf/yacas/CVersion.java: ../config.h dumpversion.cpp
+- g++ dumpversion.cpp -o dumpversion
++ $(CXX) $(CXXFLAGS) dumpversion.cpp -o dumpversion
+ ./dumpversion
+
+
diff --git a/sci-mathematics/yacas/yacas-1.0.61.ebuild b/sci-mathematics/yacas/yacas-1.0.61.ebuild
deleted file mode 100644
index 60785097170a..000000000000
--- a/sci-mathematics/yacas/yacas-1.0.61.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/yacas-1.0.61.ebuild,v 1.4 2007/12/13 11:31:32 markusle Exp $
-
-inherit eutils flag-o-matic
-
-IUSE="glut"
-
-DESCRIPTION="very powerful general purpose computer algebra system"
-HOMEPAGE="http://yacas.sourceforge.net/"
-SRC_URI="http://${PN}.sourceforge.net/backups/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ~ppc x86"
-
-DEPEND="virtual/libc
- >=sys-apps/sed-4
- glut? ( media-libs/glut )
- www-client/lynx"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- if ! use glut; then
- sed -e "s:opengl::g" -i plugins/Makefile.in || die "sed (opengl) failed"
- sed -e "s/\(^PLUGINDOCSCHAPTERS.*\)opengl.chapt\(.*\)/\1 \2/" -i \
- manmake/Makefile.in || die 'sed (manmake) failed'
- sed -e "s:\*INCLUDE opengl.chapt::" \
- -i manmake/plugin-docs.chapt.txt \
- || die "failed to fix plugin-doc.chapt"
- fi
-}
-
-src_compile() {
- # Filter -Os due to reported issues with it in bug 126779.
- replace-flags -Os -O2
- econf --with-numlib=native || die "./configure failed"
- emake || die
-}
-
-src_install() {
- make DESTDIR="${D}" install-strip || die
-
- dodoc AUTHORS INSTALL NEWS README TODO
- mv "${D}"/usr/share/${PN}/documentation "${D}"/usr/share/doc/${PF}/html
- rmdir "${D}"/usr/include/
- rm "${D}"/usr/share/${PN}/include/win32*
- sed -e "s|\":FindFile(\"documentation/ref.html\"):\"|localhost/usr/share/doc/${PF}/html/ref.html|" \
- -e "s|\":FindFile(\"documentation/books.html\"):\"|localhost/usr/share/doc/${PF}/html/books.html|" \
- -i "${D}"/usr/share/${PN}/yacasinit.ys || die
-}
diff --git a/sci-mathematics/yacas/yacas-1.2.2.ebuild b/sci-mathematics/yacas/yacas-1.2.2.ebuild
index 723daf37c5c3..37fbdb1254d8 100644
--- a/sci-mathematics/yacas/yacas-1.2.2.ebuild
+++ b/sci-mathematics/yacas/yacas-1.2.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/yacas-1.2.2.ebuild,v 1.5 2008/11/08 17:20:49 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/yacas-1.2.2.ebuild,v 1.6 2008/11/10 23:34:22 bicatali Exp $
-inherit eutils java
+inherit eutils java-pkg-opt-2
DESCRIPTION="Powerful general purpose computer algebra system"
HOMEPAGE="http://yacas.sourceforge.net/"
@@ -14,13 +14,14 @@ KEYWORDS="amd64 ppc x86"
IUSE="doc java server"
-RDEPEND="java? ( >=virtual/jdk-1.6 )"
-DEPEND="java? ( >=virtual/jre-1.6 )"
+DEPEND="java? ( >=virtual/jdk-1.6 )"
+RDEPEND="java? ( >=virtual/jre-1.6 )"
src_unpack() {
unpack ${A}
- cd "${S}"
+ cd "${S}" || die
epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}"/${P}-makefixes.patch
}
src_compile() {
@@ -31,7 +32,7 @@ src_compile() {
|| die "econf failed"
emake || die "emake failed"
if use java; then
- cd JavaYacas
+ cd JavaYacas || die
emake -f makefile.yacas || die "emake java interface failed"
fi
}
@@ -40,12 +41,10 @@ src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS README TODO || die
if use java; then
- cd JavaYacas
+ cd JavaYacas || die
+ java-pkg_dojar yacas.jar
+ java-pkg_dolauncher jyacas --main net.sf.yacas.YacasConsole
insinto /usr/share/${PN}
- doins yacas.jar hints.txt yacasconsole.html || die "doins java interface failed"
- echo "#!/bin/sh" > jyacas
- echo "java -jar /usr/share/${PN}/yacas.jar" >> jyacas
- exeinto /usr/bin
- doexe jyacas
+ doins hints.txt yacasconsole.html || die "doins java resources failed"
fi
}