summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2010-01-12 13:41:48 +0000
committerMarkus Dittrich <markusle@gentoo.org>2010-01-12 13:41:48 +0000
commit7d257541f90df0b99aa87e7aae1efe43cb2451bc (patch)
treeff291102632fdf1ea2505cdc84e36377471c965f /sci-mathematics/octave
parentadd ~x86, bug 297725 (diff)
downloadgentoo-2-7d257541f90df0b99aa87e7aae1efe43cb2451bc.tar.gz
gentoo-2-7d257541f90df0b99aa87e7aae1efe43cb2451bc.tar.bz2
gentoo-2-7d257541f90df0b99aa87e7aae1efe43cb2451bc.zip
New revision pulls in sci-libs/qrupdate so everybody gets fast QR & Cholesky updating functions.
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/octave')
-rw-r--r--sci-mathematics/octave/ChangeLog11
-rw-r--r--sci-mathematics/octave/octave-3.2.3-r1.ebuild104
2 files changed, 113 insertions, 2 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index 129c2c0e04d4..630d0d72c3df 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-mathematics/octave
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.79 2009/11/04 11:26:39 markusle Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.80 2010/01/12 13:41:48 markusle Exp $
+
+*octave-3.2.3-r1 (12 Jan 2010)
+
+ 12 Jan 2010; Markus Dittrich <markusle@gentoo.org>
+ +octave-3.2.3-r1.ebuild:
+ New revision pulls in sci-libs/qrupdate so everybody gets fast QR & Cholesky
+ updating functions.
*octave-3.2.3 (04 Nov 2009)
diff --git a/sci-mathematics/octave/octave-3.2.3-r1.ebuild b/sci-mathematics/octave/octave-3.2.3-r1.ebuild
new file mode 100644
index 000000000000..6ccbb34b7810
--- /dev/null
+++ b/sci-mathematics/octave/octave-3.2.3-r1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.2.3-r1.ebuild,v 1.1 2010/01/12 13:41:48 markusle Exp $
+
+EAPI="2"
+inherit flag-o-matic fortran xemacs-elisp-common
+
+DESCRIPTION="High-level interactive language for numerical computations"
+LICENSE="GPL-3"
+HOMEPAGE="http://www.octave.org/"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+IUSE="emacs readline zlib doc hdf5 curl fftw xemacs sparse"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="virtual/lapack
+ dev-libs/libpcre
+ sys-libs/ncurses
+ sci-visualization/gnuplot
+ >=sci-mathematics/glpk-4.15
+ media-libs/qhull
+ sci-libs/qrupdate
+ fftw? ( >=sci-libs/fftw-3.1.2 )
+ zlib? ( sys-libs/zlib )
+ hdf5? ( sci-libs/hdf5 )
+ curl? ( net-misc/curl )
+ xemacs? ( app-editors/xemacs )
+ sparse? ( sci-libs/umfpack
+ sci-libs/arpack
+ sci-libs/colamd
+ sci-libs/camd
+ sci-libs/ccolamd
+ sci-libs/cholmod
+ sci-libs/cxsparse )
+ !sci-mathematics/octave-forge"
+
+DEPEND="${RDEPEND}
+ virtual/latex-base
+ sys-apps/texinfo
+ || ( dev-texlive/texlive-genericrecommended
+ app-text/ptex )
+ dev-util/gperf
+ dev-util/pkgconfig"
+
+FORTRAN="gfortran ifc g77 f2c"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.2.0_parallel_make.patch
+ epatch "${FILESDIR}"/${PN}-3.2.0_as_needed.patch
+}
+
+src_configure() {
+ econf \
+ --localstatedir=/var/state/octave \
+ --enable-shared \
+ --with-blas="$(pkg-config --libs blas)" \
+ --with-lapack="$(pkg-config --libs lapack)" \
+ --with-qrupdate \
+ $(use_with hdf5) \
+ $(use_with curl) \
+ $(use_with zlib) \
+ $(use_with fftw) \
+ $(use_with sparse arpack) \
+ $(use_with sparse umfpack) \
+ $(use_with sparse colamd) \
+ $(use_with sparse ccolamd) \
+ $(use_with sparse cholmod) \
+ $(use_with sparse cxsparse) \
+ $(use_enable readline)
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ if use xemacs; then
+ cd "${S}/emacs"
+ xemacs-elisp-comp *.el
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+
+ if use doc; then
+ einfo "Installing documentation..."
+ insinto /usr/share/doc/${PF}
+ doins $(find doc -name \*.pdf)
+ fi
+
+ if use emacs || use xemacs; then
+ cd emacs
+ exeinto /usr/bin
+ doexe octave-tags || die "Failed to install octave-tags"
+ doman octave-tags.1 || die "Failed to install octave-tags.1"
+ if use xemacs; then
+ xemacs-elisp-install ${PN} *.el *.elc
+ fi
+ cd ..
+ fi
+
+ echo "LDPATH=/usr/$(get_libdir)/octave-${PV}" > 99octave
+ doenvd 99octave || die
+}