summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2011-05-08 15:13:58 +0000
committerMichael Januszewski <spock@gentoo.org>2011-05-08 15:13:58 +0000
commitdcf474a22c983d1e0e30d1c9099c5b030b619c7f (patch)
tree57c2a15089230cbeaddc9ed10ef1dd54c5cb827f /sci-mathematics/gimps
parentRemoved sqlite USE flag in 4.9.x since it's not supported anymore. (diff)
downloadgentoo-2-dcf474a22c983d1e0e30d1c9099c5b030b619c7f.tar.gz
gentoo-2-dcf474a22c983d1e0e30d1c9099c5b030b619c7f.tar.bz2
gentoo-2-dcf474a22c983d1e0e30d1c9099c5b030b619c7f.zip
Version bump (bug #363053).
(Portage version: 2.1.9.47/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/gimps')
-rw-r--r--sci-mathematics/gimps/ChangeLog7
-rw-r--r--sci-mathematics/gimps/gimps-26.6.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/sci-mathematics/gimps/ChangeLog b/sci-mathematics/gimps/ChangeLog
index cb1ede018752..d3d10509d78e 100644
--- a/sci-mathematics/gimps/ChangeLog
+++ b/sci-mathematics/gimps/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/gimps
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gimps/ChangeLog,v 1.39 2011/03/16 23:11:28 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gimps/ChangeLog,v 1.40 2011/05/08 15:13:58 spock Exp $
+
+*gimps-26.6 (08 May 2011)
+
+ 08 May 2011; Michał Januszewski <spock@gentoo.org> +gimps-26.6.ebuild:
+ Version bump (bug #363053).
*gimps-26.5 (16 Mar 2011)
diff --git a/sci-mathematics/gimps/gimps-26.6.ebuild b/sci-mathematics/gimps/gimps-26.6.ebuild
new file mode 100644
index 000000000000..5ed09f38b40a
--- /dev/null
+++ b/sci-mathematics/gimps/gimps-26.6.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gimps/gimps-26.6.ebuild,v 1.1 2011/05/08 15:13:58 spock Exp $
+
+IUSE=""
+DESCRIPTION="GIMPS - The Great Internet Mersenne Prime Search"
+HOMEPAGE="http://mersenne.org/"
+SRC_URI="amd64? ( ftp://mersenne.org/gimps/mprime${PV/./}-linux64.tar.gz )
+ x86? ( ftp://mersenne.org/gimps/mprime${PV/./}.tar.gz )"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="-* ~amd64 ~x86"
+
+# Since there are no statically linked binaries for this version of mprime,
+# and no static binaries for amd64 in general, we use the dynamically linked
+# ones and try to cover the .so deps with the packages listed in RDEPEND.
+DEPEND=""
+RDEPEND="net-misc/curl"
+
+S="${WORKDIR}"
+I="/opt/gimps"
+
+src_install() {
+ dodir ${I} /var/lib/gimps
+ cp mprime "${D}/${I}"
+ chmod a-w "${D}/${I}/mprime"
+ chown root:0 "${D}/${I}"
+ chown root:0 "${D}/${I}/mprime"
+
+ dodoc license.txt readme.txt stress.txt whatsnew.txt undoc.txt
+
+ newinitd "${FILESDIR}/gimps-25.6-init.d" gimps
+ newconfd "${FILESDIR}/gimps-25.6-conf.d" gimps
+}
+
+pkg_postinst() {
+ echo
+ einfo "You can use \`/etc/init.d/gimps start\` to start a GIMPS client in the"
+ einfo "background at boot. Have a look at /etc/conf.d/gimps and check some"
+ einfo "configuration options."
+ einfo
+ einfo "If you don't want to use the init script to start gimps, remember to"
+ einfo "pass it an additional command line parameter specifying where the data"
+ einfo "files are to be stored, e.g.:"
+ einfo " ${I}/mprime -w/var/lib/gimps"
+ echo
+}
+
+pkg_postrm() {
+ echo
+ einfo "GIMPS data files were not removed."
+ einfo "Remove them manually from /var/lib/gimps/"
+ echo
+}