summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-05-23 18:17:39 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-05-23 18:17:39 +0000
commitedddd6902a8f22d6916e6a38c5dfe9d608cbce55 (patch)
tree385331359d0040ae75da8f3d8122a18efecc5f84 /sci-mathematics/fann
parentThe glint driver is broken completely currently (diff)
downloadgentoo-2-edddd6902a8f22d6916e6a38c5dfe9d608cbce55.tar.gz
gentoo-2-edddd6902a8f22d6916e6a38c5dfe9d608cbce55.tar.bz2
gentoo-2-edddd6902a8f22d6916e6a38c5dfe9d608cbce55.zip
Version bump, beta recommended by upstream, closing bug #199785.
(Portage version: 2.1.5.2)
Diffstat (limited to 'sci-mathematics/fann')
-rw-r--r--sci-mathematics/fann/ChangeLog11
-rw-r--r--sci-mathematics/fann/fann-2.1.0_beta.ebuild74
-rw-r--r--sci-mathematics/fann/files/fann-2.1.0_beta-benchmark.patch80
-rw-r--r--sci-mathematics/fann/files/fann-2.1.0_beta-examples.patch23
-rw-r--r--sci-mathematics/fann/files/fann-2.1.0_beta-python.patch20
-rw-r--r--sci-mathematics/fann/metadata.xml18
6 files changed, 216 insertions, 10 deletions
diff --git a/sci-mathematics/fann/ChangeLog b/sci-mathematics/fann/ChangeLog
index 4173941956f2..6c6942e807f8 100644
--- a/sci-mathematics/fann/ChangeLog
+++ b/sci-mathematics/fann/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sci-mathematics/fann
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fann/ChangeLog,v 1.11 2008/05/12 13:10:17 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fann/ChangeLog,v 1.12 2008/05/23 18:17:38 bicatali Exp $
+
+*fann-2.1.0_beta (23 May 2008)
+
+ 23 May 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/fann-2.1.0_beta-benchmark.patch,
+ +files/fann-2.1.0_beta-examples.patch,
+ +files/fann-2.1.0_beta-python.patch, metadata.xml,
+ +fann-2.1.0_beta.ebuild:
+ Version bump, beta recommended by upstream, closing bug #199785.
12 May 2008; Markus Dittrich <markusle@gentoo.org> fann-1.2.0.ebuild,
fann-1.2.0-r1.ebuild, fann-2.0.0.ebuild:
diff --git a/sci-mathematics/fann/fann-2.1.0_beta.ebuild b/sci-mathematics/fann/fann-2.1.0_beta.ebuild
new file mode 100644
index 000000000000..e7380eafe309
--- /dev/null
+++ b/sci-mathematics/fann/fann-2.1.0_beta.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fann/fann-2.1.0_beta.ebuild,v 1.1 2008/05/23 18:17:38 bicatali Exp $
+
+inherit eutils python
+
+MY_P=${P/_/}
+DESCRIPTION="Fast Artificial Neural Network Library"
+HOMEPAGE="http://leenissen.dk/fann/"
+SRC_URI="mirror://sourceforge/fann/${MY_P}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc python"
+
+RDEPEND="python? ( virtual/python )"
+DEPEND="${RDEPEND}
+ python? ( dev-lang/swig )
+ app-arch/unzip"
+
+
+S="${WORKDIR}/${P/_beta/}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-python.patch
+ epatch "${FILESDIR}"/${P}-benchmark.patch
+ epatch "${FILESDIR}"/${P}-examples.patch
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+ if use python; then
+ cd "${S}"/python
+ python_version
+ emake PYTHON_VERSION="${PYVER}" || die "emake python failed"
+ fi
+}
+
+src_test() {
+ cd "${S}"/examples
+ emake CFLAGS="${CFLAGS} -I../src/include -L../src/.libs" \
+ || die "emake examples failed"
+ LD_LIBRARY_PATH="../src/.libs" emake runtest || die "tests failed"
+ emake clean
+ if use python; then
+ cd "${S}"/python
+ emake test || die "failed tests for python wrappers"
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+
+ if use doc; then
+ dodoc doc/*.txt || die "failed to install docs"
+ insinto /usr/share/doc/${PF}
+ doins doc/fann_en.pdf || die "failed to install reference manual"
+ doins -r examples || die "failed to install examples"
+ doins -r benchmarks || die "failed to install benchmarks"
+ fi
+
+ if use python; then
+ cd "${S}"/python
+ emake install ROOT="${D}" || die "failed to install python wrappers"
+ if use doc; then
+ insinto /usr/share/doc/${PF}/examples/python
+ doins -r examples || die "failed to install python examples"
+ fi
+ fi
+}
diff --git a/sci-mathematics/fann/files/fann-2.1.0_beta-benchmark.patch b/sci-mathematics/fann/files/fann-2.1.0_beta-benchmark.patch
new file mode 100644
index 000000000000..60933e5e361f
--- /dev/null
+++ b/sci-mathematics/fann/files/fann-2.1.0_beta-benchmark.patch
@@ -0,0 +1,80 @@
+--- benchmarks/Makefile.orig 2008-04-22 10:16:48.664395478 +0000
++++ benchmarks/Makefile 2008-04-22 10:59:59.815994915 +0000
+@@ -1,43 +1,35 @@
+-# The jneural library (http://voltar-confed.org/jneural/) and lwneuralnet library (http://sourceforge.net/projects/lwneuralnet/) needs to be installed in order to run the benchmarks
+-
+-GCC = gcc
+-G++ = g++
++# The jneural library (http://voltar-confed.org/jneural/) and lwneuralnet library (http://sourceforge.net/projects/lwneuralnet/) needs to be installed in order to run the benchmarks with EXTRA_NEURALS
+
+ TARGETS = quality quality_fixed performance performance_fixed shuffle parity two-spirals
+
+-CFLAGS = -O3 -finline-functions -funroll-loops -Werror
+-
+ LFLAGS = -lm
+-
+-JNEURALDIR = ../../libraries/jneural/
+-
+-LWNNDIR = ../../libraries/lwneuralnet-0.8/source/
++#EXTRA_NEURALS="-llwneuralnet -ljneural -DJNEURAL"
+
+ all: $(TARGETS)
+
+ quality: quality.cc
+- $(G++) $(CFLAGS) $(LFLAGS) -I$(JNEURALDIR)include/ -L$(JNEURALDIR) -I$(LWNNDIR) -L$(LWNNDIR) $< -o $@ -lfloatfann -llwneuralnet -ljneural -lfl
++ $(CXX) $(CXXFLAGS) $(LFLAGS) $< -o $@ -lfloatfann -lfl $(EXTRA_NEURALS)
+
+ quality_fixed: quality_fixed.c
+- $(GCC) $(CFLAGS) $(LFLAGS) $< -o $@ -lfixedfann
++ $(CC) $(CFLAGS) $(LFLAGS) $< -o $@ -lfixedfann
+
+ quality_fixed_debug: quality_fixed.c
+- $(GCC) -ggdb -lm -DDEBUG -Wall -ansi -I../src/ -I../src/include/ ../src/fixedfann.c $< -o $@
++ $(CC) -ggdb -lm -DDEBUG -Wall -ansi -I../src/ -I../src/include/ ../src/fixedfann.c $< -o $@
+
+ performance: performance.cc
+- $(G++) $(CFLAGS) $(LFLAGS) -I$(JNEURALDIR)include/ -L$(JNEURALDIR) -I$(LWNNDIR) -L$(LWNNDIR) $< -o $@ -lfloatfann -llwneuralnet -ljneural -lfl
++ $(CXX) $(CXXFLAGS) $(LFLAGS) $< -o $@ -lfloatfann -lfl $(EXTRA_NEURALS)
+
+ performance_fixed: performance.cc
+- $(G++) $(CFLAGS) $(LFLAGS) -DFIXEDFANN $< -o $@ -lfixedfann
++ $(CXX) $(CXXFLAGS) $(LFLAGS) -DFIXEDFANN $< -o $@ -lfixedfann
+
+ shuffle: shuffle.c
+- $(GCC) $(CFLAGS) $(LFLAGS) $< -o $@ -lfloatfann
++ $(CC) $(CFLAGS) $(LFLAGS) $< -o $@ -lfloatfann
+
+ two-spirals: two-spirals.c
+- $(GCC) $(CFLAGS) $(LFLAGS) $< -o $@
++ $(CC) $(CFLAGS) $(LFLAGS) $< -o $@
+
+ parity: parity.c
+- $(GCC) $(CFLAGS) $(LFLAGS) $< -o $@
++ $(CC) $(CFLAGS) $(LFLAGS) $< -o $@
+
+ clean:
+ rm -rf -- $(TARGETS) *~
+--- benchmarks/performance.cc.orig 2008-04-22 10:24:38.604894867 +0000
++++ benchmarks/performance.cc 2008-04-22 10:26:57.436806446 +0000
+@@ -19,9 +19,6 @@
+
+ //uncomment lines below to benchmark the libraries
+
+-#define JNEURAL
+-#define LWNN
+-
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+--- benchmarks/quality.cc.orig 2008-04-22 10:59:27.814171235 +0000
++++ benchmarks/quality.cc 2008-04-22 10:59:39.570841209 +0000
+@@ -19,9 +19,6 @@
+
+ //uncomment lines below to benchmark the libraries
+
+-#define JNEURAL
+-#define LWNN
+-
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
diff --git a/sci-mathematics/fann/files/fann-2.1.0_beta-examples.patch b/sci-mathematics/fann/files/fann-2.1.0_beta-examples.patch
new file mode 100644
index 000000000000..45bfdd02b384
--- /dev/null
+++ b/sci-mathematics/fann/files/fann-2.1.0_beta-examples.patch
@@ -0,0 +1,23 @@
+--- examples/Makefile.orig 2008-04-22 10:15:42.500625020 +0000
++++ examples/Makefile 2008-04-22 10:16:40.563933859 +0000
+@@ -1,18 +1,16 @@
+ # This makefile is on purpose not made with configure, to show how to use the library
+ # The make file requires that the fann library is installed (see ../README)
+
+-GCC=gcc
+-
+ TARGETS = xor_train xor_test xor_test_fixed simple_train steepness_train simple_test robot mushroom cascade_train scaling_test scaling_train
+ DEBUG_TARGETS = xor_train_debug xor_test_debug xor_test_fixed_debug cascade_train_debug
+
+ all: $(TARGETS)
+
+ %: %.c Makefile
+- $(GCC) -O3 $< -o $@ -lm -lfann
++ $(CC) $(CFLAGS) $< -o $@ -lm -lfann
+
+ %_fixed: %.c Makefile
+- $(GCC) -O3 -DFIXEDFANN $< -o $@ -lm -lfixedfann
++ $(CC) $(CFLAGS) -DFIXEDFANN $< -o $@ -lm -lfixedfann
+
+ clean:
+ rm -f $(TARGETS) $(DEBUG_TARGETS) xor_fixed.data *.net *~ *.obj *.exe *.tds noscale.txt withscale.txt scale_test_results.txt
diff --git a/sci-mathematics/fann/files/fann-2.1.0_beta-python.patch b/sci-mathematics/fann/files/fann-2.1.0_beta-python.patch
new file mode 100644
index 000000000000..6c6a68201b59
--- /dev/null
+++ b/sci-mathematics/fann/files/fann-2.1.0_beta-python.patch
@@ -0,0 +1,20 @@
+--- python/setup.py.orig 2008-04-22 10:11:05.284827392 +0000
++++ python/setup.py 2008-04-22 10:13:21.668599460 +0000
+@@ -9,7 +9,7 @@
+ import os
+
+ NAME='pyfann'
+-VERSION='2.0.0'
++VERSION='2.1.0'
+
+ LONG_DESCRIPTION="""\
+ Fast Artificial Neural Network Library implements multilayer
+@@ -42,7 +42,7 @@
+ py_modules=['pyfann.libfann'],
+ ext_modules=[Extension('pyfann._libfann',['pyfann/pyfann_wrap.cxx'],
+ include_dirs=['../src/include'],
+- extra_objects=['../src/doublefann.o'],
++ extra_objects=['../src/.libs/doublefann.o'],
+ define_macros=[("SWIG_COMPILE",None)]
+ ),
+ ]
diff --git a/sci-mathematics/fann/metadata.xml b/sci-mathematics/fann/metadata.xml
index f535a709598f..971b62a31019 100644
--- a/sci-mathematics/fann/metadata.xml
+++ b/sci-mathematics/fann/metadata.xml
@@ -1,13 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-mathematics</herd>
- <longdescription lang="en">
- Fast Artificial Neural Network Library implements multilayer artificial
- neural networks in C with support for both fully connected and sparsely
- connected networks. Cross-platform execution in both fixed and floating
- point are supported. It includes a framework for easy handling of
- training data sets. It is easy to use, versatile, well documented, and
- fast. Delphi, PHP, Python and other bindings are available.
- </longdescription>
+ <herd>sci-mathematics</herd>
+ <longdescription lang="en">
+ Fast Artificial Neural Network Library implements multilayer artificial
+ neural networks in C with support for both fully connected and sparsely
+ connected networks. Cross-platform execution in both fixed and floating
+ point are supported. It includes a framework for easy handling of
+ training data sets. It is easy to use, versatile, well documented, and
+ fast. Delphi, PHP, Python and other bindings are available.
+ </longdescription>
</pkgmetadata>