summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2008-03-14 10:54:33 +0000
committerChristian Heim <phreak@gentoo.org>2008-03-14 10:54:33 +0000
commit3fd131a5f8d0f1ade5b36987598d0b462fc7d5ef (patch)
tree66eb5cad6c924138fc9db8b69d6a914a04cfd650 /sci-mathematics/fann
parentRemoving Christian Andreetta (satya, #48841) from metadata.xml. (diff)
downloadgentoo-2-3fd131a5f8d0f1ade5b36987598d0b462fc7d5ef.tar.gz
gentoo-2-3fd131a5f8d0f1ade5b36987598d0b462fc7d5ef.tar.bz2
gentoo-2-3fd131a5f8d0f1ade5b36987598d0b462fc7d5ef.zip
Fixing the minor syntax errors. Adding some style.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-mathematics/fann')
-rw-r--r--sci-mathematics/fann/ChangeLog6
-rw-r--r--sci-mathematics/fann/fann-1.2.0-r1.ebuild55
-rw-r--r--sci-mathematics/fann/fann-1.2.0.ebuild53
-rw-r--r--sci-mathematics/fann/fann-2.0.0.ebuild18
4 files changed, 68 insertions, 64 deletions
diff --git a/sci-mathematics/fann/ChangeLog b/sci-mathematics/fann/ChangeLog
index f32134b207ea..fc64e40ac21a 100644
--- a/sci-mathematics/fann/ChangeLog
+++ b/sci-mathematics/fann/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/fann
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fann/ChangeLog,v 1.9 2008/03/14 10:42:39 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fann/ChangeLog,v 1.10 2008/03/14 10:54:33 phreak Exp $
+
+ 14 Mar 2008; Christian Heim <phreak@gentoo.org> fann-1.2.0.ebuild,
+ fann-1.2.0-r1.ebuild, fann-2.0.0.ebuild:
+ Fixing the minor syntax errors. Adding some style.
14 Mar 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing Christian Andreetta (satya, #48841) from metadata.xml.
diff --git a/sci-mathematics/fann/fann-1.2.0-r1.ebuild b/sci-mathematics/fann/fann-1.2.0-r1.ebuild
index 618aefcaa7b3..cc47a0416a8d 100644
--- a/sci-mathematics/fann/fann-1.2.0-r1.ebuild
+++ b/sci-mathematics/fann/fann-1.2.0-r1.ebuild
@@ -1,68 +1,69 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fann/fann-1.2.0-r1.ebuild,v 1.3 2007/07/13 05:28:09 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fann/fann-1.2.0-r1.ebuild,v 1.4 2008/03/14 10:54:33 phreak Exp $
inherit eutils
-#-----------------------------------------------------------------------------
+
MY_PKG_NAME=${PN}-${PV/-.*/}
DESCRIPTION="Fast Artificial Neural Network Library implements multilayer artificial neural networks in C"
HOMEPAGE="http://fann.sourceforge.net/"
SRC_URI="mirror://sourceforge/fann/${MY_PKG_NAME}.tar.bz2"
-#-----------------------------------------------------------------------------
+
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~x86"
IUSE="doc python"
-#-----------------------------------------------------------------------------
+
DEPEND="sys-devel/autoconf
sys-apps/sed
doc? ( app-text/docbook-sgml-utils )
python? ( dev-lang/python dev-lang/swig )"
-#-----------------------------------------------------------------------------
+
S=${WORKDIR}/${MY_PKG_NAME}
-#=============================================================================
+
src_unpack() {
- unpack ${A} || die
- cd ${S} || die
- epatch ${FILESDIR}/${PF}.patch
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PF}.patch
}
-#=============================================================================
+
src_compile() {
local myconf
myconf="--prefix=/usr"
- cd ${S} || die
- econf ${myconf} || die
- emake || die
+
+ econf ${myconf} || die "econf failed!"
+ emake || die "emake failed!"
+
if use python; then
- einfo "python ------------------------------"
- cd ${S}/python || die
+ cd "${S}"/python
#mkdir fann
#for f in `ls *py |grep -v setup.py`; do
# mv $f fann || die
#done
python setup_unix.py build
+ cd "${S}"
fi
}
-#=============================================================================
+
src_install() {
- cd ${S}
- make install DESTDIR=${D} || die
+ make install DESTDIR="${D}" || die
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+
if use doc; then
- einfo "doc ---------------------------------"
- dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
insinto /usr/share/doc/${PF}/benchmarks
- cp -pPR ${S}/benchmarks/* ${D}/usr/share/doc/${PF}/benchmarks
+ cp -pPR "${S}"/benchmarks/* "${D}"/usr/share/doc/${PF}/benchmarks
insinto /usr/share/doc/${PF}/examples/c
- doins ${S}/examples/*
+ doins "${S}"/examples/*
insinto /usr/share/doc/${PF}/html
- cp -pPR doc/html/* ${D}/usr/share/doc/${PF}/html
+ cp -pPR doc/html/* "${D}"/usr/share/doc/${PF}/html
insinto /usr/share/doc/${PF}/pdf
doins doc/*pdf
fi
+
if use python; then
- einfo "python ------------------------------"
- cd ${S}/python || die
- python setup_unix.py install --root=${D} || die "No python"
+ cd "${S}"/python
+ python setup_unix.py install --root="${D}" || die "python setup failed!"
if use doc; then
local python_doc_dir="/usr/share/doc/${PF}/examples/python"
insinto ${python_doc_dir}
diff --git a/sci-mathematics/fann/fann-1.2.0.ebuild b/sci-mathematics/fann/fann-1.2.0.ebuild
index a068afed8cd5..34cfae29e23f 100644
--- a/sci-mathematics/fann/fann-1.2.0.ebuild
+++ b/sci-mathematics/fann/fann-1.2.0.ebuild
@@ -1,66 +1,65 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fann/fann-1.2.0.ebuild,v 1.4 2007/07/13 05:28:09 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fann/fann-1.2.0.ebuild,v 1.5 2008/03/14 10:54:33 phreak Exp $
inherit eutils
-#-----------------------------------------------------------------------------
+
DESCRIPTION="Fast Artificial Neural Network Library implements multilayer artificial neural networks in C"
HOMEPAGE="http://fann.sourceforge.net/"
SRC_URI="mirror://sourceforge/fann/${PF}.tar.bz2"
-#-----------------------------------------------------------------------------
+
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~x86"
IUSE="doc python"
-#-----------------------------------------------------------------------------
+
DEPEND="sys-devel/autoconf
sys-apps/sed
doc? ( app-text/docbook-sgml-utils )
python? ( dev-lang/python dev-lang/swig )"
-#-----------------------------------------------------------------------------
+
S=${WORKDIR}/${PF}
-#=============================================================================
+
src_unpack() {
- unpack ${A} || die
- cd ${S} || die
- cp ${FILESDIR}/${PF}-setup.py ${S}/python/setup.py
+ unpack ${A}
+ cd "${S}"
+ cp "${FILESDIR}"/${PF}-setup.py "${S}"/python/setup.py
}
-#=============================================================================
+
src_compile() {
local myconf
myconf="--prefix=/usr"
- cd ${S} || die
- econf ${myconf} || die
- emake || die
+
+ cd "${S}"
+ econf ${myconf} || die "econf failed!"
+ emake || die "emake failed!"
if use python; then
- einfo "python ------------------------------"
- cd ${S}/python || die
+ cd "${S}"/python || die
mkdir fann
for f in `ls *py |grep -v setup.py`; do
mv $f fann || die
done
+ cd "${S}"
fi
}
-#=============================================================================
+
src_install() {
- cd ${S}
- make install DESTDIR=${D} || die
+ make install DESTDIR="${D}" || die "make install failed!"
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+
if use doc; then
- einfo "doc ---------------------------------"
- dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
insinto /usr/share/doc/${PF}/benchmarks
- cp -pPR ${S}/benchmarks/* ${D}/usr/share/doc/${PF}/benchmarks
+ cp -pPR "${S}"/benchmarks/* "${D}"/usr/share/doc/${PF}/benchmarks
insinto /usr/share/doc/${PF}/examples/c
- doins ${S}/examples/*
+ doins "${S}"/examples/*
insinto /usr/share/doc/${PF}/html
- cp -pPR doc/html/* ${D}/usr/share/doc/${PF}/html
+ cp -pPR doc/html/* "${D}"/usr/share/doc/${PF}/html
insinto /usr/share/doc/${PF}/pdf
doins doc/*pdf
fi
if use python; then
- einfo "python ------------------------------"
- cd ${S}/python || die
- python setup.py install --root=${D} || die "No python"
+ cd "${S}"/python || die
+ python setup.py install --root="${D}" || die "python setup failed!"
if use doc; then
local python_doc_dir="/usr/share/doc/${PF}/examples/python"
insinto ${python_doc_dir}
diff --git a/sci-mathematics/fann/fann-2.0.0.ebuild b/sci-mathematics/fann/fann-2.0.0.ebuild
index 2c0370c88d98..2e736fce38c1 100644
--- a/sci-mathematics/fann/fann-2.0.0.ebuild
+++ b/sci-mathematics/fann/fann-2.0.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fann/fann-2.0.0.ebuild,v 1.4 2007/07/13 05:28:09 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fann/fann-2.0.0.ebuild,v 1.5 2008/03/14 10:54:33 phreak Exp $
inherit eutils
@@ -16,8 +16,8 @@ IUSE="doc python"
DEPEND="python? ( dev-lang/python dev-lang/swig )"
src_unpack() {
- unpack ${A} || die
- cd "${S}" || die
+ unpack ${A}
+ cd "${S}"
epatch "${FILESDIR}"/${P}-shared-libs-gentoo.patch
epatch "${FILESDIR}"/${P}-benchmark.patch
}
@@ -26,15 +26,15 @@ src_compile() {
econf ${myconf} || die "configure failed"
emake || die "failed to build src"
if use python; then
- cd ${S}/python || \
+ cd "${S}"/python || \
die "failed to step into python subdirectory"
emake || die "failed to build python wrappers"
+ cd "${S}"
fi
}
src_install() {
- cd "${S}"
- make install DESTDIR=${D} || die "install failed"
+ make install DESTDIR="${D}" || die "install failed"
dodoc AUTHORS ChangeLog NEWS README TODO
if use doc; then
@@ -52,9 +52,9 @@ src_install() {
fi
if use python; then
- cd ${S}/python || \
+ cd "${S}"/python || \
die "Faild to step into python subdirectory"
- make install ROOT=${D} || \
+ make install ROOT="${D}" || \
die "failed to install python wrappers"
if use doc; then
local python_doc_dir="/usr/share/${PN}/examples/python"