summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-10-26 14:40:18 +0000
committerJustin Lecher <jlec@gentoo.org>2014-10-26 14:40:18 +0000
commit2c958f356c69453265e8acfa74f19cde9d225264 (patch)
treedc5039a7b2a02c60df06e86c8cd707f28057a00a /sci-mathematics/dataplot/dataplot-20090821.ebuild
parentnet-analyzer/ospd: Initial commit, written by me (diff)
downloadgentoo-2-2c958f356c69453265e8acfa74f19cde9d225264.tar.gz
gentoo-2-2c958f356c69453265e8acfa74f19cde9d225264.tar.bz2
gentoo-2-2c958f356c69453265e8acfa74f19cde9d225264.zip
sci-mathematics/dataplot: Drop bashisms from configure.ac, #526888
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-mathematics/dataplot/dataplot-20090821.ebuild')
-rw-r--r--sci-mathematics/dataplot/dataplot-20090821.ebuild27
1 files changed, 11 insertions, 16 deletions
diff --git a/sci-mathematics/dataplot/dataplot-20090821.ebuild b/sci-mathematics/dataplot/dataplot-20090821.ebuild
index 653b48046e19..626821da5313 100644
--- a/sci-mathematics/dataplot/dataplot-20090821.ebuild
+++ b/sci-mathematics/dataplot/dataplot-20090821.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/dataplot/dataplot-20090821.ebuild,v 1.6 2012/10/16 19:13:05 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/dataplot/dataplot-20090821.ebuild,v 1.7 2014/10/26 14:40:18 jlec Exp $
-EAPI=4
+EAPI=5
inherit eutils fortran-2 toolchain-funcs autotools
@@ -39,19 +39,19 @@ S_AUX="${WORKDIR}/${MY_P_AUX}"
src_unpack() {
# unpacking and renaming because
# upstream does not use directories
- mkdir "${S_AUX}"
- pushd "${S_AUX}" > /dev/null
+ mkdir "${S_AUX}" || die
+ pushd "${S_AUX}" > /dev/null || die
unpack ${MY_P_AUX}.tar.gz
- popd > /dev/null
- mkdir ${MY_P}
- cd "${S}"
+ popd > /dev/null || die
+ mkdir ${MY_P} || die
+ cd "${S}" || die
unpack ${MY_P}.tar.gz
}
src_prepare() {
epatch "${FILESDIR}"/${P}-opengl.patch
- cp "${FILESDIR}"/Makefile.am.${PV} Makefile.am
- cp "${FILESDIR}"/configure.ac.${PV} configure.ac
+ cp "${FILESDIR}"/Makefile.am.${PV} Makefile.am || die
+ cp "${FILESDIR}"/configure.ac.${PV} configure.ac || die
sed -e "s:IHOST1='SUN':IHOST1='@HOST@:" \
-e "s:/usr/local/lib:@datadir@:g" \
dp1_linux.f > dp1_linux.f.in || die
@@ -69,7 +69,7 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install
+ default
if use examples; then
insinto /usr/share/doc/${PF}/examples
@@ -79,8 +79,3 @@ src_install() {
doins "${S_AUX}"/dp{mes,sys,log}f.tex
doenvd "${FILESDIR}"/90${PN}
}
-
-pkg_postinst() {
- elog "Before using dataplot, please run (as root):"
- elog "env-update && source /etc/profile"
-}