summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-08-25 20:52:49 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-08-25 20:52:49 +0000
commitf8f7108765c87e0d3f1f2dcbc00de7073e210563 (patch)
tree2932a2c9007a784f4b7713cbca6f78ecde28f728 /sci-libs
parentStable on amd64/x86 wrt bug #144369. (diff)
downloadgentoo-2-f8f7108765c87e0d3f1f2dcbc00de7073e210563.tar.gz
gentoo-2-f8f7108765c87e0d3f1f2dcbc00de7073e210563.tar.bz2
gentoo-2-f8f7108765c87e0d3f1f2dcbc00de7073e210563.zip
Disabled detection of CPU throttling and added a warning for the user.
(Portage version: 2.1.1_pre5-r3)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/blas-atlas/ChangeLog7
-rw-r--r--sci-libs/blas-atlas/blas-atlas-3.7.15.ebuild15
2 files changed, 19 insertions, 3 deletions
diff --git a/sci-libs/blas-atlas/ChangeLog b/sci-libs/blas-atlas/ChangeLog
index f849e1f3a871..b731ee2414a1 100644
--- a/sci-libs/blas-atlas/ChangeLog
+++ b/sci-libs/blas-atlas/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/blas-atlas
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/ChangeLog,v 1.34 2006/08/25 05:18:31 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/ChangeLog,v 1.35 2006/08/25 20:52:49 markusle Exp $
+
+ 25 Aug 2006; Markus Dittrich <markusle@gentoo.org>
+ blas-atlas-3.7.15.ebuild:
+ Disabled detection of CPU throttling and added a warning for the
+ user.
25 Aug 2006; Donnie Berkholz <dberkholz@gentoo.org>; +files/eselect.blas,
+files/eselect.blas-threaded, +files/eselect.cblas,
diff --git a/sci-libs/blas-atlas/blas-atlas-3.7.15.ebuild b/sci-libs/blas-atlas/blas-atlas-3.7.15.ebuild
index 21b2066432f3..716eea4df3ec 100644
--- a/sci-libs/blas-atlas/blas-atlas-3.7.15.ebuild
+++ b/sci-libs/blas-atlas/blas-atlas-3.7.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.7.15.ebuild,v 1.1 2006/08/24 21:11:43 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.7.15.ebuild,v 1.2 2006/08/25 20:52:49 markusle Exp $
inherit eutils toolchain-funcs fortran
@@ -28,6 +28,16 @@ BLD_DIR="${S}/gentoo-build"
RPATH="${DESTTREE}/$(get_libdir)/blas"
FORTRAN="g77 gfortran"
+pkg_setup() {
+ fortran_pkg_setup
+ echo
+ ewarn "Please make sure to disable CPU throttling completely"
+ ewarn "during the compile of blas-atlas. Otherwise, all atlas"
+ ewarn "generated timings will be completely random and the"
+ ewarn "performance of the resulting libraries will be degraded"
+ ewarn "considerably."
+ echo
+}
src_unpack() {
unpack ${A}
@@ -48,7 +58,8 @@ src_unpack() {
cp "${FILESDIR}"/war ${BLD_DIR} && chmod a+x ${BLD_DIR}/war || \
die "failed to install war"
- cd ${BLD_DIR} && ../configure || die "configure failed"
+ cd ${BLD_DIR} && ../configure -Si cputhrchk 0 \
+ || die "configure failed"
sed -e "s:GENTOO_GCC:$(tc-getCC):" \
-e "s:GENTOO_FORTRAN:${FORTRANC}:" \