summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-03-20 21:33:16 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-03-20 21:33:16 +0000
commitf05b67a0815c538c23c51504cbc92a1626ef061e (patch)
tree07e500f7142ba659574a48c124d3824f0587a2e8 /sci-libs
parentPut the egg-info files in the build directory; should resove bug 462424. (diff)
downloadgentoo-2-f05b67a0815c538c23c51504cbc92a1626ef061e.tar.gz
gentoo-2-f05b67a0815c538c23c51504cbc92a1626ef061e.tar.bz2
gentoo-2-f05b67a0815c538c23c51504cbc92a1626ef061e.zip
Version bump
(Portage version: 2.2.01.21688-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/matio/ChangeLog9
-rw-r--r--sci-libs/matio/matio-1.5.1.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/sci-libs/matio/ChangeLog b/sci-libs/matio/ChangeLog
index a8698a4c8b11..b46d4bd32d6e 100644
--- a/sci-libs/matio/ChangeLog
+++ b/sci-libs/matio/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/matio
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/matio/ChangeLog,v 1.4 2012/09/22 20:46:37 xarthisius Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/matio/ChangeLog,v 1.5 2013/03/20 21:33:16 bicatali Exp $
+
+*matio-1.5.1 (20 Mar 2013)
+
+ 20 Mar 2013; Sébastien Fabbro <bicatali@gentoo.org> +matio-1.5.1.ebuild:
+ Version bump
22 Sep 2012; Kacper Kowalik <xarthisius@gentoo.org>
-files/matio-1.3.4-autotools.patch, -matio-1.3.4.ebuild:
diff --git a/sci-libs/matio/matio-1.5.1.ebuild b/sci-libs/matio/matio-1.5.1.ebuild
new file mode 100644
index 000000000000..dd9aaab80aff
--- /dev/null
+++ b/sci-libs/matio/matio-1.5.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/matio/matio-1.5.1.ebuild,v 1.1 2013/03/20 21:33:16 bicatali Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils eutils
+
+DESCRIPTION="Library for reading and writing matlab files"
+HOMEPAGE="http://sourceforge.net/projects/matio/"
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples hdf5 sparse static-libs"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+RDEPEND="sys-libs/zlib
+ hdf5? ( sci-libs/hdf5 )"
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base )"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.5.0-asneeded.patch )
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ $(use_enable hdf5 mat73)
+ $(use_enable sparse extended-sparse)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile -C documentation pdf
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dodoc documentation/matio_user_guide.pdf
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins test/test*
+ insinto /usr/share/${PN}
+ doins share/test*
+ fi
+}