summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-03-05 18:58:23 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-03-05 18:58:23 +0000
commit9c047cd54ba607562028da861a3c21c07d8a2191 (patch)
tree596a844021c11528775b75ac70f994fd8803a15a /sci-libs
parentKeyword on amd64 wrt bug #153911. (diff)
downloadgentoo-2-9c047cd54ba607562028da861a3c21c07d8a2191.tar.gz
gentoo-2-9c047cd54ba607562028da861a3c21c07d8a2191.tar.bz2
gentoo-2-9c047cd54ba607562028da861a3c21c07d8a2191.zip
fixes on ebuild and added ~amd64
(Portage version: 2.1.2-r9)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/pgplot/ChangeLog10
-rw-r--r--sci-libs/pgplot/files/digest-pgplot-5.2.2-r13
-rw-r--r--sci-libs/pgplot/files/pgplot-path.patch18
-rw-r--r--sci-libs/pgplot/metadata.xml7
-rw-r--r--sci-libs/pgplot/pgplot-5.2.2-r1.ebuild106
5 files changed, 143 insertions, 1 deletions
diff --git a/sci-libs/pgplot/ChangeLog b/sci-libs/pgplot/ChangeLog
index a2a24121ae05..2a8e6b0abc43 100644
--- a/sci-libs/pgplot/ChangeLog
+++ b/sci-libs/pgplot/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-libs/pgplot
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/pgplot/ChangeLog,v 1.5 2007/02/22 01:24:26 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/pgplot/ChangeLog,v 1.6 2007/03/05 18:58:23 bicatali Exp $
+
+*pgplot-5.2.2-r1 (05 Mar 2007)
+
+ 05 Mar 2007; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/pgplot-path.patch, metadata.xml, +pgplot-5.2.2-r1.ebuild:
+ General cleaning, added patches, a src_test, now does full
+ installation, and a longdescrption in metadata.xml. Also tested on
+ amd64.
22 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/sci-libs/pgplot/files/digest-pgplot-5.2.2-r1 b/sci-libs/pgplot/files/digest-pgplot-5.2.2-r1
new file mode 100644
index 000000000000..a08d5a4ce344
--- /dev/null
+++ b/sci-libs/pgplot/files/digest-pgplot-5.2.2-r1
@@ -0,0 +1,3 @@
+MD5 e8a6e8d0d5ef9d1709dfb567724525ae pgplot522.tar.gz 1197397
+RMD160 4c21cad6613772f4104c65ac3d8d9a42e3c4afe1 pgplot522.tar.gz 1197397
+SHA256 a5799ff719a510d84d26df4ae7409ae61fe66477e3f1e8820422a9a4727a5be4 pgplot522.tar.gz 1197397
diff --git a/sci-libs/pgplot/files/pgplot-path.patch b/sci-libs/pgplot/files/pgplot-path.patch
new file mode 100644
index 000000000000..990d9104c181
--- /dev/null
+++ b/sci-libs/pgplot/files/pgplot-path.patch
@@ -0,0 +1,18 @@
+diff -Nur pgplot/makehtml pgplot.new/makehtml
+--- pgplot/makehtml 1997-02-26 21:54:09.000000000 +0000
++++ pgplot.new/makehtml 2006-06-04 16:21:34.000000000 +0100
+@@ -1,4 +1,4 @@
+-#!/usr/local/bin/perl
++#!/usr/bin/perl
+
+ $, = ' '; # set output field separator
+ $\ = "\n"; # set output record separator
+diff -Nur pgplot/maketex pgplot.new/maketex
+--- pgplot/maketex 1996-04-16 22:51:24.000000000 +0100
++++ pgplot.new/maketex 2006-06-04 16:21:47.000000000 +0100
+@@ -1,4 +1,4 @@
+-#!/usr/local/bin/perl
++#!/usr/bin/perl
+
+ $, = ' '; # set output field separator
+ $\ = "\n"; # set output record separator
diff --git a/sci-libs/pgplot/metadata.xml b/sci-libs/pgplot/metadata.xml
index b229aec85b8f..f3e88639d650 100644
--- a/sci-libs/pgplot/metadata.xml
+++ b/sci-libs/pgplot/metadata.xml
@@ -2,4 +2,11 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci</herd>
+<longdescription lang="en">
+PGPLOT is a Fortran subroutine package for drawing graphs on a variety
+of display devices. The CPGPLOT library adds an intermediate level of
+wrapper functions between C programs and the PGPLOT library. These
+functions hide the system dependencies of calling PGPLOT behind a
+system independent interface.
+</longdescription>
</pkgmetadata>
diff --git a/sci-libs/pgplot/pgplot-5.2.2-r1.ebuild b/sci-libs/pgplot/pgplot-5.2.2-r1.ebuild
new file mode 100644
index 000000000000..d66412a0ed9b
--- /dev/null
+++ b/sci-libs/pgplot/pgplot-5.2.2-r1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/pgplot/pgplot-5.2.2-r1.ebuild,v 1.1 2007/03/05 18:58:23 bicatali Exp $
+
+inherit eutils toolchain-funcs fortran
+
+FORTRAN="g77"
+MY_P="${PN}${PV//.}"
+DESCRIPTION="A C/FORTRAN device-independent graphics library for making simple scientific graphs"
+HOMEPAGE="http://www.astro.caltech.edu/~tjp/pgplot/"
+SRC_URI="ftp://ftp.astro.caltech.edu/pub/pgplot/${MY_P}.tar.gz"
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="doc"
+RDEPEND="x11-libs/libX11
+ media-libs/libpng"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ fortran_src_unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-drivers.patch
+ epatch "${FILESDIR}"/${PN}-makemake.patch
+ epatch "${FILESDIR}"/${PN}-compile-setup.patch
+
+ if use amd64 -o use ia64; then
+ sed -i \
+ -e 's/INTEGER PIXMAP/INTEGER*8 PIXMAP/g' \
+ drivers/{gi,pp,wd}driv.f || die "sed 64bits failed"
+ fi
+
+ cp sys_linux/g77_gcc.conf local.conf
+
+ sed -i \
+ -e "s:FCOMPL=.*:FCOMPL=\"${FORTRANC}\":g" \
+ -e "s:FFLAGOPT=.*:FFLAGOPT=\"${FFLAGS:- -O2}\":g" \
+ -e "s:CCOMPL=.*:CCOMPL=\"$(tc-getCC)\":g" \
+ -e "s:CFLAGOPT=.*:CFLAGOPT=\"${CFLAGS}\":g" \
+ local.conf || die "sed flags failed"
+
+ sed -i \
+ -e "s:/usr/local/pgplot:/usr/$(get_libdir)/pgplot:" \
+ src/grgfil.f || die "sed path failed"
+}
+
+src_compile() {
+ ./makemake "${S}" linux
+
+ emake -j1 || die "emake failed"
+
+ # Build C portion
+ make cpg || die "make cpg failed"
+
+ # this just cleans out unneeded files
+ make clean
+}
+
+src_test() {
+ einfo "Testing various demo programs"
+ # i can go to 16
+ for i in 1 2 3; do
+ make pgdemo${i}
+ # j can also be LATEX CPS...
+ for j in GIF PNG PS; do
+ local testexe=./test_${j}_${i}
+ echo "./pgdemo${i} <<EOF" > ${testexe}
+ echo "/${j}" >> ${testexe}
+ echo "EOF" >> ${testexe}
+ sh ${testexe} || die "test ${i} failed"
+ done
+ done
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/pgplot
+ doins grfont.dat grexec.f grpckg1.inc rgb.txt
+
+ # FORTRAN libs
+ dolib.a libpgplot.a
+ dolib.so libpgplot.so
+ dosym libpgplot.so.5 /usr/$(get_libdir)/libpgplot.so
+ dobin pgxwin_server
+
+ # C binding
+ insinto /usr/include
+ doins cpgplot.h
+ dolib.a libcpgplot.a
+ # shared lib: todo eventually in a patch
+ # dolib.so libcpgplot.so
+ # dosym libcpgplot.so.5 /usr/$(get_libdir)/libcpgplot.so
+
+ # minimal doc
+ dodoc aaaread.me pgplot.doc
+
+ if use doc; then
+ dodoc cpg/cpgplot.doc applications/curvefit/curvefit.doc
+ dohtml pgplot.html
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/* cpg/cpgdemo.c
+ insinto /usr/share/doc/${PF}/pgm
+ doins pgmf/* drivers/xmotif/pgmdemo.c
+ fi
+}