summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-10-11 14:12:09 +0000
committerJustin Lecher <jlec@gentoo.org>2011-10-11 14:12:09 +0000
commit9bc2bb7c7b41b0eb7fcf17a78b1a4456ebebc41a (patch)
tree1e01a63163aa1990f209c8545e56846ffc933b1e /sci-libs
parentversion bump, bug #378477 (diff)
downloadgentoo-2-9bc2bb7c7b41b0eb7fcf17a78b1a4456ebebc41a.tar.gz
gentoo-2-9bc2bb7c7b41b0eb7fcf17a78b1a4456ebebc41a.tar.bz2
gentoo-2-9bc2bb7c7b41b0eb7fcf17a78b1a4456ebebc41a.zip
Add missing use of python.eclass
(Portage version: 2.2.0_alpha66/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/ccpn-data/ChangeLog10
-rw-r--r--sci-libs/ccpn-data/ccpn-data-2.1.5_p111011.ebuild (renamed from sci-libs/ccpn-data/ccpn-data-2.1.5_p110928.ebuild)4
-rw-r--r--sci-libs/ccpn-data/ccpn-data-2.2.1_p111011.ebuild (renamed from sci-libs/ccpn-data/ccpn-data-2.2.1_p110928.ebuild)14
3 files changed, 21 insertions, 7 deletions
diff --git a/sci-libs/ccpn-data/ChangeLog b/sci-libs/ccpn-data/ChangeLog
index a7ac61bdac2e..66b7fa6aa5f8 100644
--- a/sci-libs/ccpn-data/ChangeLog
+++ b/sci-libs/ccpn-data/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-libs/ccpn-data
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccpn-data/ChangeLog,v 1.5 2011/09/28 14:16:34 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccpn-data/ChangeLog,v 1.6 2011/10/11 14:12:09 jlec Exp $
+
+*ccpn-data-2.2.1_p111011 (11 Oct 2011)
+*ccpn-data-2.1.5_p111011 (11 Oct 2011)
+
+ 11 Oct 2011; Justin Lecher <jlec@gentoo.org> -ccpn-data-2.1.5_p110928.ebuild,
+ +ccpn-data-2.1.5_p111011.ebuild, -ccpn-data-2.2.1_p110928.ebuild,
+ +ccpn-data-2.2.1_p111011.ebuild:
+ Add missing use of python.eclass
*ccpn-data-2.2.1_p110928 (28 Sep 2011)
*ccpn-data-2.1.5_p110928 (28 Sep 2011)
diff --git a/sci-libs/ccpn-data/ccpn-data-2.1.5_p110928.ebuild b/sci-libs/ccpn-data/ccpn-data-2.1.5_p111011.ebuild
index 28e40a35c29e..c44b40e08faa 100644
--- a/sci-libs/ccpn-data/ccpn-data-2.1.5_p110928.ebuild
+++ b/sci-libs/ccpn-data/ccpn-data-2.1.5_p111011.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccpn-data/ccpn-data-2.1.5_p110928.ebuild,v 1.1 2011/09/28 14:16:34 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccpn-data/ccpn-data-2.1.5_p111011.ebuild,v 1.1 2011/10/11 14:12:09 jlec Exp $
EAPI=3
@@ -61,5 +61,5 @@ src_install() {
dohtml -r doc/*
insinto /usr/share/ccpn
- doins -r data model
+ doins -r data model || die
}
diff --git a/sci-libs/ccpn-data/ccpn-data-2.2.1_p110928.ebuild b/sci-libs/ccpn-data/ccpn-data-2.2.1_p111011.ebuild
index 3dbd18d730c1..c954a819c8c0 100644
--- a/sci-libs/ccpn-data/ccpn-data-2.2.1_p110928.ebuild
+++ b/sci-libs/ccpn-data/ccpn-data-2.2.1_p111011.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccpn-data/ccpn-data-2.2.1_p110928.ebuild,v 1.1 2011/09/28 14:16:34 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccpn-data/ccpn-data-2.2.1_p111011.ebuild,v 1.1 2011/10/11 14:12:09 jlec Exp $
-EAPI=4
+EAPI=3
-inherit portability versionator
+PYTHON_DEPEND="2"
+
+inherit portability python versionator
PATCHSET="${PV##*_p}"
MY_PN="${PN/-data}mr"
@@ -28,6 +30,10 @@ RESTRICT="binchecks strip"
S="${WORKDIR}"/ccpnmr/ccpnmr2.2
+pkg_setup() {
+ python_set_active_version 2
+}
+
src_prepare() {
[[ -n ${PATCHSET} ]] && \
epatch "${WORKDIR}"/ccpn-update-${MY_MAJOR}-${PATCHSET}.patch
@@ -55,5 +61,5 @@ src_install() {
dohtml -r doc/*
insinto /usr/share/ccpn
- doins -r data model
+ doins -r data model || die
}