summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-03-25 19:42:14 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-03-25 19:42:14 +0000
commit90d705701117d9998a6ab3f305748a4869285c70 (patch)
tree1e8353990ac3e9bbcf8592a975d9dbdc6b225c99 /sci-libs
parentMore fixes to the site.cfg file generation (diff)
downloadgentoo-2-90d705701117d9998a6ab3f305748a4869285c70.tar.gz
gentoo-2-90d705701117d9998a6ab3f305748a4869285c70.tar.bz2
gentoo-2-90d705701117d9998a6ab3f305748a4869285c70.zip
More fixes to the site.cfg file generation
(Portage version: 2.2.8-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/scipy/ChangeLog5
-rw-r--r--sci-libs/scipy/scipy-0.13.3.ebuild8
2 files changed, 8 insertions, 5 deletions
diff --git a/sci-libs/scipy/ChangeLog b/sci-libs/scipy/ChangeLog
index 8d8013c15660..e9973697f3ec 100644
--- a/sci-libs/scipy/ChangeLog
+++ b/sci-libs/scipy/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/scipy
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.114 2014/03/25 17:52:09 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.115 2014/03/25 19:42:14 bicatali Exp $
+
+ 25 Mar 2014; Sébastien Fabbro <bicatali@gentoo.org> scipy-0.13.3.ebuild:
+ More fixes to the site.cfg file generation
25 Mar 2014; Sébastien Fabbro <bicatali@gentoo.org> scipy-0.13.3.ebuild:
Fixed syntax error thanks Ruslan Savchenko bug #505572
diff --git a/sci-libs/scipy/scipy-0.13.3.ebuild b/sci-libs/scipy/scipy-0.13.3.ebuild
index ca926c39ade1..97a4803a7fdd 100644
--- a/sci-libs/scipy/scipy-0.13.3.ebuild
+++ b/sci-libs/scipy/scipy-0.13.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.13.3.ebuild,v 1.3 2014/03/25 17:52:09 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.13.3.ebuild,v 1.4 2014/03/25 19:42:14 bicatali Exp $
EAPI=5
@@ -53,19 +53,19 @@ src_unpack() {
pc_incdir() {
$(tc-getPKG_CONFIG) --cflags-only-I $@ | \
- sed -e 's/^-I//' -e 's/[ ]*-I/:/g' -e 's/[ ]*$//'
+ sed -e 's/^-I//' -e 's/[ ]*-I/:/g' -e 's/[ ]*$//' -e 's|^:||'
}
pc_libdir() {
$(tc-getPKG_CONFIG) --libs-only-L $@ | \
- sed -e 's/^-L//' -e 's/[ ]*-L/:/g' -e 's/[ ]*$//'
+ sed -e 's/^-L//' -e 's/[ ]*-L/:/g' -e 's/[ ]*$//' -e 's|^:||'
}
pc_libs() {
$(tc-getPKG_CONFIG) --libs-only-l $@ | \
sed -e 's/[ ]-l*\(pthread\|m\)\([ ]\|$\)//g' \
-e 's/^-l//' -e 's/[ ]*-l/,/g' -e 's/[ ]*$//' \
- | tr ',' '\n' | sort -u | tr '\n' ','
+ | tr ',' '\n' | sort -u | tr '\n' ',' | sed -e 's|,$||'
}
python_prepare_all() {