summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2006-07-03 08:04:29 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2006-07-03 08:04:29 +0000
commit8eb57a51f62dd1a6b5ac27bc7c24ec25b26545ee (patch)
tree60eb629d0261a3c3714282a57d0b999e3208e635 /sci-libs
parentAdd all the new blas/cblas/lapack stuff to the eselect 1.0.3 mask. (diff)
downloadgentoo-2-8eb57a51f62dd1a6b5ac27bc7c24ec25b26545ee.tar.gz
gentoo-2-8eb57a51f62dd1a6b5ac27bc7c24ec25b26545ee.tar.bz2
gentoo-2-8eb57a51f62dd1a6b5ac27bc7c24ec25b26545ee.zip
Bumps to switch to new eselect modules.
(Portage version: 2.1.1_pre1-r5)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/blas-atlas/ChangeLog9
-rw-r--r--sci-libs/blas-atlas/blas-atlas-3.6.0-r2.ebuild181
-rw-r--r--sci-libs/blas-atlas/blas-atlas-3.7.11-r1.ebuild193
-rw-r--r--sci-libs/blas-atlas/files/digest-blas-atlas-3.6.0-r26
-rw-r--r--sci-libs/blas-atlas/files/digest-blas-atlas-3.7.11-r16
5 files changed, 394 insertions, 1 deletions
diff --git a/sci-libs/blas-atlas/ChangeLog b/sci-libs/blas-atlas/ChangeLog
index f65a5bdc3019..35773e8c1bfc 100644
--- a/sci-libs/blas-atlas/ChangeLog
+++ b/sci-libs/blas-atlas/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/blas-atlas
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/ChangeLog,v 1.24 2006/06/17 00:34:47 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/ChangeLog,v 1.25 2006/07/03 08:04:29 spyderous Exp $
+
+*blas-atlas-3.7.11-r1 (03 Jul 2006)
+*blas-atlas-3.6.0-r2 (03 Jul 2006)
+
+ 03 Jul 2006; Donnie Berkholz <spyderous@gentoo.org>;
+ +blas-atlas-3.6.0-r2.ebuild, +blas-atlas-3.7.11-r1.ebuild:
+ Bumps to switch to new eselect modules.
17 Jun 2006; Luca Barbato <lu_zero@gentoo.org>
+files/3.6.0-ppc-configure.patch, +files/3.7.11-ppc-configure.patch,
diff --git a/sci-libs/blas-atlas/blas-atlas-3.6.0-r2.ebuild b/sci-libs/blas-atlas/blas-atlas-3.6.0-r2.ebuild
new file mode 100644
index 000000000000..2009dee6b430
--- /dev/null
+++ b/sci-libs/blas-atlas/blas-atlas-3.6.0-r2.ebuild
@@ -0,0 +1,181 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.6.0-r2.ebuild,v 1.1 2006/07/03 08:04:29 spyderous Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Automatically Tuned Linear Algebra Software BLAS implementation"
+HOMEPAGE="http://math-atlas.sourceforge.net/"
+MY_PN=${PN/blas-/}
+SRC_URI="mirror://sourceforge/math-atlas/${MY_PN}${PV}.tar.bz2
+ mirror://gentoo/atlas${PV}-shared-libs.1.patch.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND="app-admin/eselect-blas
+ app-admin/eselect-cblas"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-1.5"
+
+
+PROVIDE="virtual/blas"
+
+S=${WORKDIR}/ATLAS
+
+# Libraries will be installed in ${RPATH}/atlas
+# and ${RPATH}/threaded-atlas:
+RPATH="${DESTTREE}/lib/blas"
+
+
+pkg_setup() {
+ if [ -z `which g77` ]; then
+ eerror "No fortran compiler found on the system!"
+ eerror "Please add fortran to your USE flags and reemerge gcc!"
+ die
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ epatch ${FILESDIR}/unbuffered.patch
+ epatch ${DISTDIR}/atlas3.6.0-shared-libs.1.patch.bz2
+ epatch ${FILESDIR}/${PV}-ppc-configure.patch
+ sed -i -e "s:ASM:ASM VOLATILE:" include/contrib/camm_dpa.h || die "sed failed to fix clobbering"
+ cp ${FILESDIR}/war ${S}
+ chmod a+x ${S}/war
+}
+
+atlas_fail() {
+ eerror
+ eerror "ATLAS auto-config failed."
+ eerror "Please run 'interactive=1 emerge blas-atlas' to configure manually."
+ eerror
+ die "ATLAS auto-config failed."
+}
+
+# Added to allow compilation on sparc architecture. The default CCFLAG0
+# and MMFLAGS are *bad*.
+# Danny van Dyk <kugelfang@gentoo.org> 2004/07/02
+#
+reconfigure() {
+ case "`uname -p`" in
+ "sun4m")
+ MY_CCFLAGS="-O3 -mcpu=v8"
+ MY_CXXFLAGS="${MY_CCFLAGS}"
+ MY_MMFLAGS="-O -mcpu=v8"
+ MY_LDFLAGS=""
+ ;;
+ "sun4u")
+ MY_CCFLAGS="-O3 -mcpu=ultrasparc"
+ MY_CXXFLAGS="${MY_CCFLAGS}"
+ MY_MMFLAGS="-O -mcpu=ultrasparc"
+ MY_LDFLAGS=""
+ ;;
+ *)
+ MY_CCFLAGS="${CFLAGS}"
+ MY_CXXFLAGS="${CXXFLAGS}"
+ MY_MMFLAGS="${CFLAGS}"
+ MY_LDFLAGS="${LDFLAGS}"
+ ;;
+ esac
+
+ MY_FILE="`find -name Make.Linux*`"
+
+ sed -i -e "s/CCFLAG0 =.*/CCFLAG0 = \$(CDEFS) ${MY_CCFLAGS}/" \
+ -e "s/CCFLAGS =.*/CCFLAGS = \$(CDEFS) ${MY_CCFLAGS}/" \
+ -e "s/CLINKFLAGS =.*/CLINKFLAGS =\$(CDEFS) ${MY_LDFLAGS}/" \
+ -e "s/XCCFLAGS =.*/XCCFLAGS =\$(CDEFS) ${MY_CXXFLAGS}/" \
+ -e "s/MMFLAGS =.*/MMFLAGS = ${MY_MMFLAGS}/" \
+ ${MY_FILE} || die "sed didnt complete"
+
+}
+
+src_compile() {
+ if [ -n "${interactive}" ]
+ then
+ echo "${interactive}"
+ make config CC="$(tc-getCC) -DUSE_LIBTOOL -DINTERACTIVE" || die
+ else
+ # Use ATLAS defaults for all questions:
+ (echo | make config CC="$(tc-getCC) -DUSE_LIBTOOL") || atlas_fail
+ fi
+
+ reconfigure
+
+ TMPSTR=$(ls Make.Linux*)
+ ATLAS_ARCH=${TMPSTR#'Make.'}
+
+ make install arch=${ATLAS_ARCH} || die
+
+ make shared-strip arch=${ATLAS_ARCH} RPATH=${RPATH}/atlas || die
+
+ # Build shared versions of the threaded libs.
+ # ATLAS only compiles threaded libs on multiprocessor machines.
+ if [ -d gentoo/libptf77blas.a ]
+ then
+ make ptshared-strip \
+ arch=${ATLAS_ARCH} RPATH=${RPATH}/threaded-atlas || die
+ fi
+}
+
+src_install () {
+ dodir ${RPATH}/atlas
+ cd ${S}/gentoo/libs
+ cp -P libatlas* ${D}/${DESTTREE}/lib
+ cp -P *blas* ${D}/${RPATH}/atlas #the rest really
+
+ eselect blas add $(get_libdir) ${FILESDIR}/eselect.blas atlas
+ eselect cblas add $(get_libdir) ${FILESDIR}/eselect.cblas atlas
+
+ if [ -d ${S}/gentoo/threaded-libs ]
+ then
+ dodir ${RPATH}/threaded-atlas
+ cd ${S}/gentoo/threaded-libs
+ cp -P * ${D}/${RPATH}/threaded-atlas
+ eselect blas add $(get_libdir) ${FILESDIR}/eselect.blas-threaded threaded-atlas
+ eselect cblas add $(get_libdir) ${FILESDIR}/eselect.cblas-threaded threaded-atlas
+ fi
+
+ insinto ${DESTTREE}/include/atlas
+ doins ${S}/include/cblas.h ${S}/include/atlas_misc.h
+ doins ${S}/include/atlas_enum.h
+
+ # These headers contain the architecture-specific optimizations determined
+ # by ATLAS. The atlas-lapack build is much shorter if they are available,
+ # so save them:
+ doins ${S}/include/${ATLAS_ARCH}/*.h
+
+ #some docs
+ cd ${S}
+ dodoc README doc/{AtlasCredits.txt,ChangeLog}
+ use doc && dodoc doc/*.ps
+}
+
+pkg_postinst() {
+ local THREADED
+
+ if [ -d ${RPATH}/threaded-atlas ]
+ then
+ THREADED="threaded-"
+ fi
+ if [[ -z "$(eselect blas show)" ]]; then
+ eselect blas set ${THREADED}atlas
+ fi
+ if [[ -z "$(eselect cblas show)" ]]; then
+ eselect cblas set ${THREADED}atlas
+ fi
+
+ einfo
+ einfo "Fortran users link using -lblas"
+ einfo
+ einfo "C users compile against the header ${ROOT}usr/include/atlas/cblas.h and"
+ einfo "link using -lcblas"
+ einfo
+ einfo "If using threaded ATLAS, you may also need to link with -lpthread."
+}
diff --git a/sci-libs/blas-atlas/blas-atlas-3.7.11-r1.ebuild b/sci-libs/blas-atlas/blas-atlas-3.7.11-r1.ebuild
new file mode 100644
index 000000000000..db67ec661655
--- /dev/null
+++ b/sci-libs/blas-atlas/blas-atlas-3.7.11-r1.ebuild
@@ -0,0 +1,193 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.7.11-r1.ebuild,v 1.1 2006/07/03 08:04:29 spyderous Exp $
+
+inherit eutils toolchain-funcs fortran
+
+DESCRIPTION="Automatically Tuned Linear Algebra Software BLAS implementation"
+HOMEPAGE="http://math-atlas.sourceforge.net/"
+MY_PN=${PN/blas-/}
+MY_PV=3.6.0
+SRC_URI="mirror://sourceforge/math-atlas/${MY_PN}${PV}.tar.bz2
+ mirror://gentoo/atlas${MY_PV}-shared-libs.1.patch.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND="app-admin/eselect-blas
+ app-admin/eselect-cblas"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-1.5"
+PROVIDE="virtual/blas"
+
+
+S="${WORKDIR}/ATLAS"
+RPATH="${DESTTREE}/$(get_libdir)/blas"
+FORTRAN="g77 gfortran"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch "${FILESDIR}"/unbuffered.patch
+ epatch "${FILESDIR}"/${PV}-allow-any-gcc-version.patch
+ epatch "${DISTDIR}"/atlas3.6.0-shared-libs.1.patch.bz2
+ epatch "${FILESDIR}"/${PV}-ppc-configure.patch
+ sed -i \
+ -e "s:ASM:ASM VOLATILE:" \
+ include/contrib/camm_dpa.h \
+ || die "sed failed to fix clobbering"
+
+ sed -i \
+ -e "s:\(\t./xconfig\):\1 -m $(tc-getCC) -c $(tc-getCC) -f ${FORTRANC}:g" \
+ ${S}/Makefile \
+ || die "Failed to fix compilers"
+
+ if [[ $(gcc-major-version) -ge 4 ]]; then
+ einfo "Updating Makefiles for gcc-4"
+ sed -i \
+ -e "s:g2c:gfortran:g" \
+ ${S}/Make.top \
+ ${S}/makes/Make.lib \
+ || die "Failed to update for gcc-4"
+ fi
+
+ cp "${FILESDIR}"/war "${S}"
+ chmod a+x "${S}"/war
+}
+
+atlas_fail() {
+ eerror
+ eerror "ATLAS auto-config failed."
+ eerror "Please run 'interactive=1 emerge blas-atlas' to configure manually."
+ eerror
+ die "ATLAS auto-config failed."
+}
+
+# Added to allow compilation on sparc architecture. The default CCFLAG0
+# and MMFLAGS are *bad*.
+# Danny van Dyk <kugelfang@gentoo.org> 2004/07/02
+#
+reconfigure() {
+ case "`uname -p`" in
+ "sun4m")
+ MY_CCFLAGS="-O3 -mcpu=v8"
+ MY_CXXFLAGS="${MY_CCFLAGS}"
+ MY_MMFLAGS="-O -mcpu=v8"
+ MY_LDFLAGS=""
+ ;;
+ "sun4u")
+ MY_CCFLAGS="-O3 -mcpu=ultrasparc"
+ MY_CXXFLAGS="${MY_CCFLAGS}"
+ MY_MMFLAGS="-O -mcpu=ultrasparc"
+ MY_LDFLAGS=""
+ ;;
+ *)
+ MY_CCFLAGS="${CFLAGS}"
+ MY_CXXFLAGS="${CXXFLAGS}"
+ MY_MMFLAGS="${CFLAGS}"
+ MY_LDFLAGS="${LDFLAGS}"
+ ;;
+ esac
+
+ MY_FILE="`find -name Make.Linux*`"
+
+ sed -i -e "s/CCFLAG0 =.*/CCFLAG0 = \$(CDEFS) ${MY_CCFLAGS}/" \
+ -e "s/CCFLAGS =.*/CCFLAGS = \$(CDEFS) ${MY_CCFLAGS}/" \
+ -e "s/CLINKFLAGS =.*/CLINKFLAGS =\$(CDEFS) ${MY_LDFLAGS}/" \
+ -e "s/XCCFLAGS =.*/XCCFLAGS =\$(CDEFS) ${MY_CXXFLAGS}/" \
+ -e "s/MMFLAGS =.*/MMFLAGS = ${MY_MMFLAGS}/" \
+ ${MY_FILE} || die "sed didnt complete"
+}
+
+src_compile() {
+ if [ -n "${interactive}" ]
+ then
+ echo "${interactive}"
+ make config CC="$(tc-getCC) -DUSE_LIBTOOL -DINTERACTIVE" || die
+ else
+ # Use ATLAS defaults for all questions:
+ (echo | make config CC="$(tc-getCC) -DUSE_LIBTOOL") || atlas_fail
+ fi
+
+ reconfigure
+
+ TMPSTR=$(ls Make.Linux*)
+ ATLAS_ARCH=${TMPSTR#'Make.'}
+
+ make install arch=${ATLAS_ARCH} || \
+ die "Failed to install blas-atlas"
+
+ make shared-strip arch=${ATLAS_ARCH} RPATH=${RPATH}/atlas || \
+ die "Failed to build shared libraries"
+
+ # Build shared versions of the threaded libs.
+ # ATLAS only compiles threaded libs on multiprocessor machines.
+ if [ -d gentoo/libptf77blas.a ]
+ then
+ make ptshared-strip \
+ arch=${ATLAS_ARCH} RPATH=${RPATH}/threaded-atlas || die
+ fi
+}
+
+src_install () {
+ dodir "${RPATH}"/atlas
+ cd "${S}"/gentoo/libs
+ cp -P libatlas* "${D}/${DESTTREE}/$(get_libdir)" || \
+ die "Failed to install libatlas"
+ cp -P *blas* "${D}/${RPATH}"/atlas || \
+ die "Failed to install blas/cblas"
+
+ eselect blas add $(get_libdir) ${FILESDIR}/eselect.blas atlas
+ eselect cblas add $(get_libdir) ${FILESDIR}/eselect.cblas atlas
+
+ if [ -d "${S}"/gentoo/threaded-libs ]
+ then
+ dodir "${RPATH}"/threaded-atlas
+ cd "${S}"/gentoo/threaded-libs
+ cp -P * "${D}/${RPATH}"/threaded-atlas || \
+ die "Failed to install threaded atlas"
+
+ eselect blas add $(get_libdir) ${FILESDIR}/eselect.blas-threaded threaded-atlas
+ eselect cblas add $(get_libdir) ${FILESDIR}/eselect.cblas-threaded threaded-atlas
+ fi
+
+ insinto "${DESTTREE}"/include/atlas
+ doins "${S}"/include/cblas.h "${S}"/include/atlas_misc.h
+ doins "${S}"/include/atlas_enum.h
+
+ # These headers contain the architecture-specific
+ # optimizations determined by ATLAS. The atlas-lapack build
+ # is much shorter if they are available, so save them:
+ doins "${S}/include/${ATLAS_ARCH}"/*.h
+
+ #some docs
+ cd "${S}"
+ dodoc README doc/{AtlasCredits.txt,ChangeLog}
+ use doc && dodoc doc/*.ps
+}
+
+pkg_postinst() {
+ local THREADED
+
+ if [ -d "${RPATH}"/threaded-atlas ]
+ then
+ THREADED="threaded-"
+ fi
+ if [[ -z "$(eselect blas show)" ]]; then
+ eselect blas set ${THREADED}atlas
+ fi
+ if [[ -z "$(eselect cblas show)" ]]; then
+ eselect cblas set ${THREADED}atlas
+ fi
+
+ einfo
+ einfo "Fortran users link using -lblas"
+ einfo
+ einfo "C users compile against the header ${ROOT}usr/include/atlas/cblas.h and"
+ einfo "link using -lcblas"
+ einfo
+ einfo "If using threaded ATLAS, you may also need to link with -lpthread."
+}
diff --git a/sci-libs/blas-atlas/files/digest-blas-atlas-3.6.0-r2 b/sci-libs/blas-atlas/files/digest-blas-atlas-3.6.0-r2
new file mode 100644
index 000000000000..a097b774b921
--- /dev/null
+++ b/sci-libs/blas-atlas/files/digest-blas-atlas-3.6.0-r2
@@ -0,0 +1,6 @@
+MD5 d2940721d6592f43a5d2e7740d13076d atlas3.6.0-shared-libs.1.patch.bz2 5148
+RMD160 96f9357049fb22e0955ff1375630e542b0bdee7c atlas3.6.0-shared-libs.1.patch.bz2 5148
+SHA256 f669030bf042808a4f4a92c746f3fd3067597d0ec94756ecac63bc331109c565 atlas3.6.0-shared-libs.1.patch.bz2 5148
+MD5 df2ee2eb65d1c08ee93d04370172c262 atlas3.6.0.tar.bz2 1687723
+RMD160 e7d40a6677ce7c4442df7152150aecf812020713 atlas3.6.0.tar.bz2 1687723
+SHA256 1c2ad68fe3c66e261c012788fc1b6f74eada791f713848a3a6420c50fa35c8e8 atlas3.6.0.tar.bz2 1687723
diff --git a/sci-libs/blas-atlas/files/digest-blas-atlas-3.7.11-r1 b/sci-libs/blas-atlas/files/digest-blas-atlas-3.7.11-r1
new file mode 100644
index 000000000000..4f9a1ab52c6f
--- /dev/null
+++ b/sci-libs/blas-atlas/files/digest-blas-atlas-3.7.11-r1
@@ -0,0 +1,6 @@
+RMD160 96f9357049fb22e0955ff1375630e542b0bdee7c atlas3.6.0-shared-libs.1.patch.bz2 5148
+SHA256 f669030bf042808a4f4a92c746f3fd3067597d0ec94756ecac63bc331109c565 atlas3.6.0-shared-libs.1.patch.bz2 5148
+MD5 d2940721d6592f43a5d2e7740d13076d atlas3.6.0-shared-libs.1.patch.bz2 5148
+RMD160 f58b8a85c097bd1bff6a53ee42bcff97240fb8ec atlas3.7.11.tar.bz2 2032724
+SHA256 558b9f3f0dc8f63306f99f75d6e6fa762ea3d9d0dea88053e3e8b6f0e6364109 atlas3.7.11.tar.bz2 2032724
+MD5 ccde41dd4f41c47e16ebfa8e6dfd1117 atlas3.7.11.tar.bz2 2032724