summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-08-14 03:37:21 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-08-14 03:37:21 +0000
commit73f8b2f7e272f2bcbad6c74dc6c958b4fdfd5844 (patch)
tree0d4f7bf97a55361827467a682d619a6ecf126302 /sci-libs
parentversion bump (diff)
downloadgentoo-2-73f8b2f7e272f2bcbad6c74dc6c958b4fdfd5844.tar.gz
gentoo-2-73f8b2f7e272f2bcbad6c74dc6c958b4fdfd5844.tar.bz2
gentoo-2-73f8b2f7e272f2bcbad6c74dc6c958b4fdfd5844.zip
Fixed problems with octave files and added a patch to correct a bug in a C macro (see bug #182949).
(Portage version: 2.1.3.5)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/plplot/ChangeLog7
-rw-r--r--sci-libs/plplot/files/plplot-5.5.2-macro-fix.patch12
-rw-r--r--sci-libs/plplot/plplot-5.5.2.ebuild21
3 files changed, 28 insertions, 12 deletions
diff --git a/sci-libs/plplot/ChangeLog b/sci-libs/plplot/ChangeLog
index 7b02d28005c3..618b9882fe42 100644
--- a/sci-libs/plplot/ChangeLog
+++ b/sci-libs/plplot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/plplot
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/plplot/ChangeLog,v 1.11 2007/07/22 07:05:08 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/plplot/ChangeLog,v 1.12 2007/08/14 03:37:21 markusle Exp $
+
+ 14 Aug 2007; Markus Dittrich <markusle@gentoo.org>
+ +files/plplot-5.5.2-macro-fix.patch, plplot-5.5.2.ebuild:
+ Fixed problems with octave files and added a patch to correct
+ a bug in a C macro (see bug #182949).
22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>; plplot-5.5.2.ebuild:
Drop virtual/x11 references.
diff --git a/sci-libs/plplot/files/plplot-5.5.2-macro-fix.patch b/sci-libs/plplot/files/plplot-5.5.2-macro-fix.patch
new file mode 100644
index 000000000000..7e97070a3280
--- /dev/null
+++ b/sci-libs/plplot/files/plplot-5.5.2-macro-fix.patch
@@ -0,0 +1,12 @@
+diff -Naur plplot-5.5.2/drivers/gd.c plplot-5.5.2.new/drivers/gd.c
+--- plplot-5.5.2/drivers/gd.c 2005-03-07 16:33:42.000000000 -0500
++++ plplot-5.5.2.new/drivers/gd.c 2007-08-13 15:30:09.000000000 -0400
+@@ -137,7 +137,7 @@
+ "png:PNG file:0:gd:39:png\n";
+ #else
+ #if defined(PLD_png) && defined(PLD_gif)
+- char* plD_DEVICE_INFO_gd = "png:PNG file:0:gd:39:png\n";
++ char* plD_DEVICE_INFO_gd = "png:PNG file:0:gd:39:png\n"
+ "gif:GIF file:0:gd:47:gif";
+ #else
+
diff --git a/sci-libs/plplot/plplot-5.5.2.ebuild b/sci-libs/plplot/plplot-5.5.2.ebuild
index cc715599a60f..9a5b810e0eef 100644
--- a/sci-libs/plplot/plplot-5.5.2.ebuild
+++ b/sci-libs/plplot/plplot-5.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/plplot/plplot-5.5.2.ebuild,v 1.9 2007/07/22 07:05:08 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/plplot/plplot-5.5.2.ebuild,v 1.10 2007/08/14 03:37:21 markusle Exp $
inherit eutils
@@ -59,9 +59,16 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd ${S}
- # Fix compilation problems on GCC 3.4 and the octave bindings, thanks to the
- # patch from Debian's BTS bug 274359.
+ # Fix compilation problems on GCC 3.4 and the octave
+ # bindings, thanks to the patch from Debian's BTS bug 274359.
epatch ${FILESDIR}/${PN}-5.5.1-gcc-3.4-fix.patch
+ epatch ${FILESDIR}/${P}-macro-fix.patch
+
+ # properly detect octave 2.9.x
+ sed -e "s:filepath:filedir:" \
+ -e "s:plplot_octave$:plplot/octave:" \
+ -i configure \
+ || die "Failed to make configure octave 2.9.x aware"
}
src_compile() {
@@ -155,14 +162,6 @@ src_install() {
mv ${D}/usr/lib/java/plplot ${D}/usr/share/${PN}/lib
rm -r ${D}/usr/lib/java
fi
- if use octave; then
- # fix the path to plplot's .m files
- mv ${D}/usr/share/plplot_octave ${D}/usr/share/plplot/octave || die \
- "Error moving octave files."
- sed -i -e 's|/usr/share/plplot_octave|/usr/share/plplot/octave|' \
- ${D}/usr/share/octave/site/m/PLplot/plplot_octave_path.m \
- || die "sed replacement of octave path failed."
- fi
# Fix permissions and gzip the basic documentation.
chmod 644 ${D}/usr/share/doc/${PF}/*