summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-12-05 13:51:36 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-12-05 13:51:36 +0000
commit6c1fea14f18787651094d098ec95e2948fda4d20 (patch)
tree26e9ede61b2c8bcd4dbf5aa6d0b149b445fc88c3 /sci-libs
parentQA: Fix SRC_URI (diff)
downloadgentoo-2-6c1fea14f18787651094d098ec95e2948fda4d20.tar.gz
gentoo-2-6c1fea14f18787651094d098ec95e2948fda4d20.tar.bz2
gentoo-2-6c1fea14f18787651094d098ec95e2948fda4d20.zip
Version bump (this fixes bug #157128).
(Portage version: 2.1.2_rc2-r4)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/itpp/ChangeLog8
-rw-r--r--sci-libs/itpp/files/digest-itpp-3.10.73
-rw-r--r--sci-libs/itpp/itpp-3.10.7.ebuild58
3 files changed, 68 insertions, 1 deletions
diff --git a/sci-libs/itpp/ChangeLog b/sci-libs/itpp/ChangeLog
index a0508f1f520d..d0b081055df5 100644
--- a/sci-libs/itpp/ChangeLog
+++ b/sci-libs/itpp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/itpp
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.15 2006/11/23 20:31:03 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.16 2006/12/05 13:51:36 markusle Exp $
+
+*itpp-3.10.7 (05 Dec 2006)
+
+ 05 Dec 2006; Markus Dittrich <markusle@gentoo.org> +itpp-3.10.7.ebuild:
+ Version bump (this fixes bug #157128). As usual, thanks much to
+ Adam Piatyszek <ediap@et.put.poznan.pl> for keeping us up to date.
23 Nov 2006; <blubb@gentoo.org> itpp-3.10.6.ebuild:
stable on amd64
diff --git a/sci-libs/itpp/files/digest-itpp-3.10.7 b/sci-libs/itpp/files/digest-itpp-3.10.7
new file mode 100644
index 000000000000..b3cc35915665
--- /dev/null
+++ b/sci-libs/itpp/files/digest-itpp-3.10.7
@@ -0,0 +1,3 @@
+MD5 c46c74352f735955d53ba762196039a6 itpp-3.10.7.tar.bz2 799040
+RMD160 a515bc4f71833c76cd421194f65175dffd30fb57 itpp-3.10.7.tar.bz2 799040
+SHA256 1724fad1120042152ca5bb066fe7b71d5c5b30848a9e573c7dcf7e2875c3321d itpp-3.10.7.tar.bz2 799040
diff --git a/sci-libs/itpp/itpp-3.10.7.ebuild b/sci-libs/itpp/itpp-3.10.7.ebuild
new file mode 100644
index 000000000000..e4899e96f6d9
--- /dev/null
+++ b/sci-libs/itpp/itpp-3.10.7.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-3.10.7.ebuild,v 1.1 2006/12/05 13:51:36 markusle Exp $
+
+inherit fortran
+
+DESCRIPTION="IT++ is a C++ library of mathematical, signal processing, speech processing, and communications classes and functions"
+LICENSE="GPL-2"
+HOMEPAGE="http://itpp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="blas cblas debug doc fftw lapack"
+
+DEPEND="fftw? ( >=sci-libs/fftw-3.0.0 )
+ blas? ( virtual/blas
+ cblas? ( || ( >=sci-libs/gsl-1.4
+ >=sci-libs/acml-2.5.3
+ >=sci-libs/blas-atlas-3.6.0
+ sci-libs/cblas-reference ) )
+ lapack? ( virtual/lapack ) )
+ doc? ( app-doc/doxygen
+ virtual/tetex )"
+
+pkg_setup() {
+ # lapack/cblas can only be used in conjunction with blas
+ if use cblas && ! use blas; then
+ die "USE=cblas requires USE=blas to be set"
+ fi
+ if use lapack && ! use blas; then
+ die "USE=lapack requires USE=blas to be set"
+ fi
+}
+
+src_compile() {
+ local myconf
+
+ if use blas; then
+ myconf="--with-blas=-lblas"
+ else
+ myconf="--without-blas"
+ fi
+ econf $(use_enable doc html-doc) \
+ $(use_enable debug) \
+ $(use_with cblas) \
+ $(use_with lapack) \
+ $(use_with fftw fft) \
+ "$myconf" \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO || \
+ die "failed to install docs"
+}