summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-02 07:29:42 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-02 07:29:42 +0000
commit37cfc6a751a5f9322aa56e607f0dcfa0999bda8c (patch)
tree45da44621d545b54da34bc85e2b02bafab6ba118 /sci-libs
parentVersion bump. Drop ppc64 keyword due to dev-ruby/bundler dependency, bug 369741. (diff)
downloadgentoo-2-37cfc6a751a5f9322aa56e607f0dcfa0999bda8c.tar.gz
gentoo-2-37cfc6a751a5f9322aa56e607f0dcfa0999bda8c.tar.bz2
gentoo-2-37cfc6a751a5f9322aa56e607f0dcfa0999bda8c.zip
Make it gold ready, #369675
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/buddy/ChangeLog8
-rw-r--r--sci-libs/buddy/buddy-2.2.ebuild25
-rw-r--r--sci-libs/buddy/buddy-2.4.ebuild42
-rw-r--r--sci-libs/buddy/files/buddy-2.4-gold.patch16
4 files changed, 53 insertions, 38 deletions
diff --git a/sci-libs/buddy/ChangeLog b/sci-libs/buddy/ChangeLog
index 757be4e657bb..381b53ed7e39 100644
--- a/sci-libs/buddy/ChangeLog
+++ b/sci-libs/buddy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/buddy
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/buddy/ChangeLog,v 1.8 2010/01/02 18:06:57 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/buddy/ChangeLog,v 1.9 2011/06/02 07:29:42 jlec Exp $
+
+ 02 Jun 2011; Justin Lecher <jlec@gentoo.org> buddy-2.2.ebuild,
+ buddy-2.4.ebuild, +files/buddy-2.4-gold.patch:
+ Make it gold ready, #369675
02 Jan 2010; Christian Faulhammer <fauli@gentoo.org> buddy-2.4.ebuild:
Transfer Prefix keywords
diff --git a/sci-libs/buddy/buddy-2.2.ebuild b/sci-libs/buddy/buddy-2.2.ebuild
index b0e7c5eff6f9..a013d2c2a0f1 100644
--- a/sci-libs/buddy/buddy-2.2.ebuild
+++ b/sci-libs/buddy/buddy-2.2.ebuild
@@ -1,32 +1,31 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/buddy/buddy-2.2.ebuild,v 1.3 2009/09/23 20:06:00 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/buddy/buddy-2.2.ebuild,v 1.4 2011/06/02 07:29:42 jlec Exp $
-DESCRIPTION="BuDDY - A Binary Decision Diagram Package"
+DESCRIPTION="Binary Decision Diagram Package"
HOMEPAGE="http://www.itu.dk/research/buddy/"
SRC_URI="http://www.itu.dk/research/buddy/buddy22.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="x86 ~ppc"
-
IUSE=""
-DEPEND=""
S=${WORKDIR}/buddy22
src_compile() {
- make CFLAGS="${CFLAGS}" \
- LIBDIR=usr/lib \
- INCDIR=usr/include \
- || die
+ emake \
+ CFLAGS="${CFLAGS}" \
+ LIBDIR=usr/lib \
+ INCDIR=usr/include \
+ || die
}
src_install() {
- install -d "${D}"/usr/lib "${D}"/usr/include
- make install \
- LIBDIR="${D}"/usr/lib \
- INCDIR="${D}"/usr/include || die
+ dodir /usr/lib /usr/include
+ emake install \
+ LIBDIR="${D}"/usr/lib \
+ INCDIR="${D}"/usr/include || die
dodoc CHANGES README doc/*.txt
insinto /usr/share/doc/${P}/ps
doins doc/*.ps
diff --git a/sci-libs/buddy/buddy-2.4.ebuild b/sci-libs/buddy/buddy-2.4.ebuild
index eff50e23b750..fe87ef6f0af5 100644
--- a/sci-libs/buddy/buddy-2.4.ebuild
+++ b/sci-libs/buddy/buddy-2.4.ebuild
@@ -1,40 +1,36 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/buddy/buddy-2.4.ebuild,v 1.5 2010/01/02 18:06:57 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/buddy/buddy-2.4.ebuild,v 1.6 2011/06/02 07:29:42 jlec Exp $
+
+EAPI=4
inherit eutils
-DESCRIPTION="BuDDY - A Binary Decision Diagram Package"
-HOMEPAGE="http://sourceforge.net/projects/buddy"
+DESCRIPTION="Binary Decision Diagram Package"
+HOMEPAGE="http://sourceforge.net/projects/buddy/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~x86-linux ~ppc-macos"
+IUSE="examples"
-IUSE=""
-DEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-gcc43.patch
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gold.patch
}
src_install() {
- emake install DESTDIR="${D}" || die "emake install failed"
+ default
- dodoc ChangeLog NEWS AUTHORS README doc/*.txt || \
- die "failed to install docs"
+ dodoc doc/*.txt
- insinto /usr/share/doc/${P}/ps
- doins doc/*.ps || die "failed to install postscripts files"
+ insinto /usr/share/doc/${PF}/ps
+ doins doc/*.ps
- insinto /usr/share/${PN}/examples
- cd examples
- for example in *; do
- tar -czf ${example}.tar.gz ${example}
- doins ${example}.tar.gz
- done
+ if use examples; then
+ insinto /usr/share/${PN}/
+ doins -r examples
+ fi
}
diff --git a/sci-libs/buddy/files/buddy-2.4-gold.patch b/sci-libs/buddy/files/buddy-2.4-gold.patch
new file mode 100644
index 000000000000..dc30a642141d
--- /dev/null
+++ b/sci-libs/buddy/files/buddy-2.4-gold.patch
@@ -0,0 +1,16 @@
+ examples/cmilner/Makefile.in | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/examples/cmilner/Makefile.in b/examples/cmilner/Makefile.in
+index 9b49e9d..f7a9b8a 100644
+--- a/examples/cmilner/Makefile.in
++++ b/examples/cmilner/Makefile.in
+@@ -217,7 +217,7 @@ clean-checkPROGRAMS:
+ done
+ cmilner$(EXEEXT): $(cmilner_OBJECTS) $(cmilner_DEPENDENCIES)
+ @rm -f cmilner$(EXEEXT)
+- $(LINK) $(cmilner_LDFLAGS) $(cmilner_OBJECTS) $(cmilner_LDADD) $(LIBS)
++ $(LINK) $(cmilner_LDFLAGS) $(cmilner_OBJECTS) $(cmilner_LDADD) $(LIBS) -lm
+
+ mostlyclean-compile:
+ -rm -f *.$(OBJEXT)