summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-02-02 23:01:37 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-02-02 23:01:37 +0000
commit1efa25c1e806d6ceefac614e23ce5366122795a5 (patch)
treeed3494b219bcc16aab8d208b58380381aeebefa3 /sci-libs
parentFix etc installation prefix. Thanks to billie for the report. (diff)
downloadgentoo-2-1efa25c1e806d6ceefac614e23ce5366122795a5.tar.gz
gentoo-2-1efa25c1e806d6ceefac614e23ce5366122795a5.tar.bz2
gentoo-2-1efa25c1e806d6ceefac614e23ce5366122795a5.zip
Version bump, now propagates flags properly and backport changes to 1.7
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libcore/ChangeLog10
-rw-r--r--sci-libs/libcore/files/libcore-1.7.patch19
-rw-r--r--sci-libs/libcore/libcore-1.7.ebuild8
-rw-r--r--sci-libs/libcore/libcore-1.8.ebuild60
4 files changed, 78 insertions, 19 deletions
diff --git a/sci-libs/libcore/ChangeLog b/sci-libs/libcore/ChangeLog
index 3820e4621049..e6961b57030c 100644
--- a/sci-libs/libcore/ChangeLog
+++ b/sci-libs/libcore/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/libcore
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libcore/ChangeLog,v 1.4 2008/09/03 09:32:37 bicatali Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libcore/ChangeLog,v 1.5 2009/02/02 23:01:37 bicatali Exp $
+
+*libcore-1.8 (02 Feb 2009)
+
+ 02 Feb 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ files/libcore-1.7.patch, libcore-1.7.ebuild, +libcore-1.8.ebuild:
+ Version bump, now propagates flags properly and backport changes to 1.7
03 Sep 2008; Sébastien Fabbro <bicatali@gentoo.org> libcore-1.7.ebuild:
Fixed virtual/tetex, tested on am64 and some cleaning
diff --git a/sci-libs/libcore/files/libcore-1.7.patch b/sci-libs/libcore/files/libcore-1.7.patch
index 645c10af023f..dcc2c77ac45b 100644
--- a/sci-libs/libcore/files/libcore-1.7.patch
+++ b/sci-libs/libcore/files/libcore-1.7.patch
@@ -24,7 +24,7 @@
${CORE_SHARED_LIB}: $(EXPROBJS)
- $(CXX) $(CORE_LDFLAGS) -o $@ $^
-+ $(CXX) $(CORE_LDFLAGS) -Wl,-soname,$(CORE_SHARED_LIB_NAME).1 -o $@ $^
++ $(CXX) $(LDFLAGS) $(CORE_LDFLAGS) -Wl,-soname,$(CORE_SHARED_LIB_NAME).1 -o $@ $^
%${VAR}.o: %.cpp
# Aug 8, 2004 by Chee (TEMP CHANGE! FOR DEBUGGING)
@@ -60,7 +60,7 @@
${COREX_SHARED_LIB_LEVEL3}: ${L3_OBJS}
-@rm -rf $@
- $(CXX) $(CORE_LDFLAGS) -o $@ $?
-+ $(CXX) $(CORE_LDFLAGS) -Wl,-soname,$(COREX_SHARED_LIB_LEVEL3_NAME).1 -o $@ $?
++ $(CXX) $(LDFLAGS) $(CORE_LDFLAGS) -Wl,-soname,$(COREX_SHARED_LIB_LEVEL3_NAME).1 -o $@ $?
${COREX_LIB_LEVEL2}: ${L2_OBJS}
-@rm -rf $@
@@ -69,7 +69,7 @@
${COREX_SHARED_LIB_LEVEL2}: ${L2_OBJS}
-@rm -rf $@
- $(CXX) $(CORE_LDFLAGS) -o $@ $?
-+ $(CXX) $(CORE_LDFLAGS) -Wl,-soname,$(COREX_SHARED_LIB_LEVEL2_NAME).1 -o $@ $?
++ $(CXX) $(LDFLAGS) $(CORE_LDFLAGS) -Wl,-soname,$(COREX_SHARED_LIB_LEVEL2_NAME).1 -o $@ $?
${COREX_LIB_LEVEL1}: ${L1_OBJS}
-@rm -rf $@
@@ -78,7 +78,7 @@
${COREX_SHARED_LIB_LEVEL1}: ${L1_OBJS}
-@rm -rf $@
- $(CXX) $(CORE_LDFLAGS) -o $@ $?
-+ $(CXX) $(CORE_LDFLAGS) -Wl,-soname,$(COREX_SHARED_LIB_LEVEL1_NAME).1 -o $@ $?
++ $(CXX) $(LDFLAGS) $(CORE_LDFLAGS) -Wl,-soname,$(COREX_SHARED_LIB_LEVEL1_NAME).1 -o $@ $?
%_level3.o: %.cpp
- ${CXX} $(CORE_CXXFLAGS) -DCORE_LEVEL=3 $(INCLUDE) -c $< -o $@
@@ -94,14 +94,3 @@
clean:
-@test -z "*.o" || rm -f *.o
---- Make.config 2005-02-02 14:25:29.000000000 +0100
-+++ Make.config 2006-10-12 20:20:59.000000000 +0200
-@@ -217,7 +217,7 @@
- ifeq (${VAR}, Debug)
- CXXFLAGS=-g -Wall
- else
-- CXXFLAGS=-O2 -Wall -DNDEBUG
-+ CXXFLAGS=${CFLAGS} -Wall -DNDEBUG
- endif
-
- ifeq (${VAR}, Opt)
diff --git a/sci-libs/libcore/libcore-1.7.ebuild b/sci-libs/libcore/libcore-1.7.ebuild
index 8fa10e0cd929..2a32fcc8fae8 100644
--- a/sci-libs/libcore/libcore-1.7.ebuild
+++ b/sci-libs/libcore/libcore-1.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libcore/libcore-1.7.ebuild,v 1.4 2008/09/03 09:32:37 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libcore/libcore-1.7.ebuild,v 1.5 2009/02/02 23:01:37 bicatali Exp $
inherit eutils toolchain-funcs
@@ -24,6 +24,10 @@ src_unpack(){
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}.patch
+ sed -i \
+ -e "s/-O2/${CXXFLAGS}/g" \
+ -e "s/-shared/-shared ${LDFLAGS}/g" \
+ Make.config || die
}
src_compile(){
diff --git a/sci-libs/libcore/libcore-1.8.ebuild b/sci-libs/libcore/libcore-1.8.ebuild
new file mode 100644
index 000000000000..789549c7763f
--- /dev/null
+++ b/sci-libs/libcore/libcore-1.8.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libcore/libcore-1.8.ebuild,v 1.1 2009/02/02 23:01:37 bicatali Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+MYP="${PN/lib}_v${PV}"
+
+DESCRIPTION="Robust numerical and geometric computation library"
+HOMEPAGE="http://www.cs.nyu.edu/exact/core_pages/"
+SRC_URI="http://cs.nyu.edu/exact/core/download/${MYP}/${MYP}.tgz
+ doc? ( http://cs.nyu.edu/exact/core/download/${MYP}/${MYP}_doc.tgz )"
+
+LICENSE="QPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-libs/gmp"
+RDEPEND=""
+
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.7.patch
+ sed -i \
+ -e "s/-O2/${CXXFLAGS}/g" \
+ -e "s/-shared/-shared ${LDFLAGS}/g" \
+ Make.config || die
+}
+
+src_compile(){
+ emake LINKAGE=shared corelib corex || die "emake shared failed"
+ emake -C src clean && emake -C ext clean
+ emake corelib corex || die "emake static failed"
+ if use doc; then
+ cd "${S}/doc"
+ emake -j1 all || die "doc creation failed"
+ emake -j1 -C doxy/latex pdf || die "pdf doc creation failed"
+ fi
+}
+
+src_install(){
+ dolib lib/*.a lib/*.so || die "Unable to find libraries"
+ for i in $(find "${D}/usr/$(get_libdir)" -name "*so" | sed "s:${D}::g"); do
+ dosym $i $i.1 && dosym $i $i.1.0.0 || die "Unable to sym $i"
+ done
+
+ dodir /usr/include || die "Unable to create include dir"
+ cp -r ./inc/* "${D}/usr/include/" || die "Unable to copy headers"
+
+ dodoc FAQs README || die "Unable to install default doc"
+ if use doc; then
+ dodoc doc/*.txt
+ insinto /usr/share/doc/${PF}
+ doins doc/papers/* doc/tutorial/tutorial.pdf || die
+ doins -r doc/doxy/html doc/doxy/latex/*pdf || die
+ fi
+}