summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-12-23 12:41:48 +0000
committerJustin Lecher <jlec@gentoo.org>2014-12-23 12:41:48 +0000
commit3dd005a59ba369ed42234ac85a8e4e85d687ab15 (patch)
tree9e1b9bbf67dcbd5de95b8a2a7a720564617c52ad /sci-libs/xkaapi
parentarm stable, bug #532686 (diff)
downloadgentoo-2-3dd005a59ba369ed42234ac85a8e4e85d687ab15.tar.gz
gentoo-2-3dd005a59ba369ed42234ac85a8e4e85d687ab15.tar.bz2
gentoo-2-3dd005a59ba369ed42234ac85a8e4e85d687ab15.zip
sci-libs/xkaapi: Verion Bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-libs/xkaapi')
-rw-r--r--sci-libs/xkaapi/ChangeLog7
-rw-r--r--sci-libs/xkaapi/xkaapi-2.2.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/sci-libs/xkaapi/ChangeLog b/sci-libs/xkaapi/ChangeLog
index ff0dd1988f86..df99dafc93c3 100644
--- a/sci-libs/xkaapi/ChangeLog
+++ b/sci-libs/xkaapi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/xkaapi
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/xkaapi/ChangeLog,v 1.4 2014/12/22 15:51:53 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/xkaapi/ChangeLog,v 1.5 2014/12/23 12:41:48 jlec Exp $
+
+*xkaapi-2.2 (23 Dec 2014)
+
+ 23 Dec 2014; Justin Lecher <jlec@gentoo.org> +xkaapi-2.2.ebuild:
+ Verion Bump
22 Dec 2014; Justin Lecher <jlec@gentoo.org> xkaapi-3.0.3.ebuild:
Drop unrecognised configure options
diff --git a/sci-libs/xkaapi/xkaapi-2.2.ebuild b/sci-libs/xkaapi/xkaapi-2.2.ebuild
new file mode 100644
index 000000000000..760fbf5fed9c
--- /dev/null
+++ b/sci-libs/xkaapi/xkaapi-2.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/xkaapi/xkaapi-2.2.ebuild,v 1.1 2014/12/23 12:41:48 jlec Exp $
+
+EAPI=5
+
+FORTRAN_NEEDED=fortran
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils fortran-2
+
+UPSTREAM_NO=33666
+
+DESCRIPTION="Kernel for Adaptative, Asynchronous Parallel and Interactive programming"
+HOMEPAGE="http://kaapi.gforge.inria.fr"
+SRC_URI="https://gforge.inria.fr/frs/download.php/${UPSTREAM_NO}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="CeCILL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="blas cxx fortran gpu openmp static-libs"
+
+RDEPEND="
+ sys-apps/hwloc
+ virtual/libffi
+"
+DEPEND="${RDEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1-flags.patch
+ "${FILESDIR}"/${PN}-2.1-ffi.patch
+ )
+
+src_prepare() {
+ sed \
+ -e 's:-Werror::g' \
+ -i tests/testsuite* tests/*/*.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-mode=gentoo
+ --enable-api-kaapic
+ --enable-api-quark
+ --with-ccache=no
+ --enable-hwloc
+ --with-libffi="${EPREFIX}"/usr
+ --enable-target$(usex gpu gpu mt)
+ $(use_enable fortran api-kaapif)
+ $(use_enable cxx api-kaapixx)
+ $(use_enable blas kblas)
+ $(use_enable openmp libkomp)
+# $(use_with plasma "${EPREFIX}"/usr)
+ )
+ autotools-utils_src_configure
+}