summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-06-12 12:38:38 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-06-12 12:38:38 +0000
commit0e3804d659a827bd257e8c4cc0a71b2fca6e2708 (patch)
treee75a37a0b7b57cb5fbf0c051ba7a01023b4ab68d /sci-libs/vtk
parentVersion bump. (diff)
downloadgentoo-2-0e3804d659a827bd257e8c4cc0a71b2fca6e2708.tar.gz
gentoo-2-0e3804d659a827bd257e8c4cc0a71b2fca6e2708.tar.bz2
gentoo-2-0e3804d659a827bd257e8c4cc0a71b2fca6e2708.zip
Fix RDEPEND and cmake configuration such that tcl/tk is only pulled in and used if USE=tcltk. This closes bug #136324.
(Portage version: 2.1)
Diffstat (limited to 'sci-libs/vtk')
-rw-r--r--sci-libs/vtk/ChangeLog6
-rw-r--r--sci-libs/vtk/vtk-5.0.0.ebuild15
2 files changed, 16 insertions, 5 deletions
diff --git a/sci-libs/vtk/ChangeLog b/sci-libs/vtk/ChangeLog
index 0ca1e72fdde1..0ce123239228 100644
--- a/sci-libs/vtk/ChangeLog
+++ b/sci-libs/vtk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/vtk
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.17 2006/04/27 22:29:18 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.18 2006/06/12 12:38:38 markusle Exp $
+
+ 11 Jun 2006; Markus Dittrich <markusle@gentoo.org> vtk-5.0.0.ebuild:
+ Fix RDEPEND and cmake configuration such that tcl/tk is only
+ pulled in and used if USE=tcltk. This closes bug #136324.
27 Apr 2006; Alec Warner <antarus@gentoo.org> Manifest:
Fixing SHA256 digest, pass four
diff --git a/sci-libs/vtk/vtk-5.0.0.ebuild b/sci-libs/vtk/vtk-5.0.0.ebuild
index 0c33ba83bdba..4c913bbf1e84 100644
--- a/sci-libs/vtk/vtk-5.0.0.ebuild
+++ b/sci-libs/vtk/vtk-5.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.0.0.ebuild,v 1.5 2006/04/21 02:18:26 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.0.0.ebuild,v 1.6 2006/06/12 12:38:38 markusle Exp $
# TODO: need to fix Examples/CMakeLists.txt to build other examples
@@ -21,8 +21,8 @@ IUSE="doc examples java mpi patented python tcltk threads qt3 qt4"
RDEPEND="java? ( virtual/jdk )
mpi? ( sys-cluster/mpich )
python? ( >=dev-lang/python-2.0 )
- >=dev-lang/tcl-8.2.3
- >=dev-lang/tk-8.2.3
+ tcltk? ( >=dev-lang/tcl-8.2.3
+ >=dev-lang/tk-8.2.3 )
dev-libs/expat
media-libs/jpeg
media-libs/libpng
@@ -123,7 +123,14 @@ src_compile() {
CMAKE_VARIABLES="${CMAKE_VARIABLES} -DQT_QMAKE_EXECUTABLE:PATH=/usr/bin/qmake"
fi
- use tcltk && CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_WRAP_TCL:BOOL=ON"
+ if use tcltk; then
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_WRAP_TCL:BOOL=ON"
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_USE_TK:BOOL=ON"
+ else
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_WRAP_TCL:BOOL=OFF"
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_USE_TK:BOOL=OFF"
+ fi
+
use threads && CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_USE_PARALLEL:BOOL=ON"
use patented && CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_USE_PATENTED:BOOL=ON"
use doc && CMAKE_VARIABLES="${CMAKE_VARIABLES} -DDOCUMENTATION_HTML_HELP:BOOL=ON -DBUILD_DOCUMENTATION:BOOL=ON"