summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-01-11 16:55:51 +0000
committerJustin Lecher <jlec@gentoo.org>2014-01-11 16:55:51 +0000
commit4874b26e3e89720c1d7a506618df67ce96357e23 (patch)
tree8d1f0227dbca2b05ff8acc022ef5867a23e0c1bf /sci-libs/vtk/files
parentsci-libs/vtk: Version Bump; support offscreen rendering, #126270; unbundle as... (diff)
downloadgentoo-2-4874b26e3e89720c1d7a506618df67ce96357e23.tar.gz
gentoo-2-4874b26e3e89720c1d7a506618df67ce96357e23.tar.bz2
gentoo-2-4874b26e3e89720c1d7a506618df67ce96357e23.zip
sci-libs/vtk: Version Bump; support offscreen rendering, #126270; unbundle as many as possible libs, #433481
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-libs/vtk/files')
-rw-r--r--sci-libs/vtk/files/vtk-6.0.0-install.patch19
-rw-r--r--sci-libs/vtk/files/vtk-6.0.0-netcdf.patch75
-rw-r--r--sci-libs/vtk/files/vtk-6.0.0-system.patch27
-rw-r--r--sci-libs/vtk/files/vtk-6.0.0-vtkpython.patch12
4 files changed, 133 insertions, 0 deletions
diff --git a/sci-libs/vtk/files/vtk-6.0.0-install.patch b/sci-libs/vtk/files/vtk-6.0.0-install.patch
new file mode 100644
index 000000000000..a97755ab69ff
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-6.0.0-install.patch
@@ -0,0 +1,19 @@
+diff -up VTK6.0.0/CMake/vtkModuleTop.cmake.install VTK6.0.0/CMake/vtkModuleTop.cmake
+--- VTK6.0.0/CMake/vtkModuleTop.cmake.install 2013-06-12 13:47:10.000000000 -0600
++++ VTK6.0.0/CMake/vtkModuleTop.cmake 2013-07-12 16:15:15.706008475 -0600
+@@ -330,10 +330,15 @@ if (NOT VTK_INSTALL_NO_DEVELOPMENT)
+ CMake/pythonmodules.h.in
+ CMake/UseVTK.cmake
+ CMake/FindTCL.cmake
++ CMake/TopologicalSort.cmake
+ CMake/vtkTclTkMacros.cmake
+ CMake/vtk-forward.c.in
+ CMake/vtkForwardingExecutable.cmake
++ CMake/vtkGroups.cmake
+ CMake/vtkJavaWrapping.cmake
++ CMake/vtkMakeInstantiator.cmake
++ CMake/vtkMakeInstantiator.cxx.in
++ CMake/vtkMakeInstantiator.h.in
+ CMake/vtkModuleAPI.cmake
+ CMake/vtkModuleHeaders.cmake.in
+ CMake/vtkModuleInfo.cmake.in
diff --git a/sci-libs/vtk/files/vtk-6.0.0-netcdf.patch b/sci-libs/vtk/files/vtk-6.0.0-netcdf.patch
new file mode 100644
index 000000000000..df0ef94890f7
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-6.0.0-netcdf.patch
@@ -0,0 +1,75 @@
+diff -up VTK/IO/NetCDF/CMakeLists.txt.netcdf VTK/IO/NetCDF/CMakeLists.txt
+--- VTK/IO/NetCDF/CMakeLists.txt.netcdf 2013-01-28 14:44:35.000000000 -0700
++++ VTK/IO/NetCDF/CMakeLists.txt 2013-01-28 15:40:00.825176295 -0700
+@@ -10,5 +10,5 @@ set(Module_SRCS
+
+ vtk_module_library(vtkIONetCDF ${Module_SRCS})
+
+-target_link_libraries(vtkIONetCDF vtkNetCDF_cxx)
++target_link_libraries(vtkIONetCDF netcdf_c++ netcdf)
+ set_target_properties(vtkIONetCDF PROPERTIES LINK_INTERFACE_LIBRARIES "")
+diff -up VTK/IO/ParallelNetCDF/CMakeLists.txt.netcdf VTK/IO/ParallelNetCDF/CMakeLists.txt
+--- VTK/IO/ParallelNetCDF/CMakeLists.txt.netcdf 2013-01-28 14:44:35.000000000 -0700
++++ VTK/IO/ParallelNetCDF/CMakeLists.txt 2013-01-28 15:40:00.825176295 -0700
+@@ -8,4 +8,4 @@ set(Module_SRCS
+
+ vtk_module_library(vtkIOParallelNetCDF ${Module_SRCS})
+
+-target_link_libraries(vtkIOParallelNetCDF vtkNetCDF_cxx)
++target_link_libraries(vtkIOParallelNetCDF netcdf)
+diff -up VTK/ThirdParty/exodusII/vtkexodusII/CMakeLists.txt.netcdf VTK/ThirdParty/exodusII/vtkexodusII/CMakeLists.txt
+--- VTK/ThirdParty/exodusII/vtkexodusII/CMakeLists.txt.netcdf 2013-01-28 14:44:36.000000000 -0700
++++ VTK/ThirdParty/exodusII/vtkexodusII/CMakeLists.txt 2013-01-28 15:40:27.534030910 -0700
+@@ -241,7 +241,7 @@ ENDIF(APPLE)
+
+
+ VTK_ADD_LIBRARY(vtkexoIIc ${cbind_SRCS})
+-TARGET_LINK_LIBRARIES(vtkexoIIc vtkNetCDF)
++TARGET_LINK_LIBRARIES(vtkexoIIc netcdf)
+
+ #INCLUDE (${CMAKE_ROOT}/Modules/Dart.cmake)
+
+diff -up VTK/ThirdParty/netcdf/CMakeLists.txt.netcdf VTK/ThirdParty/netcdf/CMakeLists.txt
+--- VTK/ThirdParty/netcdf/CMakeLists.txt.netcdf 2013-01-28 14:44:36.000000000 -0700
++++ VTK/ThirdParty/netcdf/CMakeLists.txt 2013-01-28 15:40:00.825176295 -0700
+@@ -1,8 +1,12 @@
+ set(vtknetcdf_THIRD_PARTY 1)
+-set(vtknetcdf_LIBRARIES vtkNetCDF vtkNetCDF_cxx)
+-set(vtknetcdf_INCLUDE_DIRS
+- ${vtknetcdf_SOURCE_DIR}/vtknetcdf/include
+- ${vtknetcdf_BINARY_DIR}/vtknetcdf
+- )
++if(NOT VTK_USE_SYSTEM_NETCDF)
++ set(vtknetcdf_LIBRARIES vtkNetCDF vtkNetCDF_cxx)
++ set(vtknetcdf_INCLUDE_DIRS
++ ${vtknetcdf_SOURCE_DIR}/vtknetcdf/include
++ ${vtknetcdf_BINARY_DIR}/vtknetcdf
++ )
++ add_subdirectory(vtknetcdf)
++else(NOT VTK_USE_SYSTEM_NETCDF)
++ set(vtknetcdf_LIBRARIES netcdf)
++endif()
+ vtk_module_export_info()
+-add_subdirectory(vtknetcdf)
+diff -up VTK/ThirdParty/netcdf/vtk_netcdfcpp.h.netcdf VTK/ThirdParty/netcdf/vtk_netcdfcpp.h
+--- VTK/ThirdParty/netcdf/vtk_netcdfcpp.h.netcdf 2013-01-28 14:44:36.000000000 -0700
++++ VTK/ThirdParty/netcdf/vtk_netcdfcpp.h 2013-01-28 15:40:00.826176289 -0700
+@@ -16,6 +16,6 @@
+ #define __vtk_netcdfcpp_h
+
+ /* Use the netcdf library configured for VTK. */
+-#include <vtknetcdf/cxx/netcdfcpp.h>
++#include <netcdfcpp.h>
+
+ #endif
+diff -up VTK/ThirdParty/netcdf/vtk_netcdf.h.netcdf VTK/ThirdParty/netcdf/vtk_netcdf.h
+--- VTK/ThirdParty/netcdf/vtk_netcdf.h.netcdf 2013-01-28 14:44:36.000000000 -0700
++++ VTK/ThirdParty/netcdf/vtk_netcdf.h 2013-01-28 15:40:00.826176289 -0700
+@@ -16,6 +16,6 @@
+ #define __vtk_netcdf_h
+
+ /* Use the netcdf library configured for VTK. */
+-#include <vtknetcdf/include/netcdf.h>
++#include <netcdf.h>
+
+ #endif
diff --git a/sci-libs/vtk/files/vtk-6.0.0-system.patch b/sci-libs/vtk/files/vtk-6.0.0-system.patch
new file mode 100644
index 000000000000..3e5762fe5d46
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-6.0.0-system.patch
@@ -0,0 +1,27 @@
+diff -up VTK6.0.0/CMake/vtkModuleMacros.cmake.system VTK6.0.0/CMake/vtkModuleMacros.cmake
+--- VTK6.0.0/CMake/vtkModuleMacros.cmake.system 2013-06-12 13:47:10.000000000 -0600
++++ VTK6.0.0/CMake/vtkModuleMacros.cmake 2013-12-27 20:59:39.548152746 -0700
+@@ -613,7 +613,7 @@ macro(vtk_module_third_party _pkg)
+ message(FATAL_ERROR "Cannot specify both LIBRARIES and NO_LIBRARIES")
+ endif()
+
+- option(VTK_USE_SYSTEM_${_upper} "Use system-installed ${_pkg}" OFF)
++ option(VTK_USE_SYSTEM_${_upper} "Use system-installed ${_pkg}" ${VTK_USE_SYSTEM_LIBRARIES})
+ mark_as_advanced(VTK_USE_SYSTEM_${_upper})
+
+ if(VTK_USE_SYSTEM_${_upper})
+diff -up VTK6.0.0/CMakeLists.txt.system VTK6.0.0/CMakeLists.txt
+--- VTK6.0.0/CMakeLists.txt.system 2013-06-12 13:47:10.000000000 -0600
++++ VTK6.0.0/CMakeLists.txt 2013-12-27 20:59:39.548152746 -0700
+@@ -107,6 +107,11 @@ set(VTK_INSTALL_INCLUDE_DIR_CM24 ${VTK_I
+ set(VTK_INSTALL_DOXYGEN_DIR_CM24 ${VTK_INSTALL_DATA_DIR}/doxygen)
+
+ #-----------------------------------------------------------------------------
++# Do we try to use system libraries by default?
++OPTION(VTK_USE_SYSTEM_LIBRARIES "Use the system's libraries by default." OFF)
++MARK_AS_ADVANCED(VTK_USE_SYSTEM_LIBRARIES)
++
++#-----------------------------------------------------------------------------
+ # The third party macros are still used in one or two third party builds.
+ include(vtkThirdParty)
+
diff --git a/sci-libs/vtk/files/vtk-6.0.0-vtkpython.patch b/sci-libs/vtk/files/vtk-6.0.0-vtkpython.patch
new file mode 100644
index 000000000000..f310479e8ab8
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-6.0.0-vtkpython.patch
@@ -0,0 +1,12 @@
+diff -up VTK6.0.0/Wrapping/Python/CMakeLists.txt.vtkpython VTK6.0.0/Wrapping/Python/CMakeLists.txt
+--- VTK6.0.0/Wrapping/Python/CMakeLists.txt.vtkpython 2013-06-12 13:47:10.000000000 -0600
++++ VTK6.0.0/Wrapping/Python/CMakeLists.txt 2013-07-26 16:44:19.954295281 -0600
+@@ -371,3 +371,8 @@ endif()
+
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/setup.py.in
+ ${CMAKE_CURRENT_BINARY_DIR}/setup.py @ONLY IMMEDIATE)
++
++if(NOT VTK_INSTALL_NO_RUNTIME AND NOT VTK_INSTALL_NO_PYTHON)
++ install(TARGETS vtkpython ${VTKPYTHON_EXECUTABLE}
++ DESTINATION ${VTK_INSTALL_RUNTIME_DIR})
++endif()