summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-11-12 02:20:56 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-11-12 02:20:56 +0000
commit79cbb414ba40e6036ea24ddd1e31a14eb0fa45a2 (patch)
tree46f9ae3ef1653ceb21cb763f794aabf26fa518b2 /sci-libs/spqr
parentVersion bump (diff)
downloadgentoo-2-79cbb414ba40e6036ea24ddd1e31a14eb0fa45a2.tar.gz
gentoo-2-79cbb414ba40e6036ea24ddd1e31a14eb0fa45a2.tar.bz2
gentoo-2-79cbb414ba40e6036ea24ddd1e31a14eb0fa45a2.zip
Version bump
(Portage version: 2.2.01.21313-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs/spqr')
-rw-r--r--sci-libs/spqr/ChangeLog9
-rw-r--r--sci-libs/spqr/metadata.xml7
-rw-r--r--sci-libs/spqr/spqr-1.3.1.ebuild32
3 files changed, 42 insertions, 6 deletions
diff --git a/sci-libs/spqr/ChangeLog b/sci-libs/spqr/ChangeLog
index 8fde861e55e1..57cd6952099c 100644
--- a/sci-libs/spqr/ChangeLog
+++ b/sci-libs/spqr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/spqr
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/spqr/ChangeLog,v 1.9 2012/05/04 08:22:54 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/spqr/ChangeLog,v 1.10 2012/11/12 02:20:56 bicatali Exp $
+
+*spqr-1.3.1 (12 Nov 2012)
+
+ 12 Nov 2012; Sébastien Fabbro <bicatali@gentoo.org> +spqr-1.3.1.ebuild,
+ metadata.xml:
+ Version bump
04 May 2012; Jeff Horelick <jdhore@gentoo.org> spqr-1.2.3.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
@@ -49,4 +55,3 @@
+files/spqr-1.1.0-autotools.patch, +files/spqr-1.1.0-gcc43.patch,
+metadata.xml, +spqr-1.1.0.ebuild:
Initial import
-
diff --git a/sci-libs/spqr/metadata.xml b/sci-libs/spqr/metadata.xml
index 1173b0ece1d7..ed49aa297db1 100644
--- a/sci-libs/spqr/metadata.xml
+++ b/sci-libs/spqr/metadata.xml
@@ -10,9 +10,8 @@
peak performance of a multicore computer.
</longdescription>
<use>
- <flag name='metis'>Use METIS (<pkg>sci-libs/metis</pkg>
- or <pkg>sci-libs/parmetis</pkg>) for partitioning</flag>
- <flag name='tbb'>Enable multithreading with the Intel Threads Building Block
- (needs <pkg>dev-cpp/tbb</pkg>)</flag>
+ <flag name='metis'>Use <pkg>sci-libs/metis</pkg> or <pkg>sci-libs/parmetis</pkg> for partitioning</flag>
+ <flag name='tbb'>Enable multithreading with the Intel Threads
+ Building Block <pkg>dev-cpp/tbb</pkg></flag>
</use>
</pkgmetadata>
diff --git a/sci-libs/spqr/spqr-1.3.1.ebuild b/sci-libs/spqr/spqr-1.3.1.ebuild
new file mode 100644
index 000000000000..b1ec736c3fe9
--- /dev/null
+++ b/sci-libs/spqr/spqr-1.3.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/spqr/spqr-1.3.1.ebuild,v 1.1 2012/11/12 02:20:56 bicatali Exp $
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="Multithreaded multifrontal sparse QR factorization library"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/SPQR"
+SRC_URI="http://dev.gentoo.org/~bicatali/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc metis static-libs tbb"
+RDEPEND="
+ >=sci-libs/cholmod-2
+ tbb? ( dev-cpp/tbb )
+ metis? ( >=sci-libs/cholmod-2[metis] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( virtual/latex-base )"
+
+src_configure() {
+ local myeconfargs+=(
+ $(use_with doc)
+ $(use_with metis partition)
+ $(use_with tbb)
+ )
+ autotools-utils_src_configure
+}