summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-02-07 17:30:59 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-02-07 17:30:59 +0000
commit344a44f52bd7ea05488794ebcb998bc72caf56d5 (patch)
tree13982777f199c0797e008e92a24f5bf49cb36092 /sci-libs/scotch
parentMarked stable for amd64 wrt bug #455768 (diff)
downloadgentoo-2-344a44f52bd7ea05488794ebcb998bc72caf56d5.tar.gz
gentoo-2-344a44f52bd7ea05488794ebcb998bc72caf56d5.tar.bz2
gentoo-2-344a44f52bd7ea05488794ebcb998bc72caf56d5.zip
Fixed for parallel compiling when mpi flag is set
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs/scotch')
-rw-r--r--sci-libs/scotch/ChangeLog6
-rw-r--r--sci-libs/scotch/files/scotch-6.0.0-as-needed.patch37
2 files changed, 23 insertions, 20 deletions
diff --git a/sci-libs/scotch/ChangeLog b/sci-libs/scotch/ChangeLog
index 58a9cfe823d9..036aa6b191d1 100644
--- a/sci-libs/scotch/ChangeLog
+++ b/sci-libs/scotch/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/scotch
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scotch/ChangeLog,v 1.10 2013/02/07 07:29:28 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scotch/ChangeLog,v 1.11 2013/02/07 17:30:59 bicatali Exp $
+
+ 07 Feb 2013; Sébastien Fabbro <bicatali@gentoo.org>
+ files/scotch-6.0.0-as-needed.patch:
+ Fixed for parallel compiling when mpi flag is set
*scotch-6.0.0 (07 Feb 2013)
diff --git a/sci-libs/scotch/files/scotch-6.0.0-as-needed.patch b/sci-libs/scotch/files/scotch-6.0.0-as-needed.patch
index 8246cd4c81df..ad41380de884 100644
--- a/sci-libs/scotch/files/scotch-6.0.0-as-needed.patch
+++ b/sci-libs/scotch/files/scotch-6.0.0-as-needed.patch
@@ -1,6 +1,6 @@
diff -Nur src.orig/check/Makefile src/check/Makefile
---- src.orig/check/Makefile 2013-02-06 22:03:30.487658815 -0800
-+++ src/check/Makefile 2013-02-06 23:02:59.724078652 -0800
+--- src.orig/check/Makefile 2013-02-07 17:27:00.000000000 +0000
++++ src/check/Makefile 2013-02-07 17:27:21.000000000 +0000
@@ -48,7 +48,7 @@
$(CC) $(CFLAGS) $(CLIBFLAGS) -I$(SCOTCHINCLUDEDIR) -c $(<) -o $(@)
@@ -11,8 +11,8 @@ diff -Nur src.orig/check/Makefile src/check/Makefile
##
## Project rules.
diff -Nur src.orig/esmumps/Makefile src/esmumps/Makefile
---- src.orig/esmumps/Makefile 2013-02-06 22:03:30.486658809 -0800
-+++ src/esmumps/Makefile 2013-02-06 23:03:17.826171776 -0800
+--- src.orig/esmumps/Makefile 2013-02-07 17:27:00.000000000 +0000
++++ src/esmumps/Makefile 2013-02-07 17:28:11.000000000 +0000
@@ -44,7 +44,7 @@
$(CC) $(CFLAGS) $(CLIBFLAGS) -I$(includedir) -c $(<) -o $(@)
@@ -31,18 +31,17 @@ diff -Nur src.orig/esmumps/Makefile src/esmumps/Makefile
$(MAKE) CFLAGS="$(CFLAGS) -DSCOTCH_PTSCOTCH" CC=$(CCP) SCOTCHLIB=ptscotch ESMUMPSLIB=ptesmumps \
libesmumps$(LIB) \
main_esmumps$(EXE)
-@@ -142,7 +142,7 @@
- common.h \
- esmumps.h
-
--libesmumps$(LIB) : graph_graph$(OBJ) \
-+lib$(ESMUMPSLIB)$(LIB) : graph_graph$(OBJ) \
- order$(OBJ) \
- order_scotch_graph$(OBJ) \
- dof$(OBJ) \
+@@ -160,6 +160,6 @@
+ order.h \
+ symbol.h \
+ esmumps.h \
+- lib$(ESMUMPSLIB)$(LIB) \
++ libesmumps$(LIB) \
+ $(libdir)/lib$(SCOTCHLIB)$(LIB) \
+ $(libdir)/lib$(SCOTCHLIB)errexit$(LIB)
diff -Nur src.orig/libscotch/Makefile src/libscotch/Makefile
---- src.orig/libscotch/Makefile 2013-02-06 22:03:30.494658850 -0800
-+++ src/libscotch/Makefile 2013-02-06 23:03:59.702387230 -0800
+--- src.orig/libscotch/Makefile 2013-02-07 17:27:00.000000000 +0000
++++ src/libscotch/Makefile 2013-02-07 17:27:21.000000000 +0000
@@ -43,7 +43,7 @@
$(CC) $(CFLAGS) $(CLIBFLAGS) -c $(<) -o $(@)
@@ -70,8 +69,8 @@ diff -Nur src.orig/libscotch/Makefile src/libscotch/Makefile
scotch.h : dummysizes$(EXE) \
library.h
diff -Nur src.orig/libscotchmetis/Makefile src/libscotchmetis/Makefile
---- src.orig/libscotchmetis/Makefile 2013-02-06 22:03:30.477658764 -0800
-+++ src/libscotchmetis/Makefile 2013-02-06 22:19:34.684626271 -0800
+--- src.orig/libscotchmetis/Makefile 2013-02-07 17:27:00.000000000 +0000
++++ src/libscotchmetis/Makefile 2013-02-07 17:27:21.000000000 +0000
@@ -44,7 +44,7 @@
$(CC) $(CFLAGS) $(CLIBFLAGS) -I$(includedir) -I../libscotch -c $(<) -o $(@)
@@ -82,8 +81,8 @@ diff -Nur src.orig/libscotchmetis/Makefile src/libscotchmetis/Makefile
##
## Project rules.
diff -Nur src.orig/scotch/Makefile src/scotch/Makefile
---- src.orig/scotch/Makefile 2013-02-06 22:03:30.500658881 -0800
-+++ src/scotch/Makefile 2013-02-06 23:04:46.244626691 -0800
+--- src.orig/scotch/Makefile 2013-02-07 17:27:00.000000000 +0000
++++ src/scotch/Makefile 2013-02-07 17:27:21.000000000 +0000
@@ -41,13 +41,13 @@
include ../Makefile.inc