summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-12-17 12:28:20 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-12-17 12:28:20 +0000
commit7cd65994dcfdfb7acd962270df12a22f4ffc4e80 (patch)
tree1244e148252a81d1df64330df1e7081a8f1fe557 /sci-libs/scipy
parentstable x86, bug 202168 (diff)
downloadgentoo-2-7cd65994dcfdfb7acd962270df12a22f4ffc4e80.tar.gz
gentoo-2-7cd65994dcfdfb7acd962270df12a22f4ffc4e80.tar.bz2
gentoo-2-7cd65994dcfdfb7acd962270df12a22f4ffc4e80.zip
Revert clapack patch (see bug #197527) and take care of LDFLAGS as numpy
(Portage version: 2.1.4_rc9)
Diffstat (limited to 'sci-libs/scipy')
-rw-r--r--sci-libs/scipy/ChangeLog8
-rw-r--r--sci-libs/scipy/files/digest-scipy-0.6.0-r33
-rw-r--r--sci-libs/scipy/scipy-0.6.0-r3.ebuild126
3 files changed, 136 insertions, 1 deletions
diff --git a/sci-libs/scipy/ChangeLog b/sci-libs/scipy/ChangeLog
index a0da35d21479..7934a05fe2ab 100644
--- a/sci-libs/scipy/ChangeLog
+++ b/sci-libs/scipy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/scipy
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.25 2007/10/18 14:17:10 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.26 2007/12/17 12:28:19 bicatali Exp $
+
+*scipy-0.6.0-r3 (17 Dec 2007)
+
+ 17 Dec 2007; Sébastien Fabbro <bicatali@gentoo.org>
+ +scipy-0.6.0-r3.ebuild:
+ Revert clapack patch (see bug #197527) and take care of LDFLAGS as numpy
*scipy-0.6.0-r2 (18 Oct 2007)
diff --git a/sci-libs/scipy/files/digest-scipy-0.6.0-r3 b/sci-libs/scipy/files/digest-scipy-0.6.0-r3
new file mode 100644
index 000000000000..aa28d16fa675
--- /dev/null
+++ b/sci-libs/scipy/files/digest-scipy-0.6.0-r3
@@ -0,0 +1,3 @@
+MD5 417adf3bfe03f4c23c9fb265018e545c scipy-0.6.0.tar.gz 6572954
+RMD160 391f2067f7dcc133e7e8622df93a2a0cd5ebbe5b scipy-0.6.0.tar.gz 6572954
+SHA256 5f70390963fb4e3ae8cf5effa301c160ef68c791098e2ea95b99380e298eac4f scipy-0.6.0.tar.gz 6572954
diff --git a/sci-libs/scipy/scipy-0.6.0-r3.ebuild b/sci-libs/scipy/scipy-0.6.0-r3.ebuild
new file mode 100644
index 000000000000..5d8c88fae284
--- /dev/null
+++ b/sci-libs/scipy/scipy-0.6.0-r3.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.6.0-r3.ebuild,v 1.1 2007/12/17 12:28:19 bicatali Exp $
+
+NEED_PYTHON=2.3
+
+inherit eutils distutils fortran flag-o-matic
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+DESCRIPTION="Scientific algorithms library for Python"
+HOMEPAGE="http://www.scipy.org/"
+LICENSE="BSD"
+
+SLOT="0"
+
+IUSE="fftw umfpack sandbox"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND=">=dev-python/numpy-1.0.3.1
+ virtual/lapack
+ fftw? ( =sci-libs/fftw-2.1* )
+ umfpack? ( sci-libs/umfpack dev-lang/swig )
+ sandbox? ( >=sci-libs/netcdf-3.6 x11-libs/libX11 )"
+
+RDEPEND=">=dev-python/numpy-1.0.3.1
+ dev-python/imaging
+ virtual/lapack
+ fftw? ( =sci-libs/fftw-2.1* )
+ umfpack? ( sci-libs/umfpack )
+ sandbox? ( >=sci-libs/netcdf-3.6 x11-libs/libX11 )"
+
+# test still buggy on lapack with 2 failures on check_syevr
+# (lapack float). check every version bump.
+RESTRICT="test"
+
+DOCS="THANKS.txt DEVELOPERS.txt LATEST.txt TOCHANGE.txt FORMAT_GUIDELINES.txt"
+
+scipy_fortran_setup() {
+ FORTRAN="gfortran g77 ifc"
+ fortran_pkg_setup
+ local fc=
+ case ${FORTRANC} in
+ gfortran) fc=gnu95 ;;
+ g77) fc=gnu ;;
+ ifc|ifort)
+ if use ia64; then
+ fc=intele
+ elif use amd64; then
+ fc=intelem
+ else
+ fc=intel
+ fi
+ ;;
+ *) eerror "Unknown fortran compiler: ${FORTRANC}"
+ die "scipy_fortran_setup failed" ;;
+ esac
+
+ # when fortran flags are set, pic is removed.
+ use amd64 && [[ -n ${FFLAGS} ]] && FFLAGS="${FFLAGS} -fPIC"
+ export SCIPY_FCONFIG="config_fc --fcompiler=${fc}"
+}
+
+# whatever LDFLAGS set will break linking
+# see progress in http://projects.scipy.org/scipy/numpy/ticket/573
+[ -n "${LDFLAGS}" ] && append-ldflags -shared
+
+pkg_setup() {
+ if use umfpack && ! built_with_use dev-lang/swig python; then
+ eerror "With umfpack enabled you need"
+ eerror "dev-lang/swig with python enabled"
+ einfo "Please re-emerge swig with USE=python"
+ die "needs swig with python"
+ fi
+ # scipy automatically detects libraries by default
+ export FFTW=None FFTW3=None UMFPACK=None DJBFFT=None
+ use fftw && unset FFTW
+ use umfpack && unset UMFPACK
+ use sandbox && elog "Warning: using sandbox modules at your own risk!"
+ scipy_fortran_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-randomkit.patch
+ epatch "${FILESDIR}"/${P}-cdf.patch
+ epatch "${FILESDIR}"/${P}-fftw-fix.patch
+
+ if use sandbox; then
+ cd scipy/sandbox
+ ls -1 */__init__.py \
+ | sed -e 's:/__init__.py::' \
+ | grep -v exmplpackage \
+ > enabled_packages.txt \
+ || die "sandbox listing failed"
+ fi
+}
+
+src_compile() {
+ distutils_src_compile ${SCIPY_FCONFIG}
+}
+
+src_test() {
+ "${python}" setup.py install \
+ --home="${S}"/test \
+ --no-compile \
+ ${SCIPY_FCONFIG} || die "install test failed"
+ pushd "${S}"/test/lib*/python
+ PYTHONPATH=. "${python}" -c \
+ "import scipy as s;import sys;sys.exit(s.test(10,3))" \
+ 2>&1 | tee test.log
+ grep -q OK test.log || die "test failed"
+ popd
+ rm -rf test
+}
+
+src_install() {
+ distutils_src_install ${SCIPY_FCONFIG}
+}
+
+pkg_postinst() {
+ elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
+ elog "to your prefered image viewer if you don't like the default one. Ex:"
+ elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
+}