summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-08-27 18:33:17 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-08-27 18:33:17 +0000
commit794f628c4b4c9c5b0d3dc5f10f507a0c63df6ea8 (patch)
tree5291cb9f0a47c179d04c9a35a7fe98983ff470aa /sci-libs/scipy
parentRemove trailing spaces from pkg-config calls (bug #444104), fix shared lib ex... (diff)
downloadgentoo-2-794f628c4b4c9c5b0d3dc5f10f507a0c63df6ea8.tar.gz
gentoo-2-794f628c4b4c9c5b0d3dc5f10f507a0c63df6ea8.tar.bz2
gentoo-2-794f628c4b4c9c5b0d3dc5f10f507a0c63df6ea8.zip
Remove trailing spaces from pkg-config calls (bug #444104)
(Portage version: 2.2.01.22288-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs/scipy')
-rw-r--r--sci-libs/scipy/ChangeLog5
-rw-r--r--sci-libs/scipy/scipy-0.12.0.ebuild8
2 files changed, 8 insertions, 5 deletions
diff --git a/sci-libs/scipy/ChangeLog b/sci-libs/scipy/ChangeLog
index 5213bb3e4932..09fca3b3e2dd 100644
--- a/sci-libs/scipy/ChangeLog
+++ b/sci-libs/scipy/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/scipy
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.94 2013/06/17 23:29:09 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.95 2013/08/27 18:33:17 bicatali Exp $
+
+ 27 Aug 2013; Sébastien Fabbro <bicatali@gentoo.org> scipy-0.12.0.ebuild:
+ Remove trailing spaces from pkg-config calls (bug #444104)
17 Jun 2013; Sébastien Fabbro <bicatali@gentoo.org>
-files/scipy-0.11.0-test_basic.patch, -scipy-0.11.0-r1.ebuild, metadata.xml,
diff --git a/sci-libs/scipy/scipy-0.12.0.ebuild b/sci-libs/scipy/scipy-0.12.0.ebuild
index 64ab238edd36..3c77391fdc07 100644
--- a/sci-libs/scipy/scipy-0.12.0.ebuild
+++ b/sci-libs/scipy/scipy-0.12.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.12.0.ebuild,v 1.3 2013/06/09 17:58:01 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.12.0.ebuild,v 1.4 2013/08/27 18:33:17 bicatali Exp $
EAPI=5
@@ -50,18 +50,18 @@ src_unpack() {
pc_incdir() {
$(tc-getPKG_CONFIG) --cflags-only-I $@ | \
- sed -e 's/^-I//' -e 's/[ ]*-I/:/g'
+ sed -e 's/^-I//' -e 's/[ ]*-I/:/g' -e 's/[ ]*$//'
}
pc_libdir() {
$(tc-getPKG_CONFIG) --libs-only-L $@ | \
- sed -e 's/^-L//' -e 's/[ ]*-L/:/g'
+ sed -e 's/^-L//' -e 's/[ ]*-L/:/g' -e 's/[ ]*$//'
}
pc_libs() {
$(tc-getPKG_CONFIG) --libs-only-l $@ | \
sed -e 's/[ ]-l*\(pthread\|m\)[ ]*//g' \
- -e 's/^-l//' -e 's/[ ]*-l/,/g'
+ -e 's/^-l//' -e 's/[ ]*-l/,/g' -e 's/[ ]*$//'
}
python_prepare_all() {