summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-12-02 11:03:55 +0000
committerJustin Lecher <jlec@gentoo.org>2013-12-02 11:03:55 +0000
commitfedb4acfafc324660600d2cf1d57805965de280c (patch)
tree2380355082cec3dfc7acd71318e0df582327a130 /sci-libs/pymmlib
parentnew dep of openstack client package python-keystoneclient, ebuild prepared by me (diff)
downloadgentoo-2-fedb4acfafc324660600d2cf1d57805965de280c.tar.gz
gentoo-2-fedb4acfafc324660600d2cf1d57805965de280c.tar.bz2
gentoo-2-fedb4acfafc324660600d2cf1d57805965de280c.zip
sci-libs/pymmlib: Bump to distutils-r1.eclass
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-libs/pymmlib')
-rw-r--r--sci-libs/pymmlib/ChangeLog10
-rw-r--r--sci-libs/pymmlib/metadata.xml2
-rw-r--r--sci-libs/pymmlib/pymmlib-1.2.0-r1.ebuild47
3 files changed, 56 insertions, 3 deletions
diff --git a/sci-libs/pymmlib/ChangeLog b/sci-libs/pymmlib/ChangeLog
index af4b2b4190f5..196922aa2fd8 100644
--- a/sci-libs/pymmlib/ChangeLog
+++ b/sci-libs/pymmlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/pymmlib
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/pymmlib/ChangeLog,v 1.25 2012/05/14 13:29:29 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/pymmlib/ChangeLog,v 1.26 2013/12/02 11:03:55 jlec Exp $
+
+*pymmlib-1.2.0-r1 (02 Dec 2013)
+
+ 02 Dec 2013; Justin Lecher <jlec@gentoo.org> +pymmlib-1.2.0-r1.ebuild,
+ metadata.xml:
+ Bump to distutils-r1.eclass
14 May 2012; Justin Lecher <jlec@gentoo.org> pymmlib-1.2.0.ebuild:
Keyworded for ~-linux, tested by me
diff --git a/sci-libs/pymmlib/metadata.xml b/sci-libs/pymmlib/metadata.xml
index e42d0af60f42..51fdedab1b38 100644
--- a/sci-libs/pymmlib/metadata.xml
+++ b/sci-libs/pymmlib/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-chemistry</herd>
+ <herd>sci-chemistry</herd>
</pkgmetadata>
diff --git a/sci-libs/pymmlib/pymmlib-1.2.0-r1.ebuild b/sci-libs/pymmlib/pymmlib-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..5887703e7678
--- /dev/null
+++ b/sci-libs/pymmlib/pymmlib-1.2.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/pymmlib/pymmlib-1.2.0-r1.ebuild,v 1.1 2013/12/02 11:03:55 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1 multilib
+
+DESCRIPTION="Toolkit and library for the analysis and manipulation of macromolecular structural models"
+HOMEPAGE="http://pymmlib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pymmlib/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pygtkglext[${PYTHON_USEDEP}]
+ media-libs/freeglut
+ virtual/glu
+ virtual/opengl
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/epydoc[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ rm mmLib/NumericCompat.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ ${EPYTHON} setup.py doc || die
+ fi
+}
+
+python_install_all() {
+ DOCS=( "${S}"/README.txt )
+ use doc && HTML_DOCS=( "${S}"/doc/. )
+ distutils-r1_python_install_all
+
+ python_foreach_impl python_doscript "${S}"/applications/* "${S}"/examples/*.py
+}