summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-04-25 10:47:08 +0000
committerJustin Lecher <jlec@gentoo.org>2010-04-25 10:47:08 +0000
commit671b6a1816713509e531cea8ba0ae0f45897380a (patch)
tree6190a14609cd6ca3bc87f4be2f739f4fa6e527f5 /sci-libs/pymmlib
parentVersion Bump, Python ABI fixes, #316225 (diff)
downloadgentoo-2-671b6a1816713509e531cea8ba0ae0f45897380a.tar.gz
gentoo-2-671b6a1816713509e531cea8ba0ae0f45897380a.tar.bz2
gentoo-2-671b6a1816713509e531cea8ba0ae0f45897380a.zip
Python ABI fixes, #316227
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/pymmlib')
-rw-r--r--sci-libs/pymmlib/ChangeLog9
-rw-r--r--sci-libs/pymmlib/pymmlib-1.0.0-r1.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/sci-libs/pymmlib/ChangeLog b/sci-libs/pymmlib/ChangeLog
index 873bb23a049d..905e73b4796a 100644
--- a/sci-libs/pymmlib/ChangeLog
+++ b/sci-libs/pymmlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/pymmlib
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/pymmlib/ChangeLog,v 1.15 2008/05/29 17:54:58 hawking Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/pymmlib/ChangeLog,v 1.16 2010/04/25 10:47:08 jlec Exp $
+
+*pymmlib-1.0.0-r1 (25 Apr 2010)
+
+ 25 Apr 2010; Justin Lecher <jlec@gentoo.org> +pymmlib-1.0.0-r1.ebuild:
+ Python ABI fixes, #316227
29 May 2008; Ali Polatel <hawking@gentoo.org> pymmlib-0.9.7.ebuild,
pymmlib-0.9.8.ebuild, pymmlib-1.0.0.ebuild:
diff --git a/sci-libs/pymmlib/pymmlib-1.0.0-r1.ebuild b/sci-libs/pymmlib/pymmlib-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..475ac6d23991
--- /dev/null
+++ b/sci-libs/pymmlib/pymmlib-1.0.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/pymmlib/pymmlib-1.0.0-r1.ebuild,v 1.1 2010/04/25 10:47:08 jlec Exp $
+
+EAPI="3"
+
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils multilib
+
+DESCRIPTION="Software toolkit and library of routines for the analysis and manipulation of macromolecular structural models"
+HOMEPAGE="http://pymmlib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pymmlib/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/numpy-0.9.8
+ dev-python/pygtkglext
+ virtual/glu
+ virtual/glut
+ virtual/opengl
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_prepare() {
+ python_convert_shebangs $(python_get_version -f) "${S}"/applications/* "${S}"/examples/*
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+ dobin "${S}"/applications/* "${S}"/examples/* || die
+ dodoc "${S}"/README.txt || die
+ dohtml -r "${S}"/doc || die
+}