summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-06-18 20:05:32 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-06-18 20:05:32 +0000
commiteeb236cfa3c326a4035db12547565559ed6ecdc4 (patch)
tree17a0d772fb60a2cf7103387e6c3f56b962938d3e /sci-libs/plplot
parentVersion bump. (diff)
downloadgentoo-2-eeb236cfa3c326a4035db12547565559ed6ecdc4.tar.gz
gentoo-2-eeb236cfa3c326a4035db12547565559ed6ecdc4.tar.bz2
gentoo-2-eeb236cfa3c326a4035db12547565559ed6ecdc4.zip
Adjust java installation directories. Remove D support, since we have no in the tree. Add dependency on cairo-ocaml for OCaml bindings if cairo is on. Fixed cmake error, bug #419743, thanks Juergen Rose for the patch.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/plplot')
-rw-r--r--sci-libs/plplot/ChangeLog11
-rw-r--r--sci-libs/plplot/files/plplot-5.9.9-CMakeLists.txt.patch14
-rw-r--r--sci-libs/plplot/plplot-5.9.9-r1.ebuild (renamed from sci-libs/plplot/plplot-5.9.7-r1.ebuild)117
3 files changed, 93 insertions, 49 deletions
diff --git a/sci-libs/plplot/ChangeLog b/sci-libs/plplot/ChangeLog
index c81761705bf1..e4def16488d1 100644
--- a/sci-libs/plplot/ChangeLog
+++ b/sci-libs/plplot/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sci-libs/plplot
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/plplot/ChangeLog,v 1.38 2012/05/04 08:22:51 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/plplot/ChangeLog,v 1.39 2012/06/18 20:05:31 bicatali Exp $
+
+*plplot-5.9.9-r1 (18 Jun 2012)
+
+ 18 Jun 2012; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/plplot-5.9.9-CMakeLists.txt.patch, +plplot-5.9.9-r1.ebuild,
+ -plplot-5.9.7-r1.ebuild:
+ Adjust java installation directories. Remove D support, since we have no in
+ the tree. Add dependency on cairo-ocaml for OCaml bindings if cairo is on.
+ Fixed cmake error, bug #419743, thanks Juergen Rose for the patch.
04 May 2012; Jeff Horelick <jdhore@gentoo.org> plplot-5.9.7-r1.ebuild,
plplot-5.9.9.ebuild:
diff --git a/sci-libs/plplot/files/plplot-5.9.9-CMakeLists.txt.patch b/sci-libs/plplot/files/plplot-5.9.9-CMakeLists.txt.patch
new file mode 100644
index 000000000000..6bec2e54cc77
--- /dev/null
+++ b/sci-libs/plplot/files/plplot-5.9.9-CMakeLists.txt.patch
@@ -0,0 +1,14 @@
+--- trunk/scripts/CMakeLists.txt 2011/10/31 15:33:42 12018
++++ trunk/scripts/CMakeLists.txt 2012/01/04 15:45:07 12116
+@@ -30,9 +30,9 @@
+ if(PLD_pstex)
+ set(scripts_SCRIPTS ${scripts_SCRIPTS} pstex2eps)
+ endif(PLD_pstex)
+- if (NOT ${scripts_SCRIPTS} STREQUAL "")
++ if (NOT "${scripts_SCRIPTS}" STREQUAL "")
+ install(PROGRAMS ${scripts_SCRIPTS} DESTINATION ${BIN_DIR})
+- endif (NOT ${scripts_SCRIPTS} STREQUAL "")
++ endif (NOT "${scripts_SCRIPTS}" STREQUAL "")
+ endif(HAVE_BASH)
+
+ if(ENABLE_tcl OR ENABLE_tk)
diff --git a/sci-libs/plplot/plplot-5.9.7-r1.ebuild b/sci-libs/plplot/plplot-5.9.9-r1.ebuild
index 01fbcbec4de1..3d2900f7c44b 100644
--- a/sci-libs/plplot/plplot-5.9.7-r1.ebuild
+++ b/sci-libs/plplot/plplot-5.9.9-r1.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/plplot/plplot-5.9.7-r1.ebuild,v 1.8 2012/05/04 08:22:51 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/plplot/plplot-5.9.9-r1.ebuild,v 1.1 2012/06/18 20:05:31 bicatali Exp $
-EAPI="3"
+EAPI=4
WX_GTK_VER="2.8"
PYTHON_DEPEND="python? 2"
-inherit eutils fortran-2 cmake-utils python toolchain-funcs virtualx wxwidgets java-pkg-opt-2
+inherit eutils fortran-2 cmake-utils python toolchain-funcs virtualx \
+ wxwidgets java-pkg-opt-2
DESCRIPTION="Multi-language scientific plotting library"
HOMEPAGE="http://plplot.sourceforge.net/"
@@ -16,12 +17,11 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="ada cairo d doc dynamic examples fortran gd java jpeg latex lua ocaml octave
- pdf perl png python qhull qt4 svg tcl test threads tk truetype wxwidgets X"
-
-RDEPEND="
- fortran? ( virtual/fortran )
+IUSE="ada cairo cxx doc dynamic examples fortran gd java jpeg latex lua
+ ocaml octave pdf perl png python qhull qt4 svg tcl test threads tk
+ truetype wxwidgets X"
+RDEPEND="fortran? ( virtual/fortran )
ada? ( virtual/gnat )
cairo? ( x11-libs/cairo[svg?,X?] )
java? ( >=virtual/jre-1.5 )
@@ -31,7 +31,7 @@ RDEPEND="
ocaml? (
dev-lang/ocaml
dev-ml/camlidl
- dev-ml/lablgtk )
+ cairo? ( dev-ml/cairo-ocaml[gtk] ) )
octave? ( sci-mathematics/octave )
pdf? ( media-libs/libharu )
perl? ( dev-perl/PDL dev-perl/XML-DOM )
@@ -50,6 +50,7 @@ RDEPEND="
gd? ( media-libs/gd[truetype] ) )
wxwidgets? ( x11-libs/wxGTK:2.8[X] x11-libs/agg[truetype?] )
X? ( x11-libs/libX11 x11-libs/libXau x11-libs/libXdmcp )"
+
DEPEND="${RDEPEND}
virtual/pkgconfig
java? ( >=virtual/jdk-1.5 dev-lang/swig )
@@ -61,38 +62,37 @@ DEPEND="${RDEPEND}
pkg_setup() {
if use fortran; then
fortran-2_pkg_setup
- export FC=$(tc-getFC) F77=$(tc-getF77)
else
export FC="" F77=""
fi
use wxwidgets && wxwidgets_pkg_setup
use python && python_set_active_version 2
- use java && java-pkg-opt-2_pkg_setup
+ java-pkg-opt-2_pkg_setup
}
src_prepare() {
# path for python independent of python version
epatch "${FILESDIR}"/${PN}-5.9.6-python.patch
+ # test with pdf assumes a modified bundled libharu
+ epatch "${FILESDIR}"/${PN}-5.9.9-no-pdftest.patch
+ # gentoo bug #419743 fixed upstream
+ epatch "${FILESDIR}"/${PN}-5.9.9-CMakeLists.txt.patch
- # remove license
+ # avoid installing license
sed -i -e '/COPYING.LIB/d' CMakeLists.txt || die
# change default install directories for doc and examples
sed -i \
-e 's:${DATA_DIR}/examples:${DOC_DIR}/examples:g' \
- examples/CMakeLists.txt examples/*/CMakeLists.txt || die
+ $(find "${S}" -name CMakeLists.txt) || die
sed -i \
-e 's:${VERSION}::g' \
-e "s:doc/\${PACKAGE}:doc/${PF}:" \
cmake/modules/instdirs.cmake || die
-
- use java && java-utils-2_src_prepare
+ java-utils-2_src_prepare
}
src_configure() {
- # see http://www.miscdebris.net/plplot_wiki/index.php?title=CMake_options_for_PLplot
- cmake-utils_pld() { _use_me_now PLD "$1 _$2" ; }
-
mycmakeargs=(
-DUSE_RPATH=OFF
-DUSE_RELATIVE_PATH=OFF
@@ -101,11 +101,9 @@ src_configure() {
-DCMAKE_INSTALL_LIBDIR="${EPREFIX}/usr/$(get_libdir)"
$(cmake-utils_use_build test)
$(cmake-utils_use_has python numpy)
- $(cmake-utils_use_has qhull QHULL)
- $(cmake-utils_use_has threads PTHREAD)
$(cmake-utils_use_with truetype FREETYPE)
$(cmake-utils_use_enable ada)
- $(cmake-utils_use_enable d)
+ $(cmake-utils_use_enable cxx)
$(cmake-utils_use_enable dynamic DYNDRIVERS)
$(cmake-utils_use_enable fortran f77)
$(cmake-utils_use_enable java)
@@ -119,37 +117,55 @@ src_configure() {
$(cmake-utils_use_enable tcl itcl)
$(cmake-utils_use_enable tk)
$(cmake-utils_use_enable tk itk)
- $(cmake-utils_pld cairo memcairo)
- $(cmake-utils_pld cairo extcairo)
- $(cmake-utils_pld cairo pdfcairo)
- $(cmake-utils_pld cairo pngcairo)
- $(cmake-utils_pld cairo pscairo)
- $(cmake-utils_pld cairo svgcairo)
- $(cmake-utils_pld cairo xcairo)
- $(cmake-utils_pld qt4 bmpqt)
- $(cmake-utils_pld qt4 epsqt)
- $(cmake-utils_pld qt4 extqt)
- $(cmake-utils_pld qt4 jpgqt)
- $(cmake-utils_pld qt4 memqt)
- $(cmake-utils_pld qt4 pdfqt)
- $(cmake-utils_pld qt4 pngqt)
- $(cmake-utils_pld qt4 ppmqt)
- $(cmake-utils_pld qt4 qtwidget)
- $(cmake-utils_pld qt4 svgqt)
- $(cmake-utils_pld qt4 tiffqt)
- $(cmake-utils_pld wxwidgets wxwidgets)
- $(cmake-utils_pld wxwidgets wxpng)
- $(cmake-utils_pld pdf)
- $(cmake-utils_pld truetype psttf)
- $(cmake-utils_pld latex pstex)
+ $(cmake-utils_use_enable wxwidgets)
+ $(cmake-utils_use threads PL_HAVE_PTHREAD)
+ $(cmake-utils_use qhull PL_HAVE_QHULL)
+ $(cmake-utils_use qt4 PLD_aqt)
+ $(cmake-utils_use qt4 PLD_bmpqt)
+ $(cmake-utils_use qt4 PLD_epsqt)
+ $(cmake-utils_use qt4 PLD_extqt)
+ $(cmake-utils_use qt4 PLD_jpgqt)
+ $(cmake-utils_use qt4 PLD_memqt)
+ $(cmake-utils_use qt4 PLD_pdfqt)
+ $(cmake-utils_use qt4 PLD_pngqt)
+ $(cmake-utils_use qt4 PLD_ppmqt)
+ $(cmake-utils_use qt4 PLD_svgqt)
+ $(cmake-utils_use qt4 PLD_qtwidget)
+ $(cmake-utils_use qt4 PLD_tiffqt)
+ $(cmake-utils_use cairo PLD_extcairo)
+ $(cmake-utils_use cairo PLD_memcairo)
+ $(cmake-utils_use cairo PLD_pdfcairo)
+ $(cmake-utils_use cairo PLD_pngcairo)
+ $(cmake-utils_use cairo PLD_pscairo)
+ $(cmake-utils_use cairo PLD_svgcairo)
+ $(cmake-utils_use cairo PLD_wincairo)
+ $(cmake-utils_use cairo PLD_xcairo)
+ $(cmake-utils_use tk PLD_ntk)
+ $(cmake-utils_use tk PLD_tk)
+ $(cmake-utils_use tk PLD_tkwin)
+ $(cmake-utils_use gd PLD_gif)
+ $(cmake-utils_use gd PLD_jpeg)
+ $(cmake-utils_use gd PLD_png)
+ $(cmake-utils_use pdf PLD_pdf)
+ $(cmake-utils_use latex PLD_ps)
+ $(cmake-utils_use latex PLD_pstex)
+ $(cmake-utils_use truetype PLD_psttf)
+ $(cmake-utils_use svg PLD_svg)
+ $(cmake-utils_use wxwidgets PLD_wxpng)
+ $(cmake-utils_use wxwidgets PLD_wxwidgets)
+ $(cmake-utils_use X PLD_xwin)
+ )
+
+ [[ $(tc-getFC) != *g77 ]] && \
+ mycmakeargs+=(
+ $(cmake-utils_use_enable fortran f95)
)
- use fortran && [[ $(tc-getFC) != *g77 ]] && \
- mycmakeargs+=( $(cmake-utils_use_enable fortran f95) )
use truetype && mycmakeargs+=(
- -DPL_FREETYPE_FONT_PATH:PATH="${EPREFIX}/usr/share/fonts/freefont-ttf" )
+ -DPL_FREETYPE_FONT_PATH:PATH="${EPREFIX}/usr/share/fonts/freefont-ttf"
+ )
- use python && use qt4 && mycmakeargs+=( $(cmake-utils_pld pyqt) )
+ use python && mycmakeargs+=( $(cmake-utils_use_enable qt4 pyqt4) )
use doc && mycmakeargs+=( -DPREBUILT_DOC=ON )
cmake-utils_src_configure
}
@@ -163,4 +179,9 @@ src_test() {
src_install() {
cmake-utils_src_install
use examples || rm -rf "${ED}"/usr/share/doc/${PF}/examples
+ if use java; then
+ rm -rf "${ED}"/usr/share/java "${ED}"/usr/$(get_libdir)/jni
+ java-pkg_dojar "${CMAKE_BUILD_DIR}"/examples/java/${PN}.jar
+ java-pkg_doso "${CMAKE_BUILD_DIR}"/bindings/java/plplotjavac_wrap.so
+ fi
}