summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-01-15 13:15:07 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-01-15 13:15:07 +0000
commit4c7466c4a73ee3ed9f08b8e4e62e22afc6084031 (patch)
treee0e21ea149e0b1db5f3433e333b085bf1ccfd798 /sci-libs/netcdf
parentremove alg_ia32 as per bug #253716 thanks Helmut Jarausch, Nickolay Kolchin-S... (diff)
downloadgentoo-2-4c7466c4a73ee3ed9f08b8e4e62e22afc6084031.tar.gz
gentoo-2-4c7466c4a73ee3ed9f08b8e4e62e22afc6084031.tar.bz2
gentoo-2-4c7466c4a73ee3ed9f08b8e4e62e22afc6084031.zip
Fixed some examples for gcc-4.3, thanks to anomen
(Portage version: 2.2_rc22/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'sci-libs/netcdf')
-rw-r--r--sci-libs/netcdf/ChangeLog9
-rw-r--r--sci-libs/netcdf/files/netcdf-3.6.2-gcc43.patch20
-rw-r--r--sci-libs/netcdf/netcdf-3.6.1-r1.ebuild73
-rw-r--r--sci-libs/netcdf/netcdf-3.6.1.ebuild73
4 files changed, 27 insertions, 148 deletions
diff --git a/sci-libs/netcdf/ChangeLog b/sci-libs/netcdf/ChangeLog
index e0d199f91e32..860bbe188b32 100644
--- a/sci-libs/netcdf/ChangeLog
+++ b/sci-libs/netcdf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/netcdf
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.50 2008/02/13 12:28:37 armin76 Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.51 2009/01/15 13:15:06 bicatali Exp $
+
+ 15 Jan 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ files/netcdf-3.6.2-gcc43.patch, -netcdf-3.6.1.ebuild,
+ -netcdf-3.6.1-r1.ebuild:
+ Fixed some examples for gcc-4.3, thanks to anomen
13 Feb 2008; Raúl Porcel <armin76@gentoo.org> netcdf-3.6.2.ebuild:
alpha stable wrt #201477
diff --git a/sci-libs/netcdf/files/netcdf-3.6.2-gcc43.patch b/sci-libs/netcdf/files/netcdf-3.6.2-gcc43.patch
index 2c4c0f749746..60fd5b895292 100644
--- a/sci-libs/netcdf/files/netcdf-3.6.2-gcc43.patch
+++ b/sci-libs/netcdf/files/netcdf-3.6.2-gcc43.patch
@@ -9,3 +9,23 @@
#include "ncvalues.h"
+--- examples/CXX/sfc_pres_temp_rd.cpp.orig 2009-01-15 13:10:38.866169747 +0000
++++ examples/CXX/sfc_pres_temp_rd.cpp 2009-01-15 13:11:21.301635873 +0000
+@@ -17,6 +17,7 @@
+ */
+
+ #include <iostream>
++#include <cstring>
+ #include <netcdfcpp.h>
+
+ using namespace std;
+--- examples/CXX/sfc_pres_temp_wr.cpp.orig 2009-01-15 13:10:28.031052831 +0000
++++ examples/CXX/sfc_pres_temp_wr.cpp 2009-01-15 13:11:07.535199220 +0000
+@@ -17,6 +17,7 @@
+ */
+
+ #include <iostream>
++#include <cstring>
+ #include <netcdfcpp.h>
+
+ using namespace std;
diff --git a/sci-libs/netcdf/netcdf-3.6.1-r1.ebuild b/sci-libs/netcdf/netcdf-3.6.1-r1.ebuild
deleted file mode 100644
index 25c8a956b46e..000000000000
--- a/sci-libs/netcdf/netcdf-3.6.1-r1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-3.6.1-r1.ebuild,v 1.3 2007/10/15 14:48:39 corsair Exp $
-
-inherit fortran eutils toolchain-funcs
-
-DESCRIPTION="Scientific library and interface for array oriented data access"
-SRC_URI="ftp://ftp.unidata.ucar.edu/pub/netcdf/${P}.tar.gz"
-HOMEPAGE="http://my.unidata.ucar.edu/content/software/netcdf/index.html"
-
-LICENSE="UCAR-Unidata"
-SLOT="0"
-IUSE="fortran"
-KEYWORDS="~alpha ~amd64 hppa ~ia64 ~mips ~ppc ppc64 ~sparc ~x86"
-
-S="${WORKDIR}/${P}/src"
-
-pkg_setup() {
- if use fortran ; then
- need_fortran "gfortran ifc g77"
-# fortran_pkg_setup
- else
- FORTRAN=""
- fi
-}
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch "${FILESDIR}"/fPIC.1.patch || die "fPIC patch failed"
-}
-
-src_compile() {
- local myconf
-
- if use fortran ; then
- if [ ${FORTRANC} == gfortran ] ; then
- myconf="${myconf} CPPFLAGS=-DpgiFortran"
- else
- myconf="${myconf} CPPFLAGS=-Df2cFortran"
- fi
- fi
-
- econf ${myconf} || die "econf failed"
-
- make || die "make failed"
-}
-
-src_test() {
- make test || die "make test failed"
-}
-
-src_install() {
- dodir /usr/{lib,share} /usr/share/man/man3
-
- einstall MANDIR=${D}usr/share/man || die "einstall failed"
-
- if test -f ${D}usr/share/man/man3/netcdf.3f ; then
- dodir /usr/share/man/man3f
- mv ${D}usr/share/man/man3/netcdf.3f ${D}usr/share/man/man3f/ \
- || die "Failed to move f77 man page"
- dosed "s:NETCDF 3:NETCDF 3F:g" /usr/share/man/man3f/netcdf.3f \
- || die "dosed failed"
- if test -f ${D}usr/share/man/man3/netcdf.3f90 ; then
- dodir /usr/share/man/man3f90
- mv ${D}usr/share/man/man3/netcdf.3f90 ${D}usr/share/man/man3f90/ \
- || die "Failed to move f90 man page"
- fi
- dodoc fortran/cfortran.doc || die "Failed to install fortran docs"
- fi
-
- dodoc COPYRIGHT README RELEASE_NOTES VERSION \
- || die "Failed to install docs"
-}
diff --git a/sci-libs/netcdf/netcdf-3.6.1.ebuild b/sci-libs/netcdf/netcdf-3.6.1.ebuild
deleted file mode 100644
index ffa02c576a74..000000000000
--- a/sci-libs/netcdf/netcdf-3.6.1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-3.6.1.ebuild,v 1.14 2006/09/08 17:57:43 tcort Exp $
-
-inherit fortran eutils toolchain-funcs
-
-DESCRIPTION="Scientific library and interface for array oriented data access"
-SRC_URI="ftp://ftp.unidata.ucar.edu/pub/netcdf/${P}.tar.gz"
-HOMEPAGE="http://my.unidata.ucar.edu/content/software/netcdf/index.html"
-
-LICENSE="UCAR-Unidata"
-SLOT="0"
-IUSE="fortran"
-KEYWORDS="alpha amd64 hppa ia64 mips ppc ppc64 sparc x86"
-
-S="${WORKDIR}/${P}/src"
-
-pkg_setup() {
- if use fortran ; then
- need_fortran "gfortran ifc g77"
-# fortran_pkg_setup
- else
- FORTRAN=""
- fi
-}
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch "${FILESDIR}"/fPIC.patch || die "fPIC patch failed"
-}
-
-src_compile() {
- local myconf
-
- if use fortran ; then
- if [ ${FORTRANC} == gfortran ] ; then
- myconf="${myconf} CPPFLAGS=-DpgiFortran"
- else
- myconf="${myconf} CPPFLAGS=-Df2cFortran"
- fi
- fi
-
- econf ${myconf} || die "econf failed"
-
- make || die "make failed"
-}
-
-src_test() {
- make test || die "make test failed"
-}
-
-src_install() {
- dodir /usr/{lib,share} /usr/share/man/man3
-
- einstall MANDIR=${D}usr/share/man || die "einstall failed"
-
- if test -f ${D}usr/share/man/man3/netcdf.3f ; then
- dodir /usr/share/man/man3f
- mv ${D}usr/share/man/man3/netcdf.3f ${D}usr/share/man/man3f/ \
- || die "Failed to move f77 man page"
- dosed "s:NETCDF 3:NETCDF 3F:g" /usr/share/man/man3f/netcdf.3f \
- || die "dosed failed"
- if test -f ${D}usr/share/man/man3/netcdf.3f90 ; then
- dodir /usr/share/man/man3f90
- mv ${D}usr/share/man/man3/netcdf.3f90 ${D}usr/share/man/man3f90/ \
- || die "Failed to move f90 man page"
- fi
- dodoc fortran/cfortran.doc || die "Failed to install fortran docs"
- fi
-
- dodoc COPYRIGHT README RELEASE_NOTES VERSION \
- || die "Failed to install docs"
-}