summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-12-06 17:20:10 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-12-06 17:20:10 +0000
commit19cccf2923af1815657a4841e7ff6b701a7b315f (patch)
tree6d99d7471691cdc1fcc180cd82d9b5baffe8000b /sci-libs/netcdf
parentalpha/ia64/sparc/x86 stable (diff)
downloadgentoo-2-19cccf2923af1815657a4841e7ff6b701a7b315f.tar.gz
gentoo-2-19cccf2923af1815657a4841e7ff6b701a7b315f.tar.bz2
gentoo-2-19cccf2923af1815657a4841e7ff6b701a7b315f.zip
Fixed for as-needed, cl closing bug #201493
(Portage version: 2.1.4_rc7)
Diffstat (limited to 'sci-libs/netcdf')
-rw-r--r--sci-libs/netcdf/ChangeLog6
-rw-r--r--sci-libs/netcdf/files/netcdf-3.6.2-as-needed.patch40
-rw-r--r--sci-libs/netcdf/netcdf-3.6.2.ebuild5
3 files changed, 48 insertions, 3 deletions
diff --git a/sci-libs/netcdf/ChangeLog b/sci-libs/netcdf/ChangeLog
index bf0729f7a394..bbc2ec09caba 100644
--- a/sci-libs/netcdf/ChangeLog
+++ b/sci-libs/netcdf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/netcdf
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.40 2007/10/15 14:48:39 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.41 2007/12/06 17:20:09 bicatali Exp $
+
+ 06 Dec 2007; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/netcdf-3.6.2-as-needed.patch, netcdf-3.6.2.ebuild:
+ Fixed for as-needed, cl closing bug #201493
15 Oct 2007; Markus Rothe <corsair@gentoo.org> netcdf-3.6.1-r1.ebuild:
Stable on ppc64
diff --git a/sci-libs/netcdf/files/netcdf-3.6.2-as-needed.patch b/sci-libs/netcdf/files/netcdf-3.6.2-as-needed.patch
new file mode 100644
index 000000000000..8f2bef7d9ff4
--- /dev/null
+++ b/sci-libs/netcdf/files/netcdf-3.6.2-as-needed.patch
@@ -0,0 +1,40 @@
+--- ./cxx/Makefile.am.orig 2007-12-06 17:12:03.352615935 +0000
++++ ./cxx/Makefile.am 2007-12-06 17:12:41.830808682 +0000
+@@ -88,6 +88,7 @@
+
+ # Library source.
+ libnetcdf_c___la_SOURCES = netcdf.cpp ncvalues.cpp
++libnetcdf_c___la_LIBADD = $(top_builddir)/libsrc/libnetcdf.la
+
+ test: check
+
+--- ./fortran/Makefile.am.orig 2007-12-06 17:11:59.140375893 +0000
++++ ./fortran/Makefile.am 2007-12-06 17:13:18.480897252 +0000
+@@ -35,6 +35,7 @@
+ # (it's generated by the configure script from nfconfig.in), or if
+ # netcdf.inc has changed.
+ libnetcdff_la_DEPENDENCIES = nfconfig.inc netcdf.inc
++libnetcdff_la_LIBADD = $(top_builddir)/libsrc/libnetcdf.la
+
+ # Is the user building netCDF-4?
+ if USE_NETCDF4
+@@ -71,7 +72,7 @@
+
+ # If F90 is built, include it's convenience library.
+ if BUILD_F90
+-libnetcdff_la_LIBADD = ../f90/libnetcdff90.la
++libnetcdff_la_LIBADD += ../f90/libnetcdff90.la
+ endif
+
+ # If we are building the dll (under MinGW) then set the correct flags.
+--- ./Makefile.am.orig 2007-12-06 17:11:55.140147933 +0000
++++ ./Makefile.am 2007-12-06 17:12:41.830808682 +0000
+@@ -57,7 +57,7 @@
+ # This is the list of subdirs for which Makefiles will be constructed
+ # and run. ncgen must come before ncdump and cxx, because their tests
+ # depend on it. nf_test depends upon ncgen as well.
+-SUBDIRS = $(F90_DIR) $(F77_DIR) libsrc $(V2_TEST) $(NCGEN) $(NCDUMP) \
++SUBDIRS = libsrc $(F90_DIR) $(F77_DIR) $(V2_TEST) $(NCGEN) $(NCDUMP) \
+ $(F77_TEST) ${CXX_DIR} nc_test $(MAN) $(EXAMPLES)
+
+ # make test should do the same as make check.
diff --git a/sci-libs/netcdf/netcdf-3.6.2.ebuild b/sci-libs/netcdf/netcdf-3.6.2.ebuild
index d35367185a6e..705bfdeba72d 100644
--- a/sci-libs/netcdf/netcdf-3.6.2.ebuild
+++ b/sci-libs/netcdf/netcdf-3.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-3.6.2.ebuild,v 1.5 2007/09/28 11:25:09 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-3.6.2.ebuild,v 1.6 2007/12/06 17:20:09 bicatali Exp $
inherit fortran eutils toolchain-funcs flag-o-matic autotools
@@ -15,7 +15,7 @@ KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
RDEPEND=""
DEPEND="${RDEPEND}
- doc? ( virtual/tetex )"
+ doc? ( virtual/latex-base )"
pkg_setup() {
if use fortran ; then
@@ -28,6 +28,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-parallel-make.patch
+ epatch "${FILESDIR}"/${P}-as-needed.patch
eautoreconf
}