summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-12-14 09:20:30 +0000
committerJustin Lecher <jlec@gentoo.org>2011-12-14 09:20:30 +0000
commitd2a1346adebb3dbded911109010c7479feac5bed (patch)
treeabc6ee704e4b2eda5c8405c33f433fc2c2a7ec3e /sci-libs/neartree/files
parentx86 stable wrt bug #393703 (diff)
downloadgentoo-2-d2a1346adebb3dbded911109010c7479feac5bed.tar.gz
gentoo-2-d2a1346adebb3dbded911109010c7479feac5bed.tar.bz2
gentoo-2-d2a1346adebb3dbded911109010c7479feac5bed.zip
Version Bump
(Portage version: 2.2.0_alpha80/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/neartree/files')
-rw-r--r--sci-libs/neartree/files/2.1.4-gcc4.3.patch20
-rw-r--r--sci-libs/neartree/files/2.1.4-iterator.patch27
-rw-r--r--sci-libs/neartree/files/3.1.1-gentoo.patch (renamed from sci-libs/neartree/files/2.1.4-gentoo.patch)77
-rw-r--r--sci-libs/neartree/files/3.1.1-notest.patch34
-rw-r--r--sci-libs/neartree/files/3.1.1-test.patch34
5 files changed, 108 insertions, 84 deletions
diff --git a/sci-libs/neartree/files/2.1.4-gcc4.3.patch b/sci-libs/neartree/files/2.1.4-gcc4.3.patch
deleted file mode 100644
index 527254ce57d3..000000000000
--- a/sci-libs/neartree/files/2.1.4-gcc4.3.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- CNearTreeTest.cpp 2009-06-08 04:54:29.000000000 +0200
-+++ CNearTreeTest.cpp.new 2009-07-25 12:36:33.000000000 +0200
-@@ -47,6 +47,7 @@
- #include <cmath>
- #include <stdio.h>
- #include <stdlib.h>
-+#include <cstring>
-
- #ifndef USE_LOCAL_HEADERS
- #include <TNear.h>
---- TNear.h 2009-06-08 04:54:29.000000000 +0200
-+++ TNear.h.new 2009-07-25 12:39:09.000000000 +0200
-@@ -272,6 +272,7 @@
- #define TRIANG(a,b,c) ( (((b)+(c))-(a) >= 0))
- #endif
-
-+#include <algorithm>
-
- //=======================================================================
- // CNearTree is the root class for the neartree. The actual data of the
diff --git a/sci-libs/neartree/files/2.1.4-iterator.patch b/sci-libs/neartree/files/2.1.4-iterator.patch
deleted file mode 100644
index 4563ecb8619d..000000000000
--- a/sci-libs/neartree/files/2.1.4-iterator.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/TNear.h b/TNear.h
-index d848b61..a5d255e 100644
---- a/TNear.h
-+++ b/TNear.h
-@@ -735,7 +735,7 @@ void BelongsToPoints( const T& t1, const T& t2, ContainerType& group1, Container
- {
- group1.clear();
- group2.clear();
-- CNearTree<T>::iterator it;
-+ typename CNearTree<T>::iterator it;
-
- for ( it=this->begin( ); it!=this->end( ); ++it )
- {
-@@ -756,11 +756,11 @@ void SeparateByRadius( const DistanceType radius, const T& tProbe, ContainerType
- {
- inside.clear();
- outside.clear();
-- CNearTree<T>::iterator it;
-+ typename CNearTree<T>::iterator it;
-
- for ( it=this->begin( ); it!=this->end( ); ++it )
- {
-- if( DistanceBetween( (*it), probe ) > radius )
-+ if( DistanceBetween( (*it), tProbe ) > radius )
- {
- inside.insert( inside.end( ), (*it) );
- }
diff --git a/sci-libs/neartree/files/2.1.4-gentoo.patch b/sci-libs/neartree/files/3.1.1-gentoo.patch
index 1570c9173f2f..4f72e022e345 100644
--- a/sci-libs/neartree/files/2.1.4-gentoo.patch
+++ b/sci-libs/neartree/files/3.1.1-gentoo.patch
@@ -1,30 +1,36 @@
+From eb88a598f46f835782ba93bfbde68761cb159f4c Mon Sep 17 00:00:00 2001
+Message-Id: <eb88a598f46f835782ba93bfbde68761cb159f4c.1323853429.git.jlec@gentoo.org>
+From: Justin Lecher <jlec@gentoo.org>
+Date: Wed, 14 Dec 2011 09:50:42 +0100
+Subject: [PATCH 1/2] gentoo.patch
+
+Conflicts:
+
+ Makefile
+---
+ Makefile | 30 +++++++++++++++---------------
+ 1 files changed, 15 insertions(+), 15 deletions(-)
+
diff --git a/Makefile b/Makefile
-index 10e9ba2..a992ea6 100644
+index 5c92d8b..859363e 100644
--- a/Makefile
+++ b/Makefile
-@@ -42,17 +42,17 @@
-
- # Version string
- VERSION = 3:0:0
--RELEASE = 2.1.3
-+RELEASE = 2.1.4
-
-
- #
- # Compiler and compilation flags
+@@ -52,11 +52,10 @@ RELEASE = 3.1
#
-CC = gcc
-+CC ?= gcc
ifneq ($(MSYSTEM),MINGW32)
-CFLAGS = -g -O2 -Wall -ansi -pedantic -DCNEARTREE_SAFE_TRIANG=1
+CFLAGS += -ansi -DCNEARTREE_SAFE_TRIANG=1
+ TIME = time
else
-CFLAGS = -g -O2 -Wall -DCNEARTREE_SAFE_TRIANG=1
+-TIME =
+CFLAGS += -DCNEARTREE_SAFE_TRIANG=1
++TIME =
endif
#
-@@ -72,8 +72,8 @@ endif
+@@ -76,8 +76,8 @@ endif
# Uncomment the next two lines if CVector is installed locally in $(HOME)/include
# and $(HOME)/lib
#
@@ -35,7 +41,7 @@ index 10e9ba2..a992ea6 100644
#
# Directories
-@@ -86,7 +86,7 @@ INC = $(ROOT)
+@@ -90,7 +90,7 @@ INC = $(ROOT)
EXAMPLES = $(ROOT)
TESTDATA = $(ROOT)
ifndef INSTALL_PREFIX
@@ -44,22 +50,31 @@ index 10e9ba2..a992ea6 100644
#INSTALL_PREFIX = $(HOME)
endif
-@@ -112,7 +112,7 @@ CLIBRARIES = $(CVECTOR_LIBLOC) -lCVector -lm
+@@ -115,10 +115,10 @@ CPPLIBRARIES = -lm
+ CLIBRARIES = $(CVECTOR_LIBLOC) -lCVector -lm
COMPILE_COMMAND = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS) $(INCLUDES) $(WARNINGS) -c
- CPPCOMPILE_COMMAND = $(LIBTOOL) --mode=compile $(CXX) $(CFLAGS) $(INCLUDES) $(WARNINGS) -c
--LIBRARY_LINK_COMMAND = $(LIBTOOL) --mode=link $(CC) -version-info $(VERSION) -release $(RELEASE) -no-undefined -rpath $(INSTALL_PREFIX)/lib
+-CPPCOMPILE_COMMAND = $(LIBTOOL) --mode=compile $(CXX) $(CFLAGS) $(INCLUDES) $(WARNINGS) -c
+-LIBRARY_LINK_COMMAND = $(LIBTOOL) --mode=link $(CC) -version-info $(VERSION) -no-undefined -rpath $(INSTALL_PREFIX)/lib
++CPPCOMPILE_COMMAND = $(LIBTOOL) --mode=compile $(CXX) $(CXXFLAGS) $(INCLUDES) $(WARNINGS) -c
+LIBRARY_LINK_COMMAND = $(LIBTOOL) --mode=link $(CC) -version-info $(VERSION) -release $(RELEASE) -no-undefined -rpath $(INSTALL_PREFIX)/GENTOOLIBDIR $(LDFLAGS)
BUILD_COMMAND_LOCAL = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(INCLUDES)
- CPPBUILD_COMMAND_LOCAL = $(LIBTOOL) --mode=link $(CXX) -no-undefined $(CFLAGS) $(INCLUDES)
+-CPPBUILD_COMMAND_LOCAL = $(LIBTOOL) --mode=link $(CXX) -no-undefined $(CFLAGS) $(INCLUDES)
++CPPBUILD_COMMAND_LOCAL = $(LIBTOOL) --mode=link $(CXX) -no-undefined $(CXXFLAGS) $(INCLUDES)
BUILD_COMMAND_DYNAMIC = $(LIBTOOL) --mode=link $(CC) -no-undefined $(CFLAGS) -shared -I$(INSTALL_PREFIX)/include
-@@ -221,10 +221,10 @@ all: $(LIB) $(BIN) $(SOURCE) $(HEADERS) \
+ BUILD_COMMAND_STATIC = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -static-libtool-libs -I$(INSTALL_PREFIX)/include
+ INSTALL_COMMAND = $(LIBTOOL) --mode=install cp
+@@ -223,13 +223,13 @@ endif
+ #
+ all: $(LIB) $(BIN) $(SOURCE) $(HEADERS) \
$(LIB)/libCNearTree.$(LIB_EXT) \
- $(BIN)/CPPMain $(BIN)/CMain $(BIN)/CPPNearTreeTest $(BIN)/CNearTreeTest
+- $(BIN)/CPPMain $(BIN)/CMain $(BIN)/CPPNearTreeTest $(BIN)/CNearTreeTest $(BIN)/CNearTreeTestInst
++ $(BIN)/CPPMain $(BIN)/CMain $(BIN)/CPPNearTreeTest $(BIN)/CNearTreeTest
-install: all $(INSTALL_PREFIX) $(INSTALL_PREFIX)/lib $(INSTALL_PREFIX)/include \
+install: all $(INSTALL_PREFIX) $(INSTALL_PREFIX)/GENTOOLIBDIR $(INSTALL_PREFIX)/include \
- $(INC) $(LIB)/libCNearTree.$(LIB_EXT) $(INC)/TNear.h $(INC)/CNearTree.h $(INC)/rhrand.h
+ $(INC) $(LIB)/libCNearTree.$(LIB_EXT) $(INC)/TNear.h $(INC)/CNearTree.h \
+ $(INC)/rhrand.h $(INC)/triple.h
- $(INSTALL_COMMAND) $(LIB)/libCNearTree.$(LIB_EXT) $(INSTALL_PREFIX)/lib/libCNearTree.$(LIB_EXT)
- $(INSTALL_FINISH_COMMAND) $(INSTALL_PREFIX)/lib/libCNearTree.$(LIB_EXT)
+ $(INSTALL_COMMAND) $(LIB)/libCNearTree.$(LIB_EXT) $(INSTALL_PREFIX)/GENTOOLIBDIR/libCNearTree.$(LIB_EXT)
@@ -67,22 +82,7 @@ index 10e9ba2..a992ea6 100644
-cp $(INSTALL_PREFIX)/include/TNear.h $(INSTALL_PREFIX)/include/TNear_old.h
-cp $(INSTALL_PREFIX)/include/CNearTree.h $(INSTALL_PREFIX)/include/CNearTree_old.h
cp $(INC)/TNear.h $(INSTALL_PREFIX)/include/TNear.h
-@@ -233,14 +233,6 @@ install: all $(INSTALL_PREFIX) $(INSTALL_PREFIX)/lib $(INSTALL_PREFIX)/include
- chmod 644 $(INSTALL_PREFIX)/include/TNear.h
- chmod 644 $(INSTALL_PREFIX)/include/CNearTree.h
- chmod 644 $(INSTALL_PREFIX)/include/rhrand.h
-- echo "Testing final install dynamic"
-- $(BUILD_COMMAND_DYNAMIC) $(INCLUDES) $(EXAMPLES)/CNearTreeTest.c \
-- -L$(INSTALL_PREFIX)/lib -lCNearTree $(CLIBRARIES) -o $(BIN)/CNearTreeTest_dynamic
-- $(BIN)/CNearTreeTest_dynamic
-- echo "Testing final install static"
-- $(BUILD_COMMAND_STATIC) $(INCLUDES) $(EXAMPLES)/CNearTreeTest.c \
-- -L$(INSTALL_PREFIX)/lib -lCNearTree $(CLIBRARIES) -o $(BIN)/CNearTreeTest_static
-- $(BIN)/CNearTreeTest_static
-
-
-
-@@ -250,8 +242,8 @@ install: all $(INSTALL_PREFIX) $(INSTALL_PREFIX)/lib $(INSTALL_PREFIX)/include
+@@ -257,8 +257,8 @@ install: all $(INSTALL_PREFIX) $(INSTALL_PREFIX)/lib $(INSTALL_PREFIX)/include
$(INSTALL_PREFIX):
mkdir -p $(INSTALL_PREFIX)
@@ -93,3 +93,6 @@ index 10e9ba2..a992ea6 100644
$(INSTALL_PREFIX)/bin: $(INSTALL_PREFIX)
mkdir -p $(INSTALL_PREFIX)/bin
+--
+1.7.8
+
diff --git a/sci-libs/neartree/files/3.1.1-notest.patch b/sci-libs/neartree/files/3.1.1-notest.patch
new file mode 100644
index 000000000000..c85a50537894
--- /dev/null
+++ b/sci-libs/neartree/files/3.1.1-notest.patch
@@ -0,0 +1,34 @@
+From c9367aefa380d276590e3e0045f69fc884fed948 Mon Sep 17 00:00:00 2001
+Message-Id: <c9367aefa380d276590e3e0045f69fc884fed948.1323853429.git.jlec@gentoo.org>
+In-Reply-To: <eb88a598f46f835782ba93bfbde68761cb159f4c.1323853429.git.jlec@gentoo.org>
+References: <eb88a598f46f835782ba93bfbde68761cb159f4c.1323853429.git.jlec@gentoo.org>
+From: Justin Lecher <jlec@gentoo.org>
+Date: Wed, 14 Dec 2011 09:56:51 +0100
+Subject: [PATCH 2/2] notest.patch
+
+---
+ Makefile | 8 --------
+ 1 files changed, 0 insertions(+), 8 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 859363e..8de706b 100644
+--- a/Makefile
++++ b/Makefile
+@@ -240,14 +240,6 @@ install: all $(INSTALL_PREFIX) $(INSTALL_PREFIX)/GENTOOLIBDIR $(INSTALL_PREFIX)
+ chmod 644 $(INSTALL_PREFIX)/include/CNearTree.h
+ chmod 644 $(INSTALL_PREFIX)/include/rhrand.h
+ chmod 644 $(INSTALL_PREFIX)/include/triple.h
+- echo "Testing final install dynamic"
+- $(BUILD_COMMAND_DYNAMIC) $(INCLUDES) $(EXAMPLES)/CNearTreeTest.c \
+- -L$(INSTALL_PREFIX)/lib -lCNearTree $(CLIBRARIES) -o $(BIN)/CNearTreeTest_dynamic
+- $(BIN)/CNearTreeTest_dynamic
+- echo "Testing final install static"
+- $(BUILD_COMMAND_STATIC) $(INCLUDES) $(EXAMPLES)/CNearTreeTest.c \
+- -L$(INSTALL_PREFIX)/lib -lCNearTree $(CLIBRARIES) -o $(BIN)/CNearTreeTest_static
+- $(BIN)/CNearTreeTest_static
+
+
+
+--
+1.7.8
+
diff --git a/sci-libs/neartree/files/3.1.1-test.patch b/sci-libs/neartree/files/3.1.1-test.patch
new file mode 100644
index 000000000000..2796be6eaf85
--- /dev/null
+++ b/sci-libs/neartree/files/3.1.1-test.patch
@@ -0,0 +1,34 @@
+From 6a9ec8e68191a3ff9ad21a34814e71f6baf6f5ce Mon Sep 17 00:00:00 2001
+Message-Id: <6a9ec8e68191a3ff9ad21a34814e71f6baf6f5ce.1323853619.git.jlec@gentoo.org>
+From: Justin Lecher <jlec@gentoo.org>
+Date: Wed, 14 Dec 2011 10:06:51 +0100
+Subject: [PATCH] 3.1.1-test.patch
+
+---
+ Makefile | 10 ----------
+ 1 files changed, 0 insertions(+), 10 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 8de706b..73ae0da 100644
+--- a/Makefile
++++ b/Makefile
+@@ -339,16 +339,6 @@ tests: $(LIB) $(BIN) $(BIN)/CPPMain $(BIN)/CPPMain_Flip $(BIN)/CPPNearTreeTest
+ $(TIME) $(BIN)/CPPNearTreeTestInstNoFlip
+ $(TIME) $(BIN)/CNearTreeTest --debug
+ $(TIME) $(BIN)/CNearTreeTestInst --debug
+-ifneq ($(MSYSTEM),MINGW32)
+- diff -b -c $(TESTDATA)/CPPMain_orig.lst $(TESTDATA)/CPPMain.lst
+- diff -b -c $(TESTDATA)/CPPMain_orig.lst $(TESTDATA)/CPPMain_Flip.lst
+- diff -b -c $(TESTDATA)/CMain_orig.lst $(TESTDATA)/CMain.lst
+-else
+- diff -b -c $(TESTDATA)/CPPMain_MINGW_orig.lst $(TESTDATA)/CPPMain.lst
+- diff -b -c $(TESTDATA)/CPPMain_MINGW_orig.lst $(TESTDATA)/CPPMain_Flip.lst
+- diff -b -c $(TESTDATA)/CMain_MINGW_orig.lst $(TESTDATA)/CMain.lst
+-endif
+-
+ #
+ # Remove all non-source files
+ #
+--
+1.7.8
+