summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-10-17 00:34:14 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-10-17 00:34:14 +0000
commit9052c0d078114bf2c924f074a91ccd19fc338dd6 (patch)
tree79eb19f6f33921da239e90bf0fe47977c7326573 /sci-libs/itpp
parentAdd pkgconfig to DEPEND. (bug #150809) (diff)
downloadgentoo-2-9052c0d078114bf2c924f074a91ccd19fc338dd6.tar.gz
gentoo-2-9052c0d078114bf2c924f074a91ccd19fc338dd6.tar.bz2
gentoo-2-9052c0d078114bf2c924f074a91ccd19fc338dd6.zip
Version bump and removed some of the old versions. This fixes bug #151487.
(Portage version: 2.1.2_pre3-r2)
Diffstat (limited to 'sci-libs/itpp')
-rw-r--r--sci-libs/itpp/ChangeLog10
-rw-r--r--sci-libs/itpp/files/digest-itpp-3.10.63
-rw-r--r--sci-libs/itpp/itpp-3.10.6.ebuild58
3 files changed, 70 insertions, 1 deletions
diff --git a/sci-libs/itpp/ChangeLog b/sci-libs/itpp/ChangeLog
index 6f297ee2ca6b..29fe4b4561b2 100644
--- a/sci-libs/itpp/ChangeLog
+++ b/sci-libs/itpp/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-libs/itpp
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.12 2006/10/12 21:07:56 je_fro Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.13 2006/10/17 00:34:14 markusle Exp $
+
+*itpp-3.10.6 (16 Oct 2006)
+
+ 16 Oct 2006; Markus Dittrich <markusle@gentoo.org> -itpp-3.10.3.ebuild,
+ -itpp-3.10.4.ebuild, +itpp-3.10.6.ebuild:
+ Version bump and removed some of the old versions. Thanks much
+ to Adam Piatyszek <ediap@et.put.poznan.pl> for keeping us up
+ to date on new versions. This fixes bug #151487.
12 Oct 2006; Jeff Gardner <je_fro@gentoo.org> itpp-3.10.5.ebuild:
Keyword itpp-3.10.5 ~amd64 per bug #129809
diff --git a/sci-libs/itpp/files/digest-itpp-3.10.6 b/sci-libs/itpp/files/digest-itpp-3.10.6
new file mode 100644
index 000000000000..8f2215c54eef
--- /dev/null
+++ b/sci-libs/itpp/files/digest-itpp-3.10.6
@@ -0,0 +1,3 @@
+MD5 b78a13b5b2c7ae5bcd369b3440804c45 itpp-3.10.6.tar.bz2 803006
+RMD160 674861a254c5bc1dadbec5ce4b8377e4a314030e itpp-3.10.6.tar.bz2 803006
+SHA256 690225fd2b28f6bce355c0fe1b1132745ef82f31bc29e37b46b7ea58af9e4a83 itpp-3.10.6.tar.bz2 803006
diff --git a/sci-libs/itpp/itpp-3.10.6.ebuild b/sci-libs/itpp/itpp-3.10.6.ebuild
new file mode 100644
index 000000000000..5e86b0b41385
--- /dev/null
+++ b/sci-libs/itpp/itpp-3.10.6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-3.10.6.ebuild,v 1.1 2006/10/17 00:34:14 markusle Exp $
+
+inherit fortran
+
+DESCRIPTION="IT++ is a C++ library of mathematical, signal processing, speech processing, and communications classes and functions"
+LICENSE="GPL-2"
+HOMEPAGE="http://itpp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="blas cblas debug doc fftw lapack"
+
+DEPEND="fftw? ( >=sci-libs/fftw-3.0.0 )
+ blas? ( virtual/blas
+ cblas? ( || ( >=sci-libs/gsl-1.4
+ >=sci-libs/acml-2.5.3
+ >=sci-libs/blas-atlas-3.6.0
+ sci-libs/cblas-reference ) )
+ lapack? ( virtual/lapack ) )
+ doc? ( app-doc/doxygen
+ virtual/tetex )"
+
+pkg_setup() {
+ # lapack/cblas can only be used in conjunction with blas
+ if use cblas && ! use blas; then
+ die "USE=cblas requires USE=blas to be set"
+ fi
+ if use lapack && ! use blas; then
+ die "USE=lapack requires USE=blas to be set"
+ fi
+}
+
+src_compile() {
+ local myconf
+
+ if use blas; then
+ myconf="--with-blas=-lblas"
+ else
+ myconf="--without-blas"
+ fi
+ econf $(use_enable doc html-doc) \
+ $(use_enable debug) \
+ $(use_with cblas) \
+ $(use_with lapack) \
+ $(use_with fftw fft) \
+ "$myconf" \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO || \
+ die "failed to install docs"
+}