summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2014-11-25 15:26:17 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2014-11-25 15:26:17 +0000
commitb29627c302cc60592b46cf31440e3d20c5d975f0 (patch)
tree494f337513543a012f5aba60fc32df9a0d0e212e /sci-libs/hdf5/files
parentSupport python 3.4 (diff)
downloadgentoo-2-b29627c302cc60592b46cf31440e3d20c5d975f0.tar.gz
gentoo-2-b29627c302cc60592b46cf31440e3d20c5d975f0.tar.bz2
gentoo-2-b29627c302cc60592b46cf31440e3d20c5d975f0.zip
Version bump, drop old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x5D21B852895192F9)
Diffstat (limited to 'sci-libs/hdf5/files')
-rw-r--r--sci-libs/hdf5/files/hdf5-1.8.14-implicits.patch (renamed from sci-libs/hdf5/files/hdf5-1.8.11-implicits.patch)50
1 files changed, 30 insertions, 20 deletions
diff --git a/sci-libs/hdf5/files/hdf5-1.8.11-implicits.patch b/sci-libs/hdf5/files/hdf5-1.8.14-implicits.patch
index 478557013596..4ee6e83d9f2f 100644
--- a/sci-libs/hdf5/files/hdf5-1.8.11-implicits.patch
+++ b/sci-libs/hdf5/files/hdf5-1.8.14-implicits.patch
@@ -1,13 +1,35 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1522,6 +1522,9 @@ case "$host_cpu-$host_vendor-$host_os" in
+ ## however, we do not do this since it breaks the big test on some
+ ## older platforms.
+ AM_CPPFLAGS="-D_BSD_SOURCE $AM_CPPFLAGS"
++
++ ## _GNU_SOURCE is needed for vasprintf
++ AM_CPPFLAGS="-D_GNU_SOURCE $AM_CPPFLAGS"
+ ;;
+ esac
+
--- a/hl/src/H5LTanalyze.c
+++ b/hl/src/H5LTanalyze.c
-@@ -49,6 +49,7 @@
- #define YY_FLEX_MINOR_VERSION 5
-
- #include <stdio.h>
-+#include "H5public.h"
- #ifdef H5_HAVE_UNISTD_H
- #include <unistd.h>
- #endif
+@@ -40,6 +40,7 @@
+ #include <string.h>
+ #include <errno.h>
+ #include <stdlib.h>
++#include <unistd.h>
+
+ /* end standard C headers. */
+
+--- a/hl/src/H5LTanalyze.l
++++ b/hl/src/H5LTanalyze.l
+@@ -16,6 +16,7 @@
+ %{
+ #include <stdlib.h>
+ #include <string.h>
++#include <unistd.h>
+ #include <hdf5.h>
+ #include "H5LTparse.h"
+
--- a/test/cache_common.h
+++ b/test/cache_common.h
@@ -702,5 +702,8 @@ void validate_mdc_config(hid_t file_id,
@@ -31,15 +53,3 @@
static void coll_write_test(int chunk_factor);
---- a/configure.ac
-+++ b/configure.ac
-@@ -1504,6 +1504,9 @@ case "$host_cpu-$host_vendor-$host_os" in
- ## however, we do not do this since it breaks the big test on some
- ## older platforms.
- AM_CPPFLAGS="-D_BSD_SOURCE $AM_CPPFLAGS"
-+
-+ ## _GNU_SOURCE is needed for vasprintf
-+ AM_CPPFLAGS="-D_GNU_SOURCE $AM_CPPFLAGS"
- ;;
- esac
-