summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2005-08-27 13:35:32 +0000
committerMasatomo Nakano <nakano@gentoo.org>2005-08-27 13:35:32 +0000
commit3e9139db127c1ce2e36539930a9a21c04fa23471 (patch)
treeac60453e64802999a210f5328ae3477ff1ff752b /sci-libs/geos
parentVersion bump wrt security bug #102379 (diff)
downloadgentoo-2-3e9139db127c1ce2e36539930a9a21c04fa23471.tar.gz
gentoo-2-3e9139db127c1ce2e36539930a9a21c04fa23471.tar.bz2
gentoo-2-3e9139db127c1ce2e36539930a9a21c04fa23471.zip
version bump
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sci-libs/geos')
-rw-r--r--sci-libs/geos/ChangeLog7
-rw-r--r--sci-libs/geos/Manifest6
-rw-r--r--sci-libs/geos/files/digest-geos-2.1.41
-rw-r--r--sci-libs/geos/geos-2.1.4.ebuild70
4 files changed, 81 insertions, 3 deletions
diff --git a/sci-libs/geos/ChangeLog b/sci-libs/geos/ChangeLog
index 509dc4fedb50..c808787b3910 100644
--- a/sci-libs/geos/ChangeLog
+++ b/sci-libs/geos/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/geos
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.6 2005/07/23 02:02:29 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.7 2005/08/27 13:35:32 nakano Exp $
+
+*geos-2.1.4 (27 Aug 2005)
+
+ 27 Aug 2005; Masatomo Nakano <nakano@gentoo.org> +geos-2.1.4.ebuild:
+ Version bump.
23 Jul 2005; Steve Arnold <nerdboy@gentoo.org> geos-2.1.1.ebuild,
geos-2.1.2.ebuild:
diff --git a/sci-libs/geos/Manifest b/sci-libs/geos/Manifest
index 8d1b51cfb410..ea5e60af2815 100644
--- a/sci-libs/geos/Manifest
+++ b/sci-libs/geos/Manifest
@@ -1,7 +1,9 @@
-MD5 e778efe49acaa3bc2b478b8eb3dfd637 ChangeLog 1127
+MD5 c437f799a11bbf183f0ce7852a2f284d geos-2.1.4.ebuild 1505
MD5 532e51052941f6e3c3ee93c7712008a0 geos-2.1.1.ebuild 959
+MD5 e778efe49acaa3bc2b478b8eb3dfd637 ChangeLog 1127
MD5 4b491a816a154aafb3877b71ae44bda2 metadata.xml 180
MD5 5285ac48180b4870ddc56f7f841bd4e8 geos-2.1.2.ebuild 880
-MD5 e64702857a489d4d24706066fb8b9edb files/digest-geos-2.1.1 63
MD5 ccfdc64d67bd756e8681dbcedf4a7ee4 files/geos-2.1.1-multilib.patch 901
+MD5 e64702857a489d4d24706066fb8b9edb files/digest-geos-2.1.1 63
MD5 10716de046c293dcbc7acead1c63aa13 files/digest-geos-2.1.2 63
+MD5 6702e1ce86d53d86b0fb87ef6796a141 files/digest-geos-2.1.4 63
diff --git a/sci-libs/geos/files/digest-geos-2.1.4 b/sci-libs/geos/files/digest-geos-2.1.4
new file mode 100644
index 000000000000..58b6790b684a
--- /dev/null
+++ b/sci-libs/geos/files/digest-geos-2.1.4
@@ -0,0 +1 @@
+MD5 e00524abc2cb26c8fb9173b8696be3b7 geos-2.1.4.tar.bz2 506683
diff --git a/sci-libs/geos/geos-2.1.4.ebuild b/sci-libs/geos/geos-2.1.4.ebuild
new file mode 100644
index 000000000000..ecdb8e1ed202
--- /dev/null
+++ b/sci-libs/geos/geos-2.1.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-2.1.4.ebuild,v 1.1 2005/08/27 13:35:32 nakano Exp $
+
+inherit eutils
+
+DESCRIPTION="Geometry Engine - Open Source"
+HOMEPAGE="http://geos.refractions.net"
+SRC_URI="http://geos.refractions.net/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc ~sparc"
+IUSE="static doc python"
+
+RDEPEND="virtual/libc"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )\
+ python? ( dev-lang/python dev-lang/swig )"
+
+src_compile(){
+ cd ${S}
+ libtoolize --force
+ local myconf
+ myconf=""
+ if use static; then
+ myconf="$(use_enable static)"
+ fi
+ econf \
+ ${myconf} \
+ || die "Error: econf failed"
+ emake || die "Error: emake failed"
+ if use python; then
+ einfo "Compilling PyGEOS"
+ cd ${S}/swig/python
+ swig -c++ -python -modern -o geos_wrap.cxx ../geos.i
+ python setup.py build
+ fi
+}
+
+src_test() {
+ cd ${S}
+ make check || die "Tring make check without success."
+# I think this test must be made after the PyGEOS installation
+# if use python; then
+# cd ${S}/swig/python
+# python tests/runtests.py -v
+# fi
+}
+
+src_install(){
+ into /usr
+ einstall
+ dodoc AUTHORS COPYING INSTALL NEWS README TODO
+ if use doc; then
+ cd ${S}/doc
+ make doxygen-html
+ dohtml -r doxygen_docs/html/*
+ fi
+ if use python; then
+ einfo "Intalling PyGEOS"
+ cd ${S}/swig/python
+ python setup.py install --prefix="${D}/usr/"
+ insinto /usr/share/doc/${PF}/python
+ doins README.txt tests/*.py
+ insinto /usr/share/doc/${PF}/python/cases
+ doins tests/cases/*
+ fi
+}
+