summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-11-26 22:55:43 +0000
committerMichał Górny <mgorny@gentoo.org>2011-11-26 22:55:43 +0000
commitf562616c24286a311d073f93da89dd720a46823e (patch)
tree7cc93f8dc7f9c752b083ba24bd7dcf3ae9406620 /sci-libs/freesteam/freesteam-2.0.ebuild
parentFix build issue when USE=-utp, bug #290737. (diff)
downloadgentoo-2-f562616c24286a311d073f93da89dd720a46823e.tar.gz
gentoo-2-f562616c24286a311d073f93da89dd720a46823e.tar.bz2
gentoo-2-f562616c24286a311d073f93da89dd720a46823e.zip
Introduce the initial ebuild for freesteam, free IF97 steam tables implementation.
(Portage version: 2.2.0_alpha77/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/freesteam/freesteam-2.0.ebuild')
-rw-r--r--sci-libs/freesteam/freesteam-2.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sci-libs/freesteam/freesteam-2.0.ebuild b/sci-libs/freesteam/freesteam-2.0.ebuild
new file mode 100644
index 000000000000..549d7fd94482
--- /dev/null
+++ b/sci-libs/freesteam/freesteam-2.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/freesteam/freesteam-2.0.ebuild,v 1.1 2011/11/26 22:55:43 mgorny Exp $
+
+EAPI=4
+
+inherit base multilib scons-utils toolchain-funcs
+
+DESCRIPTION="Open source implementation of IF97 steam tables"
+HOMEPAGE="http://freesteam.sourceforge.net/"
+SRC_URI="mirror://sourceforge/freesteam/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sci-libs/gsl"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}"/${PN}-flags.patch
+ "${FILESDIR}"/${PN}-soname-symlinks.patch
+ )
+
+ base_src_prepare
+}
+
+src_configure() {
+ myesconsargs=(
+ INSTALL_PREFIX=/usr
+ INSTALL_LIB=/usr/$(get_libdir)
+ INSTALL_ROOT="${D}"
+
+ CC="$(tc-getCC)"
+ SWIG=false
+ )
+
+ mkdir -p "${D}" || die
+}
+
+src_compile() {
+ escons
+}
+
+src_install() {
+ escons install
+}