summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-10-16 03:51:12 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-10-16 03:51:12 +0000
commit23b2aac745274cbc17ac9056960750c16e03f1f2 (patch)
tree40d28fef97bf6a6b75d1836ba21d942af01d02f6 /sci-libs/fftw
parentSet rc_shell to /sbin/sulogin by default when it is installed. (diff)
downloadgentoo-2-23b2aac745274cbc17ac9056960750c16e03f1f2.tar.gz
gentoo-2-23b2aac745274cbc17ac9056960750c16e03f1f2.tar.bz2
gentoo-2-23b2aac745274cbc17ac9056960750c16e03f1f2.zip
Added append-flags to the no-as-needed bit (bug #289220)
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/fftw')
-rw-r--r--sci-libs/fftw/fftw-2.1.5-r5.ebuild4
-rw-r--r--sci-libs/fftw/fftw-3.2.2.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/sci-libs/fftw/fftw-2.1.5-r5.ebuild b/sci-libs/fftw/fftw-2.1.5-r5.ebuild
index 8eeec2631a3e..112a04627a1f 100644
--- a/sci-libs/fftw/fftw-2.1.5-r5.ebuild
+++ b/sci-libs/fftw/fftw-2.1.5-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-2.1.5-r5.ebuild,v 1.11 2009/10/15 17:11:21 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-2.1.5-r5.ebuild,v 1.12 2009/10/16 03:51:12 bicatali Exp $
inherit eutils flag-o-matic autotools toolchain-funcs
@@ -37,7 +37,7 @@ then
ewarn "Otherwise the configure script will select POSIX threads."
epause 5
fi
- use openmp && [[ $(tc-getCC)$ == icc* ]] && no-as-needed
+ use openmp && [[ $(tc-getCC)$ == icc* ]] && append-ldflags $(no-as-needed)
}
src_unpack() {
diff --git a/sci-libs/fftw/fftw-3.2.2.ebuild b/sci-libs/fftw/fftw-3.2.2.ebuild
index e2d4e5d57c27..4468ef703a72 100644
--- a/sci-libs/fftw/fftw-3.2.2.ebuild
+++ b/sci-libs/fftw/fftw-3.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.2.2.ebuild,v 1.9 2009/10/15 17:11:21 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.2.2.ebuild,v 1.10 2009/10/16 03:51:12 bicatali Exp $
EAPI=2
inherit flag-o-matic eutils toolchain-funcs autotools
@@ -34,7 +34,7 @@ pkg_setup() {
FFTW_THREADS="--enable-threads --disable-openmp"
fi
FFTW_DIRS="single double longdouble"
- use openmp && [[ $(tc-getCC)$ == icc* ]] && no-as-needed
+ use openmp && [[ $(tc-getCC)$ == icc* ]] && append-ldflags $(no-as-needed)
}
src_prepare() {