summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-28 20:05:29 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-28 20:05:29 +0000
commitf54452e3b988568b12769335101d056f3e3efb6d (patch)
tree700c1d130f3dd7d88e1db690dafab24014e523a5 /sci-libs/cln
parentFixed ChangeLog header. (Manifest recommit) (diff)
downloadgentoo-2-f54452e3b988568b12769335101d056f3e3efb6d.tar.gz
gentoo-2-f54452e3b988568b12769335101d056f3e3efb6d.tar.bz2
gentoo-2-f54452e3b988568b12769335101d056f3e3efb6d.zip
Moved from dev-libs/cln to sci-libs/cln.
Diffstat (limited to 'sci-libs/cln')
-rw-r--r--sci-libs/cln/ChangeLog41
-rw-r--r--sci-libs/cln/Manifest6
-rw-r--r--sci-libs/cln/cln-1.1.5.ebuild45
-rw-r--r--sci-libs/cln/cln-1.1.6.ebuild49
-rw-r--r--sci-libs/cln/files/digest-cln-1.1.51
-rw-r--r--sci-libs/cln/files/digest-cln-1.1.61
-rw-r--r--sci-libs/cln/metadata.xml5
7 files changed, 148 insertions, 0 deletions
diff --git a/sci-libs/cln/ChangeLog b/sci-libs/cln/ChangeLog
new file mode 100644
index 000000000000..518af17c30d9
--- /dev/null
+++ b/sci-libs/cln/ChangeLog
@@ -0,0 +1,41 @@
+# ChangeLog for dev-libs/cln
+# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cln/ChangeLog,v 1.1 2004/12/28 20:05:29 ribosome Exp $
+
+*cln-1.1.6 (28 Dec 2004)
+
+ 28 Dec 2004; Olivier Fisette <ribosome@gentoo.org> +metadata.xml,
+ +cln-1.1.5.ebuild, +cln-1.1.6.ebuild:
+ Moved from dev-libs/cln to sci-libs/cln.
+
+ 02 Dec 2004; Patrick Kursawe <phosphan@gentoo.org> cln-1.1.6.ebuild:
+ Fixing the last fix.
+
+ 23 Nov 2004; Patrick Kursawe <phosphan@gentoo.org> cln-1.1.6.ebuild:
+ Fixing bug #70779 (compile failure with a certain gcc version and
+ -finline-functions in CFLAGS)
+
+ 04 Nov 2004; Patrick Kursawe <phosphan@gentoo.org> +metadata.xml,
+ cln-1.1.6.ebuild:
+ Adding metadata, declaring latest version stable for x86.
+
+*cln-1.1.6 (17 Mar 2004)
+
+ 17 Mar 2004; Daniel Ahlberg <aliz@gentoo.org> cln-1.1.5.ebuild,
+ cln-1.1.6.ebuild:
+ Version bump to version that builds on amd64.
+
+ 14 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> cln-1.1.5.ebuild:
+ Don't assign default to S; header fix
+
+ 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+
+*cln-1.1.5 (31 Aug 2002)
+
+ 28 Oct 2002; George Shapovalov <george@gentoo.org> cln-1.1.15.ebuild, ChangeLog :
+
+ cleaned app (KEYWORDS, SLOT..., C[XX]FLAGS filters) and added to portage
+
+ 31 Aug 2002; Pierre-Henri Jondot <Pierre-Henri.Jondot@wanadoo.fr> Changelog :
+ ebuild submitted by Pierre-Henri Jondot <Pierre-Henri.Jondot@wanadoo.fr>
+
diff --git a/sci-libs/cln/Manifest b/sci-libs/cln/Manifest
new file mode 100644
index 000000000000..0998f1bbb213
--- /dev/null
+++ b/sci-libs/cln/Manifest
@@ -0,0 +1,6 @@
+MD5 519587fd2939e70bbf4b5358eaf37dcd cln-1.1.6.ebuild 1280
+MD5 184ce1d51ade23aae6cbd48de4fea626 cln-1.1.5.ebuild 1122
+MD5 c5cc205c2b9c67bb1e16420c543c1821 ChangeLog 1316
+MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
+MD5 f0d1f7859755b5b468024ed4132f3095 files/digest-cln-1.1.5 62
+MD5 e6723419337999b42ae07ddbe7e91aa6 files/digest-cln-1.1.6 63
diff --git a/sci-libs/cln/cln-1.1.5.ebuild b/sci-libs/cln/cln-1.1.5.ebuild
new file mode 100644
index 000000000000..ce8bdbb16992
--- /dev/null
+++ b/sci-libs/cln/cln-1.1.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cln/cln-1.1.5.ebuild,v 1.1 2004/12/28 20:05:29 ribosome Exp $
+
+inherit flag-o-matic gcc
+
+DESCRIPTION="CLN, a class library (C++) for numbers"
+
+HOMEPAGE="http://www.ginac.de/CLN/"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="x86 ~ppc ~sparc"
+IUSE=""
+
+SRC_URI="ftp://ftp.santafe.edu/pub/gnu/${P}.tar.gz"
+#SRC_URI="ftp://ftpthep.physik.uni-mainz.de/pub/gnu/${P}.tar.gz"
+DEPEND="dev-libs/gmp"
+
+src_compile() {
+ libtoolize -c -f
+
+ # at least with gcc 2.95 and 3.1, cln won't like -O3 flag...
+ replace-flags -O[3..9] -O2
+
+ # and with gcc 2.95.3, it doesn't like funroll-loops as well...
+ if [ "$( gcc-fullversion )" == "2.95.3" ]; then
+ filter-flags -funroll-loops
+ filter-flags -frerun-loop-opt
+ fi
+
+ ./configure \
+ --build=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share/doc/${P} \
+ --mandir=/usr/share/man || die "./configure failed"
+
+ #it doesn't also like parallel make :)
+ make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+}
diff --git a/sci-libs/cln/cln-1.1.6.ebuild b/sci-libs/cln/cln-1.1.6.ebuild
new file mode 100644
index 000000000000..b21c686ed8ce
--- /dev/null
+++ b/sci-libs/cln/cln-1.1.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cln/cln-1.1.6.ebuild,v 1.1 2004/12/28 20:05:29 ribosome Exp $
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="CLN, a class library (C++) for numbers"
+
+HOMEPAGE="http://www.ginac.de/CLN/"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="x86 ~ppc ~sparc ~amd64"
+IUSE=""
+
+SRC_URI="ftp://ftpthep.physik.uni-mainz.de/pub/gnu/${P}.tar.bz2
+ ftp://ftp.santafe.edu/pub/gnu/${P}.tar.bz2
+ ftp://ftp.ilog.fr/pub/Users/haible/gnu/${P}.tar.bz2"
+DEPEND="dev-libs/gmp"
+
+src_compile() {
+ # at least with gcc 2.95 and 3.1, cln won't like -O3 flag...
+ replace-flags -O[3..9] -O2
+
+ # and with gcc 2.95.3, it doesn't like funroll-loops as well...
+ if [ "$( gcc-fullversion )" == "2.95.3" ]; then
+ filter-flags -funroll-loops
+ filter-flags -frerun-loop-opt
+ fi
+
+ # Trouble: see bug #70779
+ if [ "$( gcc-fullversion )" == "3.3.4" ]; then
+ filter-flags -finline-functions
+ fi
+
+ ./configure \
+ --build=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share/doc/${P} \
+ --mandir=/usr/share/man || die "./configure failed"
+
+ #it doesn't also like parallel make :)
+ make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+}
diff --git a/sci-libs/cln/files/digest-cln-1.1.5 b/sci-libs/cln/files/digest-cln-1.1.5
new file mode 100644
index 000000000000..179c916e1279
--- /dev/null
+++ b/sci-libs/cln/files/digest-cln-1.1.5
@@ -0,0 +1 @@
+MD5 55d9e26806bfe9023c09caf2d7e7e91b cln-1.1.5.tar.gz 2042960
diff --git a/sci-libs/cln/files/digest-cln-1.1.6 b/sci-libs/cln/files/digest-cln-1.1.6
new file mode 100644
index 000000000000..19aa04722604
--- /dev/null
+++ b/sci-libs/cln/files/digest-cln-1.1.6
@@ -0,0 +1 @@
+MD5 8c364297c3cd7cbd413a510b68849451 cln-1.1.6.tar.bz2 1595522
diff --git a/sci-libs/cln/metadata.xml b/sci-libs/cln/metadata.xml
new file mode 100644
index 000000000000..b229aec85b8f
--- /dev/null
+++ b/sci-libs/cln/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+</pkgmetadata>