summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-12-12 18:23:10 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-12-12 18:23:10 +0000
commitbd5b34095adef5a7ceeeebce12af70f364b7dd1b (patch)
tree8262b9546d79ea88591f774a0bb164a9dc6a8543 /sci-libs/armadillo
parentvirtual/fortran: Shorten dependency declaration suggested by Arfrever (diff)
downloadgentoo-2-bd5b34095adef5a7ceeeebce12af70f364b7dd1b.tar.gz
gentoo-2-bd5b34095adef5a7ceeeebce12af70f364b7dd1b.tar.bz2
gentoo-2-bd5b34095adef5a7ceeeebce12af70f364b7dd1b.zip
Version bump. Removed atlas flag temporarily for later integration from the science overlay
(Portage version: 2.2.01.21418-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs/armadillo')
-rw-r--r--sci-libs/armadillo/ChangeLog9
-rw-r--r--sci-libs/armadillo/armadillo-3.4.4.ebuild15
-rw-r--r--sci-libs/armadillo/armadillo-3.6.0.ebuild (renamed from sci-libs/armadillo/armadillo-3.4.3.ebuild)26
3 files changed, 17 insertions, 33 deletions
diff --git a/sci-libs/armadillo/ChangeLog b/sci-libs/armadillo/ChangeLog
index a1b18c8af26c..3c5a0c5d8c5f 100644
--- a/sci-libs/armadillo/ChangeLog
+++ b/sci-libs/armadillo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/armadillo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/ChangeLog,v 1.19 2012/11/20 00:06:33 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/ChangeLog,v 1.20 2012/12/12 18:23:10 bicatali Exp $
+
+*armadillo-3.6.0 (12 Dec 2012)
+
+ 12 Dec 2012; Sébastien Fabbro <bicatali@gentoo.org> +armadillo-3.6.0.ebuild,
+ -armadillo-3.4.3.ebuild, armadillo-3.4.4.ebuild:
+ Version bump. Removed atlas flag temporarily for later integration from the
+ science overlay
*armadillo-3.4.4 (20 Nov 2012)
diff --git a/sci-libs/armadillo/armadillo-3.4.4.ebuild b/sci-libs/armadillo/armadillo-3.4.4.ebuild
index 7d0d6d879738..53b65df7879c 100644
--- a/sci-libs/armadillo/armadillo-3.4.4.ebuild
+++ b/sci-libs/armadillo/armadillo-3.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/armadillo-3.4.4.ebuild,v 1.1 2012/11/20 00:06:33 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/armadillo-3.4.4.ebuild,v 1.2 2012/12/12 18:23:10 bicatali Exp $
EAPI=4
@@ -15,11 +15,10 @@ SRC_URI="mirror://sourceforge/arma/${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="atlas blas doc examples lapack"
+IUSE="blas doc examples lapack"
RDEPEND="
dev-libs/boost
- atlas? ( sci-libs/lapack-atlas )
blas? ( virtual/blas )
lapack? ( virtual/lapack )"
@@ -45,16 +44,6 @@ src_configure() {
-DLAPACK_LIBRARIES="$(pkg-config --libs lapack)"
)
fi
- if use atlas; then
- mycmakeargs=(
- -DARMA_USE_ATLAS=ON
- -DCBLAS_FOUND=ON
- -DCLAPACK_FOUND=ON
- -DATLAS_INCLUDE_DIR="${EPREFIX}/usr/include/atlas/"
- -DCBLAS_LIBRARIES="$(pkg-config --libs cblas)"
- -DCLAPACK_LIBRARIES="-L${EPREFIX}/usr/lib64/lapack/atlas -llapack"
- )
- fi
cmake-utils_src_configure
}
diff --git a/sci-libs/armadillo/armadillo-3.4.3.ebuild b/sci-libs/armadillo/armadillo-3.6.0.ebuild
index d12667913c76..c927983935e8 100644
--- a/sci-libs/armadillo/armadillo-3.4.3.ebuild
+++ b/sci-libs/armadillo/armadillo-3.6.0.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/armadillo-3.4.3.ebuild,v 1.2 2012/11/10 09:54:29 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/armadillo-3.6.0.ebuild,v 1.1 2012/12/12 18:23:10 bicatali Exp $
EAPI=4
CMAKE_IN_SOURCE_BUILD=1
-inherit cmake-utils
+inherit cmake-utils toolchain-funcs
DESCRIPTION="Streamlined C++ linear algebra library"
HOMEPAGE="http://arma.sourceforge.net/"
@@ -15,14 +15,12 @@ SRC_URI="mirror://sourceforge/arma/${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="atlas blas examples lapack"
+IUSE="blas doc examples lapack"
RDEPEND="
dev-libs/boost
- atlas? ( sci-libs/lapack-atlas )
blas? ( virtual/blas )
lapack? ( virtual/lapack )"
-
DEPEND="${DEPEND}
virtual/pkgconfig"
@@ -36,23 +34,13 @@ src_configure() {
if use blas; then
mycmakeargs+=(
-DBLAS_FOUND=ON
- -DBLAS_LIBRARIES="$(pkg-config --libs blas)"
+ -DBLAS_LIBRARIES="$($(tc-getPKG_CONFIG) --libs blas)"
)
fi
if use lapack; then
mycmakeargs+=(
-DLAPACK_FOUND=ON
- -DLAPACK_LIBRARIES="$(pkg-config --libs lapack)"
- )
- fi
- if use atlas; then
- mycmakeargs=(
- -DARMA_USE_ATLAS=ON
- -DCBLAS_FOUND=ON
- -DCLAPACK_FOUND=ON
- -DATLAS_INCLUDE_DIR="${EPREFIX}/usr/include/atlas/"
- -DCBLAS_LIBRARIES="$(pkg-config --libs cblas)"
- -DCLAPACK_LIBRARIES="-L${EPREFIX}/usr/lib64/lapack/atlas -llapack"
+ -DLAPACK_LIBRARIES="$($(tc-getPKG_CONFIG) --libs lapack)"
)
fi
cmake-utils_src_configure
@@ -60,8 +48,8 @@ src_configure() {
src_install() {
cmake-utils_src_install
- dodoc README.txt *pdf
- dohtml *html
+ dodoc README.txt
+ use doc && dodoc *pdf && dohtml *html
if use examples; then
insinto /usr/share/doc/${PF}
doins -r examples