summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-07-18 01:38:06 +0000
committerJustin Lecher <jlec@gentoo.org>2011-07-18 01:38:06 +0000
commitca1fed0918e23d15d057f0e4a1de9aa94ccbe9a3 (patch)
tree04f24090de4316dbe853f24b165c1de51b70274a /sci-libs/armadillo/armadillo-2.0.2.ebuild
parentStable for ppc64; bug #371169 (diff)
downloadgentoo-2-ca1fed0918e23d15d057f0e4a1de9aa94ccbe9a3.tar.gz
gentoo-2-ca1fed0918e23d15d057f0e4a1de9aa94ccbe9a3.tar.bz2
gentoo-2-ca1fed0918e23d15d057f0e4a1de9aa94ccbe9a3.zip
Version Bump, #373715
(Portage version: 2.2.0_alpha45/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/armadillo/armadillo-2.0.2.ebuild')
-rw-r--r--sci-libs/armadillo/armadillo-2.0.2.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/sci-libs/armadillo/armadillo-2.0.2.ebuild b/sci-libs/armadillo/armadillo-2.0.2.ebuild
new file mode 100644
index 000000000000..669793bb75a9
--- /dev/null
+++ b/sci-libs/armadillo/armadillo-2.0.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/armadillo-2.0.2.ebuild,v 1.1 2011/07/18 01:38:06 jlec Exp $
+
+EAPI=3
+
+CMAKE_IN_SOURCE_BUILD=1
+
+inherit cmake-utils
+
+DESCRIPTION="Streamlined C++ linear algebra library"
+HOMEPAGE="http://arma.sourceforge.net/"
+SRC_URI="mirror://sourceforge/arma/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="atlas blas doc lapack"
+
+RDEPEND="
+ >=dev-libs/boost-1.34
+ atlas? ( sci-libs/lapack-atlas )
+ blas? ( virtual/blas )
+ lapack? ( virtual/lapack )"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ # avoid the automagic cmake macros
+ sed -i -e '/ARMA_Find/d' CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=()
+ if use blas; then
+ mycmakeargs+=(
+ -DBLAS_FOUND=ON
+ -DBLAS_LIBRARIES="$(pkg-config --libs blas)"
+ )
+ fi
+ if use lapack; then
+ mycmakeargs+=(
+ -DLAPACK_FOUND=ON
+ -DLAPACK_LIBRARIES="$(pkg-config --libs lapack)"
+ )
+ fi
+ if use atlas; then
+ mycmakeargs=(
+ -DCBLAS_FOUND=ON
+ -DCLAPACK_FOUND=ON
+ -DATLAS_INCLUDE_DIR="${EPREFIX}/usr/include/atlas/"
+ -DCBLAS_LIBRARIES="$(pkg-config --libs cblas)"
+ -DCLAPACK_LIBRARIES="-L${EPREFIX}/usr/lib64/lapack/atlas -llapack"
+ )
+ fi
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc docs/*pdf
+}